aboutsummaryrefslogtreecommitdiff
path: root/astro/wmmoonclock
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>1999-03-14 11:38:21 +0000
committerKris Kennaway <kris@FreeBSD.org>1999-03-14 11:38:21 +0000
commit992950c38ecd666374041de4c6db4c60c0bcd362 (patch)
treebbac1d7f4463b746891bc3c292647c082d7beb3c /astro/wmmoonclock
parentae7ebd04a25f6fec150d0dfb7a7ad6b5e1681237 (diff)
downloadports-992950c38ecd666374041de4c6db4c60c0bcd362.tar.gz
ports-992950c38ecd666374041de4c6db4c60c0bcd362.zip
This is a WindowMaker dockapp which displays the phase of the moon,
plus assorted astronomical data (rise/set times, orbital elements, etc). PR: 9906
Notes
Notes: svn path=/head/; revision=17174
Diffstat (limited to 'astro/wmmoonclock')
-rw-r--r--astro/wmmoonclock/Makefile31
-rw-r--r--astro/wmmoonclock/distinfo1
-rw-r--r--astro/wmmoonclock/files/patch-aa17
-rw-r--r--astro/wmmoonclock/pkg-comment1
-rw-r--r--astro/wmmoonclock/pkg-descr6
-rw-r--r--astro/wmmoonclock/pkg-plist2
6 files changed, 58 insertions, 0 deletions
diff --git a/astro/wmmoonclock/Makefile b/astro/wmmoonclock/Makefile
new file mode 100644
index 000000000000..6ca3164f9b89
--- /dev/null
+++ b/astro/wmmoonclock/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: wmMoonClock
+# Version required: 1.24
+# Date created: 14 March 1999
+# Whom: Kris Kennaway <kkennawa@physics.adelaide.edu.au>
+#
+# $Id$
+#
+
+DISTNAME= wmMoonClock-1.24
+CATEGORIES= astro windowmaker
+MASTER_SITES= ftp://leadbelly.lanl.gov/pub/mgh/
+
+MAINTAINER= kris@FreeBSD.ORG
+
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm/
+
+WRKSRC= ${WRKDIR}/${PKGNAME}/wmMoonClock
+
+USE_X_PREFIX= yes
+USE_XLIB= yes
+USE_GMAKE= yes
+
+ALL_TARGET= clean all
+
+MAN1= wmmoonclock.1
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/wmMoonClock.1 ${PREFIX}/share/man/man1/wmmoonclock.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/wmMoonClock ${PREFIX}/bin/wmmoonclock
+
+.include <bsd.port.mk>
diff --git a/astro/wmmoonclock/distinfo b/astro/wmmoonclock/distinfo
new file mode 100644
index 000000000000..4cd3fd7a735f
--- /dev/null
+++ b/astro/wmmoonclock/distinfo
@@ -0,0 +1 @@
+MD5 (wmMoonClock-1.24.tar.gz) = 3b52336e996c1d84efa393819d73db71
diff --git a/astro/wmmoonclock/files/patch-aa b/astro/wmmoonclock/files/patch-aa
new file mode 100644
index 000000000000..4d414b0501e4
--- /dev/null
+++ b/astro/wmmoonclock/files/patch-aa
@@ -0,0 +1,17 @@
+*** Makefile.orig Fri Jan 8 10:01:25 1999
+--- Makefile Thu Feb 4 23:29:11 1999
+***************
+*** 1,6 ****
+! CC = gcc
+! CFLAGS = -O2
+! INCDIR = -I/usr/X11R6/include/X11
+ DESTDIR= /usr/X11R6
+ LIBDIR = -L/usr/X11R6/lib
+
+--- 1,6 ----
+! CC ?= gcc
+! CFLAGS ?= -O2
+! INCDIR = -I/usr/X11R6/share/include
+ DESTDIR= /usr/X11R6
+ LIBDIR = -L/usr/X11R6/lib
+
diff --git a/astro/wmmoonclock/pkg-comment b/astro/wmmoonclock/pkg-comment
new file mode 100644
index 000000000000..1e482dcdabdd
--- /dev/null
+++ b/astro/wmmoonclock/pkg-comment
@@ -0,0 +1 @@
+Displays the phase of the moon, plus orbital data.
diff --git a/astro/wmmoonclock/pkg-descr b/astro/wmmoonclock/pkg-descr
new file mode 100644
index 000000000000..d4d01e47e199
--- /dev/null
+++ b/astro/wmmoonclock/pkg-descr
@@ -0,0 +1,6 @@
+This is a WindowMaker dockapp which displays a graphical representation of
+the phase of the moon, plus additional astronomical data such as
+rise/set times, orbital data, orbital elements, etc (if you click on the
+image multiple times).
+
+Probably most of the data is not that useful, but what the heck :)
diff --git a/astro/wmmoonclock/pkg-plist b/astro/wmmoonclock/pkg-plist
new file mode 100644
index 000000000000..6d7ec9aa3d90
--- /dev/null
+++ b/astro/wmmoonclock/pkg-plist
@@ -0,0 +1,2 @@
+bin/wmmoonclock
+