aboutsummaryrefslogtreecommitdiff
path: root/astro/wmsolar/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-15 23:31:27 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-15 23:31:27 +0000
commit379a48272e2a346f1e8f832167994a1c8051c1cf (patch)
tree56a566c049018822cd83b481f0ff0d83812d6453 /astro/wmsolar/Makefile
parentc93e2468f6a42e35bf3889e70926a9ff6ab2bad0 (diff)
Notes
Diffstat (limited to 'astro/wmsolar/Makefile')
-rw-r--r--astro/wmsolar/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/astro/wmsolar/Makefile b/astro/wmsolar/Makefile
new file mode 100644
index 000000000000..2ca16e642381
--- /dev/null
+++ b/astro/wmsolar/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: wmsolar
+# Date created: Tue Jan 15 17:28:49 EST 2002
+# Whom: pat
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmsolar
+PORTVERSION= 1.0
+CATEGORIES= astro windowmaker
+MASTER_SITES= http://www.inxsoft.net/wmsolar/
+
+MAINTAINER= pat@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/wmSolar
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_GMAKE= yes
+
+pre-patch:
+ @${PERL} -pi.orig -e 's|values.h|float.h|; s|MAXDOUBLE|DBL_MAX|g' \
+ ${WRKSRC}/wmSolar.c
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/wmSolar ${PREFIX}/bin
+
+.include <bsd.port.mk>