aboutsummaryrefslogtreecommitdiff
path: root/astro/wmspaceweather
diff options
context:
space:
mode:
authorSoeren Straarup <xride@FreeBSD.org>2020-12-21 20:27:10 +0000
committerSoeren Straarup <xride@FreeBSD.org>2020-12-21 20:27:10 +0000
commit1b412737690daa78ae707a694bb5af2cdcd42256 (patch)
tree7861ee67f9be61042ac834b87efdf95948ae6d26 /astro/wmspaceweather
parent1f452b5066fc1ba12b730a926ec27c0263220848 (diff)
downloadports-1b412737690daa78ae707a694bb5af2cdcd42256.tar.gz
ports-1b412737690daa78ae707a694bb5af2cdcd42256.zip
Fix build error.
Update URL's used to fetch runtime data from. Reported by: pkg-fallout@FreeBSD.ORG
Notes
Notes: svn path=/head/; revision=558858
Diffstat (limited to 'astro/wmspaceweather')
-rw-r--r--astro/wmspaceweather/Makefile3
-rw-r--r--astro/wmspaceweather/files/patch-GetKp37
-rw-r--r--astro/wmspaceweather/files/patch-wmSpaceWeather.c4
-rw-r--r--astro/wmspaceweather/files/patch-wmgeneral.c10
-rw-r--r--astro/wmspaceweather/files/patch-wmgeneral.h11
5 files changed, 56 insertions, 9 deletions
diff --git a/astro/wmspaceweather/Makefile b/astro/wmspaceweather/Makefile
index d1070fb28c2a..5c410df42e79 100644
--- a/astro/wmspaceweather/Makefile
+++ b/astro/wmspaceweather/Makefile
@@ -16,9 +16,10 @@ LICENSE= GPLv2
RUN_DEPENDS= p5-Time-modules>=0:devel/p5-Time-modules
+USES= shebangfix xorg
+
WRKSRC= ${WRKDIR}/${DISTNAME}/wmSpaceWeather
-USES= shebangfix xorg
SHEBANG_FILES= GetKp
USE_XORG= x11 xext xpm
ALL_TARGET= clean all
diff --git a/astro/wmspaceweather/files/patch-GetKp b/astro/wmspaceweather/files/patch-GetKp
index e65e1700318d..c57dd956eece 100644
--- a/astro/wmspaceweather/files/patch-GetKp
+++ b/astro/wmspaceweather/files/patch-GetKp
@@ -1,6 +1,6 @@
---- GetKp.orig 1999-02-12 05:42:01 UTC
+--- GetKp.orig 2020-12-21 20:19:53 UTC
+++ GetKp
-@@ -5,7 +5,7 @@
+@@ -5,21 +5,21 @@
#
@@ -9,21 +9,46 @@
($Year, $Month, $Day) = &year_month_day();
-@@ -19,7 +19,7 @@
+
+- if (-e "/tmp/DGD.txt"){
+- unlink("/tmp/DGD.txt");
++ if (-e "/tmp/daily-geomagnetic-indices.txt"){
++ unlink("/tmp/daily-geomagnetic-indices.txt");
+ }
+
+- if (-e "/tmp/curind.txt"){
+- unlink("/tmp/curind.txt");
++ if (-e "/tmp/current-space-weather-indices.txt"){
++ unlink("/tmp/current-space-weather-indices.txt");
}
- $grabcmd = "cd /tmp; wget --passive-ftp --tries 2 -q ftp://www.sec.noaa.gov/pub/indices/DGD.txt";
-+ $grabcmd = "cd /tmp; fetch -q ftp://ftp.sec.noaa.gov/pub/indices/DGD.txt";
++ $grabcmd = "cd /tmp; fetch -q https://services.swpc.noaa.gov/text/daily-geomagnetic-indices.txt";
system "$grabcmd";
-@@ -68,7 +68,7 @@
+@@ -37,7 +37,7 @@
+ $Kp{190001018} = 999;
+
+
+- open(TmpFile, "/tmp/DGD.txt");
++ open(TmpFile, "/tmp/daily-geomagnetic-indices.txt");
+ while (<TmpFile>){
+ chop;
+ if ($_ =~ /^\d{4} \d{2} \d{2}\s*\d*/ ){
+@@ -68,12 +68,12 @@
#
# Add in very latest stuff
#
- $grabcmd = "cd /tmp; wget --passive-ftp --tries 2 -q ftp://www.sec.noaa.gov/pub/latest/curind.txt";
-+ $grabcmd = "cd /tmp; fetch -q ftp://ftp.sec.noaa.gov/pub/latest/curind.txt";
++ $grabcmd = "cd /tmp; fetch -q https://services.swpc.noaa.gov/text/current-space-weather-indices.txt";
system "$grabcmd";
%lmonstr = ( "Jan", 1, "Feb", 2, "Mar", 3, "Apr", 4, "May", 5, "Jun", 6, "Jul", 7, "Aug", 8, "Sep", 9, "Oct", 10, "Nov", 11, "Dec", 12);
+ @lval = ($lyear, $lmonstr{$lmon}, $ldom);
+- open(TmpFile, "/tmp/curind.txt");
++ open(TmpFile, "/tmp/current-space-weather-indices.txt");
+ while (<TmpFile>){
+ chop;
+ if ($_ =~ /^:Geomagnetic_Values: (\d{4}) (.*) (\d{1,2})/){
diff --git a/astro/wmspaceweather/files/patch-wmSpaceWeather.c b/astro/wmspaceweather/files/patch-wmSpaceWeather.c
index 6f22d3ac4693..7793305d9f2a 100644
--- a/astro/wmspaceweather/files/patch-wmSpaceWeather.c
+++ b/astro/wmspaceweather/files/patch-wmSpaceWeather.c
@@ -9,7 +9,7 @@
int height, UpToDate, LEDOn;
double UT, TU, TU2, TU3, T0, gmst, hour24();
-@@ -126,6 +126,7 @@ int Kp[8] = { -1, -1, -1, -1, -1, -1,
+@@ -126,6 +126,7 @@ int Kp[8] = { -1, -1, -1, -1, -1, -1, -1, -1 };
double E1, E2, P1, P2, P3;
char Xray[10], digit[2];
FILE *fp;
@@ -67,7 +67,7 @@
if (!UpToDate){
-@@ -560,7 +561,7 @@ void ParseCMDLine(int argc, char *argv[]
+@@ -560,7 +561,7 @@ void ParseCMDLine(int argc, char *argv[]) {
} else if ((!strcmp(argv[i], "-url"))||(!strcmp(argv[i], "-u"))){
diff --git a/astro/wmspaceweather/files/patch-wmgeneral.c b/astro/wmspaceweather/files/patch-wmgeneral.c
new file mode 100644
index 000000000000..8d8fb5b03791
--- /dev/null
+++ b/astro/wmspaceweather/files/patch-wmgeneral.c
@@ -0,0 +1,10 @@
+--- ../wmgeneral/wmgeneral.c.orig 2020-12-21 11:20:47.205960000 -0600
++++ ../wmgeneral/wmgeneral.c 2020-12-21 11:21:15.735441000 -0600
+@@ -51,6 +51,7 @@
+ XpmIcon wmgen;
+ Pixmap pixmask;
+
++Display *display;
+ /*****************/
+ /* Mouse Regions */
+ /*****************/
diff --git a/astro/wmspaceweather/files/patch-wmgeneral.h b/astro/wmspaceweather/files/patch-wmgeneral.h
new file mode 100644
index 000000000000..f8c8f333f96b
--- /dev/null
+++ b/astro/wmspaceweather/files/patch-wmgeneral.h
@@ -0,0 +1,11 @@
+--- ../wmgeneral/wmgeneral.h.orig 2020-12-21 11:21:23.324171000 -0600
++++ ../wmgeneral/wmgeneral.h 2020-12-21 11:21:41.194688000 -0600
+@@ -28,7 +28,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */