aboutsummaryrefslogtreecommitdiff
path: root/astro/xearth/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-10-15 12:03:40 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-10-15 12:03:40 +0000
commit7e7521ea7c3070da13c8bd7850971b5f47b864d2 (patch)
tree92b43fb6e98b874d306e86612d17149bb52ae95f /astro/xearth/Makefile
parentc67984a0647116bbf608c0d9f5226a7c328e99a7 (diff)
Notes
Diffstat (limited to 'astro/xearth/Makefile')
-rw-r--r--astro/xearth/Makefile32
1 files changed, 14 insertions, 18 deletions
diff --git a/astro/xearth/Makefile b/astro/xearth/Makefile
index 0daf36c39f7c..3e90d1c6fa0f 100644
--- a/astro/xearth/Makefile
+++ b/astro/xearth/Makefile
@@ -1,34 +1,30 @@
-# New ports collection makefile for: xearth
-# Date created: 29 October 1994
-# Whom: piero
-#
+# Created by: Piero Serini <piero@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xearth
-PORTVERSION= 1.1
-PORTREVISION= 2
+PORTVERSION= 1.2
CATEGORIES= astro geography
-MASTER_SITES= XCONTRIB/applications \
- http://seis.bris.ac.uk/~mexas/ \
- LOCAL/simon
+MASTER_SITES= http://seis.bris.ac.uk/~mexas/ \
+ LOCAL/madpilot/xearth
MAINTAINER= mexas@bristol.ac.uk
COMMENT= Set the root window to the image of earth
-BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake
-
USE_XORG= x11 xext sm ice xt
+USE_XZ= yes
MAN1= xearth.1
+PLIST_FILES= bin/xearth \
+ lib/X11/xearth/freebsd.committers.markers \
+ lib/X11/xearth/freebsd.ftp.markers \
+ lib/X11/xearth/freebsd.submitters.markers
+PLIST_DIRS= lib/X11/xearth
-pre-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${XMKMF}
-
-post-install:
- @${MKDIR} ${PREFIX}/lib/X11/xearth
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/xearth ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/xearth.man ${MANPREFIX}/man/man1/xearth.1
+ @${MKDIR} ${PREFIX}/lib/X11/xearth
# Copy the list of FreeBSD sites & committers locations
-.for marker in freebsd.committers.markers freebsd.submitters.markers freebsd.ftp.markers
+.for marker in freebsd.committers.markers freebsd.ftp.markers freebsd.submitters.markers
@${INSTALL_DATA} ${FILESDIR}/${marker} ${PREFIX}/lib/X11/xearth
.endfor