aboutsummaryrefslogtreecommitdiff
path: root/astro/xephem
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2019-03-25 16:00:16 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2019-03-25 16:00:16 +0000
commit66d7adf21262d51f8ec4738ec33b03ed7b91680d (patch)
tree638bf1f89848e8312eab6c5deeff2616df8a9ee6 /astro/xephem
parentfe2ab9b0456a0e72fce318e13ec2e5e6dd5eaa57 (diff)
downloadports-66d7adf21262d51f8ec4738ec33b03ed7b91680d.tar.gz
ports-66d7adf21262d51f8ec4738ec33b03ed7b91680d.zip
Notes
Diffstat (limited to 'astro/xephem')
-rw-r--r--astro/xephem/Makefile2
-rw-r--r--astro/xephem/files/patch-auxil_mpcorb2edb.pl9
2 files changed, 10 insertions, 1 deletions
diff --git a/astro/xephem/Makefile b/astro/xephem/Makefile
index 38c274e0c0d6..c57aa1272cc7 100644
--- a/astro/xephem/Makefile
+++ b/astro/xephem/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xephem
PORTVERSION= 3.7.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= astro
MASTER_SITES= http://www.clearskyinstitute.com/xephem/
diff --git a/astro/xephem/files/patch-auxil_mpcorb2edb.pl b/astro/xephem/files/patch-auxil_mpcorb2edb.pl
index 7a1ff50bb929..f131d5cb2275 100644
--- a/astro/xephem/files/patch-auxil_mpcorb2edb.pl
+++ b/astro/xephem/files/patch-auxil_mpcorb2edb.pl
@@ -9,3 +9,12 @@
my $MPCFTPDIR = "/iau/MPCORB";
my $MPCFILE = "MPCORB.DAT";
my $MPCZIPFILE = "MPCORB.DAT.gz";
+@@ -247,7 +247,7 @@ sub fetch
+ {
+ # transfer
+ print "Getting $MPCFTPDIR/$MPCZIPFILE from $MPCSITE...\n";
+- $cmd = "curl -connect-timeout 10 -s -u 'anonymous:xephem\@clearskyinstitute.com' $MPCSITE/$MPCFTPDIR/$MPCZIPFILE > $MPCZIPFILE";
++ $cmd = "curl --connect-timeout 10 -s -u 'anonymous:xephem\@clearskyinstitute.com' $MPCSITE/$MPCFTPDIR/$MPCZIPFILE > $MPCZIPFILE";
+ print "$cmd\n";
+ !system "$cmd" or exit(1);
+