aboutsummaryrefslogtreecommitdiff
path: root/astro/xephem
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2009-07-27 23:33:25 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2009-07-27 23:33:25 +0000
commitf9d4b890e554b238613c313b4bc7b90c3f36352a (patch)
treeef560c4fa395cdc3188badcabca9b85999753108 /astro/xephem
parent01ee857c1a802e7d9b0a933963a3c55151b1512c (diff)
downloadports-f9d4b890e554b238613c313b4bc7b90c3f36352a.tar.gz
ports-f9d4b890e554b238613c313b4bc7b90c3f36352a.zip
Notes
Diffstat (limited to 'astro/xephem')
-rw-r--r--astro/xephem/Makefile3
-rw-r--r--astro/xephem/distinfo6
-rw-r--r--astro/xephem/files/patch-Makefile38
3 files changed, 30 insertions, 17 deletions
diff --git a/astro/xephem/Makefile b/astro/xephem/Makefile
index 7e799529350d..a098abff8128 100644
--- a/astro/xephem/Makefile
+++ b/astro/xephem/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xephem
-PORTVERSION= 3.7.3
-PORTREVISION= 2
+PORTVERSION= 3.7.4
CATEGORIES= astro
MASTER_SITES= # http://www.clearskyinstitute.com/xephem/
diff --git a/astro/xephem/distinfo b/astro/xephem/distinfo
index 99e5a438afaa..c3733d0bac31 100644
--- a/astro/xephem/distinfo
+++ b/astro/xephem/distinfo
@@ -1,3 +1,3 @@
-MD5 (xephem-3.7.3.tar.gz) = aa2330dad58403020cde12b5d228e499
-SHA256 (xephem-3.7.3.tar.gz) = 450fa05a36ce4c8ceca80bd5a003c060bc4d9e07719aebcb13565b563b90e337
-SIZE (xephem-3.7.3.tar.gz) = 22148450
+MD5 (xephem-3.7.4.tar.gz) = 4e9290609f36df469a2ba5a1b4fffd46
+SHA256 (xephem-3.7.4.tar.gz) = 423b044d4a6433c62e493b891a7eb8aa332bc86d113069347945e4331d322726
+SIZE (xephem-3.7.4.tar.gz) = 22154575
diff --git a/astro/xephem/files/patch-Makefile b/astro/xephem/files/patch-Makefile
index 673b479aa707..425aabda6e13 100644
--- a/astro/xephem/files/patch-Makefile
+++ b/astro/xephem/files/patch-Makefile
@@ -1,9 +1,9 @@
---- Makefile.orig Fri Nov 18 16:43:09 2005
-+++ Makefile Mon Dec 5 12:58:21 2005
+--- Makefile.orig 2009-07-26 16:36:37.000000000 +0000
++++ Makefile 2009-07-26 16:39:34.000000000 +0000
@@ -10,9 +10,9 @@
- # back here and compile and link all the *.c files into one executable, xephem.
+ # one executable, xephem.
- # -I and -L flags to find required supporting XEphem libraries
+ # These -I and -L flags point to the supporting XEphem libraries
-LIBINC = -I../../libastro -I../../libip -I../../liblilxml -I../../libjpegd -I../../libpng -I../../libz
-LIBLNK = -L../../libastro -L../../libip -L../../liblilxml -L../../libjpegd -L../../libpng -L../../libz
-LIBLIB = -lastro -lip -llilxml -ljpegd -lpng -lz
@@ -13,16 +13,30 @@
# MOTIFI is the directory containing the Xm directory of include files.
# MOTIFL is the directory containing the libXm.a library.
-@@ -31,7 +31,7 @@
+@@ -24,18 +24,18 @@
+ MOTIFL = $(MOTIF)
+ endif
+ ifndef MOTIFI
+-MOTIFI = /usr/X11R6/include
++MOTIFI = %%LOCALBASE%%/include
+ endif
+ ifndef MOTIFL
+-MOTIFL = /usr/X11R6/lib
++MOTIFL = %%LOCALBASE%%/lib
+ endif
# for linux and Apple OS X
+ # some systems now use just /usr/X11 (not /usr/X11R6)
CC = gcc
--CLDFLAGS = -g
-+#CLDFLAGS = -g
- CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I$(MOTIFI) -I/usr/X11R6/include
- LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L/usr/X11R6/lib
- XLIBS = $(MOTIFL)/libXm.a -lXp -lXt -lXext -lSM -lICE -lXmu -lX11
-@@ -181,10 +181,7 @@
+ CLDFLAGS = -g
+-CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I$(MOTIFI) -I/usr/X11R6/include
+-LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L/usr/X11R6/lib
++CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I$(MOTIFI) -I%%LOCALBASE%%/include
++LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L%%LOCALBASE%%/lib
+ XLIBS = $(MOTIFL)/libXm.a -lXp -lXt -lXext -lXmu -lX11
+ LIBS = $(XLIBS) $(LIBLIB) -lm
+
+@@ -189,10 +189,7 @@
libs:
cd ../../libastro; make
cd ../../libip; make
@@ -32,4 +46,4 @@
- cd ../../libz; make
clean:
- touch x.o
+ rm -fr *.o ../../lib*/*.[ao]