aboutsummaryrefslogtreecommitdiff
path: root/astro/xglobe
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-25 22:29:56 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-25 22:29:56 +0000
commit9a739d2a13a402d8bedeb5f933f28ce386e95c82 (patch)
tree429b94c69eaeec222177d46f393e4d0fb9aa3b15 /astro/xglobe
parent7b98df9f62f6e510dfd30daf5ba4851745b7cb25 (diff)
downloadports-9a739d2a13a402d8bedeb5f933f28ce386e95c82.tar.gz
ports-9a739d2a13a402d8bedeb5f933f28ce386e95c82.zip
Notes
Diffstat (limited to 'astro/xglobe')
-rw-r--r--astro/xglobe/Makefile6
-rw-r--r--astro/xglobe/files/patch-aa11
-rw-r--r--astro/xglobe/files/patch-desktopwidget.cpp10
-rw-r--r--astro/xglobe/files/patch-random15
-rw-r--r--astro/xglobe/files/patch-renderer.cpp26
-rw-r--r--astro/xglobe/pkg-descr2
6 files changed, 46 insertions, 24 deletions
diff --git a/astro/xglobe/Makefile b/astro/xglobe/Makefile
index f29b49a4ec41..6279d01b289e 100644
--- a/astro/xglobe/Makefile
+++ b/astro/xglobe/Makefile
@@ -7,14 +7,16 @@
PORTNAME= xglobe
PORTVERSION= 0.5
+PORTREVISION= 1
CATEGORIES= astro
-MASTER_SITES= http://www.uni-karlsruhe.de/~uddn/xglobe/
+MASTER_SITES= http://www.cs.unc.edu/~scheuerm/xglobe/
MAINTAINER= kris@FreeBSD.org
-USE_QT_VER= 1
+USE_QT_VER= 3
USE_X_PREFIX= yes
USE_GMAKE= yes
+MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
do-install:
@${MKDIR} ${PREFIX}/share/xglobe/
diff --git a/astro/xglobe/files/patch-aa b/astro/xglobe/files/patch-aa
index 66a0983403d4..941b80f4d3db 100644
--- a/astro/xglobe/files/patch-aa
+++ b/astro/xglobe/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.orig Mon Jul 19 05:56:27 1999
-+++ Makefile Sun May 5 01:53:17 2002
+--- Makefile.orig Mon Jul 19 14:56:27 1999
++++ Makefile Sat Jan 25 14:51:03 2003
@@ -4,29 +4,30 @@
####### Installation directory
@@ -15,7 +15,7 @@
-X11_INCLUDE_DIR = /usr/X11R6/include
-QT_INCLUDE_DIR = $(QTDIR)/include
+X11_INCLUDE_DIR = $(X11BASE)/include
-+QT_INCLUDE_DIR = $(X11BASE)/include/X11/qt1
++QT_INCLUDE_DIR = $(X11BASE)/include/
-QT_LIB_DIR = $(QTDIR)/lib
-X11_LIB_DIR = /usr/X11R6/lib
@@ -27,11 +27,10 @@
-CPP = g++
-LINK = g++
--MOC = moc
+CXX ?= c++
+CPP = ${CXX}
+LINK = ${CXX}
-+MOC = moc1
+ MOC = moc
INSTALL = install
####### compile and link options
@@ -46,7 +45,7 @@
LIB_DIRS = -L$(QT_LIB_DIR) -L$(X11_LIB_DIR)
-LIBS = -lX11 -lqt -lm
-+LIBS = -lX11 -lqt1 -lm
++LIBS = -lX11 -lqt-mt -lm ${PTHREAD_LIBS}
# If you want to use the QImageIO lib (to support jpg and png maps) use the
# next two lines and comment the one above
#WITH_QIMGIO = -DWITH_QIMAGEIO
diff --git a/astro/xglobe/files/patch-desktopwidget.cpp b/astro/xglobe/files/patch-desktopwidget.cpp
new file mode 100644
index 000000000000..b08ea53549fa
--- /dev/null
+++ b/astro/xglobe/files/patch-desktopwidget.cpp
@@ -0,0 +1,10 @@
+--- desktopwidget.cpp.orig Sun Jan 26 09:35:35 2003
++++ desktopwidget.cpp Sun Jan 26 09:38:52 2003
+@@ -18,6 +18,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "desktopwidget.h"
+
+ DesktopWidget::DesktopWidget(QWidget *parent, const char *name)
diff --git a/astro/xglobe/files/patch-random b/astro/xglobe/files/patch-random
index ba9f41cf8b9e..563286db5d4c 100644
--- a/astro/xglobe/files/patch-random
+++ b/astro/xglobe/files/patch-random
@@ -11,21 +11,6 @@
}
/* ------------------------------------------------------------------------*/
---- renderer.cpp.orig Sat Feb 24 10:12:53 2001
-+++ renderer.cpp Sat Feb 24 10:13:04 2001
-@@ -1562,9 +1562,9 @@
-
- for(int i=0; i<numstars; i++)
- {
-- x = rand() % renderedImage->width();
-- y = rand() % renderedImage->height();
-- brightness = 150+ (rand() % 106);
-+ x = random() % renderedImage->width();
-+ y = random() % renderedImage->height();
-+ brightness = 150+ (random() % 106);
- p = (unsigned int *)renderedImage->scanLine(y);
- p += x;
- *p = qRgb(brightness, brightness, brightness);
--- main.cpp.orig Tue Jul 13 10:32:55 1999
+++ main.cpp Sat Feb 24 10:14:56 2001
@@ -24,6 +24,7 @@
diff --git a/astro/xglobe/files/patch-renderer.cpp b/astro/xglobe/files/patch-renderer.cpp
new file mode 100644
index 000000000000..ae0ec071695c
--- /dev/null
+++ b/astro/xglobe/files/patch-renderer.cpp
@@ -0,0 +1,26 @@
+--- renderer.cpp.orig Mon Dec 6 17:13:35 1999
++++ renderer.cpp Sun Jan 26 09:32:22 2003
+@@ -1483,8 +1483,8 @@
+ labelstring.sprintf("%s, %s %d. %d, %d:%02d %s\n"
+ "View pos %2.2f° %c %2.2f° %c\n"
+ "Sun pos %2.2f° %c %2.2f° %c",
+- dt.date().dayName(dt.date().dayOfWeek()),
+- dt.date().monthName(dt.date().month()),
++ dt.date().dayName(dt.date().dayOfWeek()).latin1(),
++ dt.date().monthName(dt.date().month()).latin1(),
+ dt.date().day(), dt.date().year(),
+ dt.time().hour(), dt.time().minute(),
+ tzname[tm->tm_isdst],
+@@ -1562,9 +1562,9 @@
+
+ for(int i=0; i<numstars; i++)
+ {
+- x = rand() % renderedImage->width();
+- y = rand() % renderedImage->height();
+- brightness = 150+ (rand() % 106);
++ x = random() % renderedImage->width();
++ y = random() % renderedImage->height();
++ brightness = 150+ (random() % 106);
+ p = (unsigned int *)renderedImage->scanLine(y);
+ p += x;
+ *p = qRgb(brightness, brightness, brightness);
diff --git a/astro/xglobe/pkg-descr b/astro/xglobe/pkg-descr
index b7481b6f56a6..e15397d3c29d 100644
--- a/astro/xglobe/pkg-descr
+++ b/astro/xglobe/pkg-descr
@@ -2,4 +2,4 @@ Displays a rendered view of the earth in your root window, similar to
xearth, but instead uses a satellite image map of the earth. You can also
substitute surface maps of other planets if you're feeling cosmic.
-WWW: http://www.stud.uni-karlsruhe.de/~uddn/xglobe/
+WWW: http://www.cs.unc.edu/~scheuerm/xglobe/