aboutsummaryrefslogtreecommitdiff
path: root/astro/xworld
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2009-03-27 16:52:58 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2009-03-27 16:52:58 +0000
commitfaa0c7d979328c40040d2e1d71d8f2d94fb7636f (patch)
tree3b3b818c7bbf0b70efbdd87b034ede14d913609c /astro/xworld
parentfaeee16a36daa0e6605aa19f60a623ac2087de5c (diff)
downloadports-faa0c7d979328c40040d2e1d71d8f2d94fb7636f.tar.gz
ports-faa0c7d979328c40040d2e1d71d8f2d94fb7636f.zip
Mark MAKE_JOBS_SAFE and squash some warnings.
Notes
Notes: svn path=/head/; revision=231123
Diffstat (limited to 'astro/xworld')
-rw-r--r--astro/xworld/Makefile1
-rw-r--r--astro/xworld/files/patch-compile_world.c10
-rw-r--r--astro/xworld/files/patch-pad.c10
3 files changed, 21 insertions, 0 deletions
diff --git a/astro/xworld/Makefile b/astro/xworld/Makefile
index b22cfe4beb34..fbdfada06d8a 100644
--- a/astro/xworld/Makefile
+++ b/astro/xworld/Makefile
@@ -23,6 +23,7 @@ CONFIGURE_ENV= CAT=${CAT} \
INCLUDES="-I${LOCALBASE}/include" \
LDLIBS="-lm -L${LOCALBASE}/lib -lX11" \
MORELIBS=""
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/xworld
STRIP= #don't strip out image data on install
diff --git a/astro/xworld/files/patch-compile_world.c b/astro/xworld/files/patch-compile_world.c
new file mode 100644
index 000000000000..9c457be19215
--- /dev/null
+++ b/astro/xworld/files/patch-compile_world.c
@@ -0,0 +1,10 @@
+--- compile_world.c.orig 2009-03-27 17:51:01.000000000 +0100
++++ compile_world.c 2009-03-27 17:51:15.000000000 +0100
+@@ -33,6 +33,7 @@
+ #include <sys/types.h>
+ #include <sys/mman.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "Sphere.h"
+ #include "SphereDim.h"
+
diff --git a/astro/xworld/files/patch-pad.c b/astro/xworld/files/patch-pad.c
new file mode 100644
index 000000000000..f132d1983ae8
--- /dev/null
+++ b/astro/xworld/files/patch-pad.c
@@ -0,0 +1,10 @@
+--- pad.c.orig 2009-03-27 17:49:37.000000000 +0100
++++ pad.c 2009-03-27 17:50:01.000000000 +0100
+@@ -35,6 +35,7 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #define roundup(x, y) ((((x)+((y)-1))/(y))*(y))
+