aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-05-22 19:04:14 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-05-22 19:07:31 +0000
commit154daacaa10bc3f5931981976b83276c8b0a4668 (patch)
treee261c7781eadf1307d7097bf59d055448929fddd /astro
parentb712fce4cb82b8a3a5a4db3b2f3beddfea7a8945 (diff)
downloadports-154daacaa10bc3f5931981976b83276c8b0a4668.tar.gz
ports-154daacaa10bc3f5931981976b83276c8b0a4668.zip
astro/stellarsolrver: NEW : Astrometric Plate Solver built on Astrometry.net and SEP
- An Astrometric Plate Solver for Mac, Linux, and Windows, built on Astrometry.net and SEP (sextractor) - Meant to be an internal library for use in a program like KStars for internal plate solving on all supported operating systems - Python is not required for the library - Netpbm is not required for the library - Internal Library, so calls to external programs are not required - No Astrometry.cfg file is needed, the settings are internal to the program - Directly loads the image data into SEP and then takes the generated xy-list internally from Sextractor into astrometry.net, so there is no need to save any files. - No temporary files need to be created for solving and no WCS file needs to be created to read the solved information. Although astrometry.net does monitor for the creation of 2 files indicating that a field is solved or a cancel was made, so these are created for now. - The Index Files are still required for solving images, but the program or the user can specify the folder locations rather than putting them in the config file. WWW: https://github.com/rlancaste/stellarsolver
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/stellarsolver/Makefile21
-rw-r--r--astro/stellarsolver/distinfo3
-rw-r--r--astro/stellarsolver/files/patch-stellarsolver_stellarsolver.cpp26
-rw-r--r--astro/stellarsolver/pkg-descr20
-rw-r--r--astro/stellarsolver/pkg-plist157
6 files changed, 228 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index b3691282726a..91463556f205 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -110,6 +110,7 @@
SUBDIR += starplot
SUBDIR += stars
SUBDIR += stellarium
+ SUBDIR += stellarsolver
SUBDIR += sunclock
SUBDIR += sunwait
SUBDIR += swe
diff --git a/astro/stellarsolver/Makefile b/astro/stellarsolver/Makefile
new file mode 100644
index 000000000000..492f1313eedf
--- /dev/null
+++ b/astro/stellarsolver/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= stellarsolver
+DISTVERSION= 1.5
+CATEGORIES= astro
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Astrometric Plate Solver built on Astrometry.net and SEP
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
+ libgsl.so:math/gsl \
+ libwcs.so:astro/wcslib
+
+USES= cmake iconv ninja qt:5 pkgconfig
+USE_QT= buildtools concurrent core gui qmake_build network widgets
+USE_GITHUB= yes
+GH_ACCOUNT= rlancaste
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/astro/stellarsolver/distinfo b/astro/stellarsolver/distinfo
new file mode 100644
index 000000000000..2ae017938f58
--- /dev/null
+++ b/astro/stellarsolver/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1621530559
+SHA256 (rlancaste-stellarsolver-1.5_GH0.tar.gz) = 62ce99c066a205c9f7c5cbace1678504750ceeb99cb12bacd4e4a329c4f512bc
+SIZE (rlancaste-stellarsolver-1.5_GH0.tar.gz) = 9113711
diff --git a/astro/stellarsolver/files/patch-stellarsolver_stellarsolver.cpp b/astro/stellarsolver/files/patch-stellarsolver_stellarsolver.cpp
new file mode 100644
index 000000000000..0516e3bb9e6c
--- /dev/null
+++ b/astro/stellarsolver/files/patch-stellarsolver_stellarsolver.cpp
@@ -0,0 +1,26 @@
+--- stellarsolver/stellarsolver.cpp.orig 2020-11-15 04:11:58 UTC
++++ stellarsolver/stellarsolver.cpp
+@@ -7,6 +7,9 @@
+ */
+ #if defined(__APPLE__)
+ #include <sys/sysctl.h>
++#elif defined(__FreeBSD__)
++#include <sys/types.h>
++#include <sys/sysctl.h>
+ #elif defined(_WIN32)
+ #include "windows.h"
+ #else //Linux
+@@ -799,8 +802,12 @@ bool StellarSolver::appendStarsRAandDEC(QList<FITSImag
+ //But from what I read, getting the Available RAM is inconsistent and buggy on many systems.
+ bool StellarSolver::getAvailableRAM(double &availableRAM, double &totalRAM)
+ {
+-#if defined(Q_OS_OSX)
++#if defined(Q_OS_OSX) || defined(Q_OS_FREEBSD)
++#if defined(Q_OS_FREEBSD)
++ int mib [] = { CTL_HW, HW_REALMEM };
++#else
+ int mib [] = { CTL_HW, HW_MEMSIZE };
++#endif
+ size_t length;
+ length = sizeof(int64_t);
+ int64_t RAMcheck;
diff --git a/astro/stellarsolver/pkg-descr b/astro/stellarsolver/pkg-descr
new file mode 100644
index 000000000000..d99e375ff2f8
--- /dev/null
+++ b/astro/stellarsolver/pkg-descr
@@ -0,0 +1,20 @@
+- An Astrometric Plate Solver for Mac, Linux, and Windows, built on
+ Astrometry.net and SEP (sextractor)
+- Meant to be an internal library for use in a program like KStars for internal
+ plate solving on all supported operating systems
+- Python is not required for the library
+- Netpbm is not required for the library
+- Internal Library, so calls to external programs are not required
+- No Astrometry.cfg file is needed, the settings are internal to the program
+- Directly loads the image data into SEP and then takes the generated xy-list
+ internally from Sextractor into astrometry.net, so there is no need to save
+ any files.
+- No temporary files need to be created for solving and no WCS file needs to be
+ created to read the solved information. Although astrometry.net does monitor
+ for the creation of 2 files indicating that a field is solved or a cancel was
+ made, so these are created for now.
+- The Index Files are still required for solving images, but the program or the
+ user can specify the folder locations rather than putting them in the config
+ file.
+
+WWW: https://github.com/rlancaste/stellarsolver
diff --git a/astro/stellarsolver/pkg-plist b/astro/stellarsolver/pkg-plist
new file mode 100644
index 000000000000..9406c0248cc9
--- /dev/null
+++ b/astro/stellarsolver/pkg-plist
@@ -0,0 +1,157 @@
+include/libstellarsolver/astrometry/2mass-fits.h
+include/libstellarsolver/astrometry/2mass.h
+include/libstellarsolver/astrometry/allquads.h
+include/libstellarsolver/astrometry/an-bool.h
+include/libstellarsolver/astrometry/an-endian.h
+include/libstellarsolver/astrometry/an-opts.h
+include/libstellarsolver/astrometry/an-thread-pthreads.h
+include/libstellarsolver/astrometry/an-thread.h
+include/libstellarsolver/astrometry/anqfits.h
+include/libstellarsolver/astrometry/anwcs.h
+include/libstellarsolver/astrometry/augment-xylist.h
+include/libstellarsolver/astrometry/axyfile.h
+include/libstellarsolver/astrometry/bl-nl.h
+include/libstellarsolver/astrometry/bl-nl.inc
+include/libstellarsolver/astrometry/bl-nl.ph
+include/libstellarsolver/astrometry/bl-sort.h
+include/libstellarsolver/astrometry/bl.h
+include/libstellarsolver/astrometry/bl.inc
+include/libstellarsolver/astrometry/bl.ph
+include/libstellarsolver/astrometry/blind.h
+include/libstellarsolver/astrometry/blindutils.h
+include/libstellarsolver/astrometry/brightstars.h
+include/libstellarsolver/astrometry/bt.h
+include/libstellarsolver/astrometry/build-index.h
+include/libstellarsolver/astrometry/cairoutils.h
+include/libstellarsolver/astrometry/catalog.h
+include/libstellarsolver/astrometry/coadd.h
+include/libstellarsolver/astrometry/codefile.h
+include/libstellarsolver/astrometry/codekd.h
+include/libstellarsolver/astrometry/codetree.h
+include/libstellarsolver/astrometry/constellation-boundaries.h
+include/libstellarsolver/astrometry/constellations.h
+include/libstellarsolver/astrometry/convolve-image.h
+include/libstellarsolver/astrometry/ctmf.h
+include/libstellarsolver/astrometry/datalog.h
+include/libstellarsolver/astrometry/dimage.h
+include/libstellarsolver/astrometry/dualtree.h
+include/libstellarsolver/astrometry/dualtree_nearestneighbour.h
+include/libstellarsolver/astrometry/dualtree_rangesearch.h
+include/libstellarsolver/astrometry/eigen-math.h
+include/libstellarsolver/astrometry/engine.h
+include/libstellarsolver/astrometry/errors.h
+include/libstellarsolver/astrometry/fileutils.h
+include/libstellarsolver/astrometry/fit-wcs.h
+include/libstellarsolver/astrometry/fits-guess-scale.h
+include/libstellarsolver/astrometry/fitsbin.h
+include/libstellarsolver/astrometry/fitsfile.h
+include/libstellarsolver/astrometry/fitsioutils.h
+include/libstellarsolver/astrometry/fitstable.h
+include/libstellarsolver/astrometry/gslutils.h
+include/libstellarsolver/astrometry/hd.h
+include/libstellarsolver/astrometry/healpix-utils.h
+include/libstellarsolver/astrometry/healpix.h
+include/libstellarsolver/astrometry/hpquads.h
+include/libstellarsolver/astrometry/image2xy-files.h
+include/libstellarsolver/astrometry/image2xy.h
+include/libstellarsolver/astrometry/index.h
+include/libstellarsolver/astrometry/intmap.h
+include/libstellarsolver/astrometry/ioutils.h
+include/libstellarsolver/astrometry/kdtree.h
+include/libstellarsolver/astrometry/kdtree_fits_io.h
+include/libstellarsolver/astrometry/keywords.h
+include/libstellarsolver/astrometry/log.h
+include/libstellarsolver/astrometry/matchfile.h
+include/libstellarsolver/astrometry/matchobj.h
+include/libstellarsolver/astrometry/mathutil.h
+include/libstellarsolver/astrometry/mathutil.inc
+include/libstellarsolver/astrometry/merge-index.h
+include/libstellarsolver/astrometry/multiindex.h
+include/libstellarsolver/astrometry/new-wcs.h
+include/libstellarsolver/astrometry/ngc2000.h
+include/libstellarsolver/astrometry/ngcic-accurate.h
+include/libstellarsolver/astrometry/nomad-fits.h
+include/libstellarsolver/astrometry/nomad.h
+include/libstellarsolver/astrometry/os-features-config.h
+include/libstellarsolver/astrometry/os-features.h
+include/libstellarsolver/astrometry/permutedsort.h
+include/libstellarsolver/astrometry/plotannotations.h
+include/libstellarsolver/astrometry/plotfill.h
+include/libstellarsolver/astrometry/plotgrid.h
+include/libstellarsolver/astrometry/plothealpix.h
+include/libstellarsolver/astrometry/plotimage.h
+include/libstellarsolver/astrometry/plotindex.h
+include/libstellarsolver/astrometry/plotmatch.h
+include/libstellarsolver/astrometry/plotoutline.h
+include/libstellarsolver/astrometry/plotradec.h
+include/libstellarsolver/astrometry/plotstuff.h
+include/libstellarsolver/astrometry/plotxy.h
+include/libstellarsolver/astrometry/qfits_byteswap.h
+include/libstellarsolver/astrometry/qfits_card.h
+include/libstellarsolver/astrometry/qfits_config.h
+include/libstellarsolver/astrometry/qfits_convert.h
+include/libstellarsolver/astrometry/qfits_error.h
+include/libstellarsolver/astrometry/qfits_float.h
+include/libstellarsolver/astrometry/qfits_header.h
+include/libstellarsolver/astrometry/qfits_image.h
+include/libstellarsolver/astrometry/qfits_keywords.h
+include/libstellarsolver/astrometry/qfits_md5.h
+include/libstellarsolver/astrometry/qfits_memory.h
+include/libstellarsolver/astrometry/qfits_rw.h
+include/libstellarsolver/astrometry/qfits_std.h
+include/libstellarsolver/astrometry/qfits_table.h
+include/libstellarsolver/astrometry/qfits_time.h
+include/libstellarsolver/astrometry/qfits_tools.h
+include/libstellarsolver/astrometry/qidxfile.h
+include/libstellarsolver/astrometry/quad-builder.h
+include/libstellarsolver/astrometry/quad-utils.h
+include/libstellarsolver/astrometry/quadfile.h
+include/libstellarsolver/astrometry/rdlist.h
+include/libstellarsolver/astrometry/resample.h
+include/libstellarsolver/astrometry/resort-xylist.h
+include/libstellarsolver/astrometry/scamp-catalog.h
+include/libstellarsolver/astrometry/scamp.h
+include/libstellarsolver/astrometry/simplexy-common.h
+include/libstellarsolver/astrometry/simplexy.h
+include/libstellarsolver/astrometry/sip-utils.h
+include/libstellarsolver/astrometry/sip.h
+include/libstellarsolver/astrometry/sip_qfits.h
+include/libstellarsolver/astrometry/solvedclient.h
+include/libstellarsolver/astrometry/solvedfile.h
+include/libstellarsolver/astrometry/solver.h
+include/libstellarsolver/astrometry/starkd.h
+include/libstellarsolver/astrometry/starutil.h
+include/libstellarsolver/astrometry/starutil.inc
+include/libstellarsolver/astrometry/starxy.h
+include/libstellarsolver/astrometry/tabsort.h
+include/libstellarsolver/astrometry/thread-specific.inc
+include/libstellarsolver/astrometry/tic.h
+include/libstellarsolver/astrometry/tpv.h
+include/libstellarsolver/astrometry/tweak.h
+include/libstellarsolver/astrometry/tweak2.h
+include/libstellarsolver/astrometry/tycho2-fits.h
+include/libstellarsolver/astrometry/tycho2.h
+include/libstellarsolver/astrometry/ucac3.h
+include/libstellarsolver/astrometry/ucac4.h
+include/libstellarsolver/astrometry/uniformize-catalog.h
+include/libstellarsolver/astrometry/unpermute-quads.h
+include/libstellarsolver/astrometry/unpermute-stars.h
+include/libstellarsolver/astrometry/usnob-fits.h
+include/libstellarsolver/astrometry/usnob.h
+include/libstellarsolver/astrometry/verify.h
+include/libstellarsolver/astrometry/wcs-pv2sip.h
+include/libstellarsolver/astrometry/wcs-rd2xy.h
+include/libstellarsolver/astrometry/wcs-xy2rd.h
+include/libstellarsolver/astrometry/xylist.h
+include/libstellarsolver/parameters.h
+include/libstellarsolver/sextractorsolver.h
+include/libstellarsolver/stellarsolver.h
+include/libstellarsolver/structuredefinitions.h
+include/libstellarsolver/version.h
+lib/cmake/StellarSolver/StellarSolverConfig-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/StellarSolver/StellarSolverConfig.cmake
+lib/cmake/StellarSolver/StellarSolverConfigVersion.cmake
+lib/libstellarsolver.so
+lib/libstellarsolver.so.1
+lib/libstellarsolver.so.1.5
+libdata/pkgconfig/stellarsolver.pc