aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2009-09-15 21:37:57 +0000
committerRene Ladan <rene@FreeBSD.org>2009-09-15 21:37:57 +0000
commit40a43e8c8f6f9bbcfe30241c54a9d7f0b1dd8ce0 (patch)
treea8892074c93fcff954bb9d54e13b43418ca0750f /astro
parent2d2b33b12e936467e02cb3711584246b444f90db (diff)
downloadports-40a43e8c8f6f9bbcfe30241c54a9d7f0b1dd8ce0.tar.gz
ports-40a43e8c8f6f9bbcfe30241c54a9d7f0b1dd8ce0.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile140
-rw-r--r--astro/boinc-setiathome-enhanced/distinfo9
-rw-r--r--astro/boinc-setiathome-enhanced/files/app_info.xml.in17
-rw-r--r--astro/boinc-setiathome-enhanced/files/patch-Makefile.am11
-rw-r--r--astro/boinc-setiathome-enhanced/files/patch-_autosetup13
-rw-r--r--astro/boinc-setiathome-enhanced/files/patch-client_Makefile.am16
-rw-r--r--astro/boinc-setiathome-enhanced/files/patch-configure.ac42
-rw-r--r--astro/boinc-setiathome-enhanced/files/pkg-message.in (renamed from astro/boinc-setiathome-enhanced/pkg-message)10
-rw-r--r--astro/boinc-setiathome-enhanced/pkg-plist4
9 files changed, 147 insertions, 115 deletions
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index f5439afa2988..9b15ebfcc718 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -5,42 +5,27 @@
#
PORTNAME= boinc-setiathome-enhanced
-PORTVERSION= ${SETI_PORTVERSION_FULL}.${AP_PORTVERSION_FULL}
-PORTREVISION= 3
+PORTVERSION= 6.08
CATEGORIES= astro
MASTER_SITES= ftp://rene-ladan.nl/pub/distfiles/
-DISTFILES= astropulse-${AP_PORTVERSION_FULL}.tar.bz2 setiathome-${SETI_PORTVERSION_FULL}.tar.bz2
+DISTNAME= setiathome-svn-412
-MAINTAINER= rene@freebsd.org
-COMMENT= Setiathome Enhanced/Astropulse for BOINC
+MAINTAINER= rene@FreeBSD.org
+COMMENT= Setiathome Enhanced for BOINC
-# don't use USE_AUTOTOOLS because we want to invoke it in a non-default way
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3 \
${LOCALBASE}/include/boinc/std_fixes.h:${PORTSDIR}/net/boinc-client \
- ${LOCALBASE}/bin/autoconf-2.62:${PORTSDIR}/devel/autoconf262 \
- ${LOCALBASE}/bin/automake-1.8:${PORTSDIR}/devel/automake18 \
- ${LOCALBASE}/bin/autoconf:${PORTSDIR}/devel/autoconf-wrapper \
- ${LOCALBASE}/bin/automake:${PORTSDIR}/devel/automake-wrapper \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
-LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float \
- jpeg.10:${PORTSDIR}/graphics/jpeg \
- xcb.2:${PORTSDIR}/x11/libxcb
-
-USE_GL= gl glu glut
-USE_XORG= ice sm x11 xau xext xi xdamage xdmcp xfixes xmu xt xxf86vm
+LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float
USE_BZIP2= yes
+USE_AUTOTOOLS= autoconf:262:env automake:18:env
+GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
-NO_WRKSUBDIR= yes
-
-SETI_PORTVERSION=6.3
-SETI_PORTVERSION_FULL=6.03
-AP_PORTVERSION=5.0
-AP_PORTVERSION_FULL=5.00
-CFLAGS+= -I${LOCALBASE}/include/boinc -O2 -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CFLAGS+= -O2 -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include -L${LOCALBASE}/lib
.if defined(CPUTYPE)
CFLAGS+= -march=${CPUTYPE}
.endif
@@ -50,106 +35,59 @@ BOINC_USER?= boinc
BOINC_GROUP?= nobody
BOINC_HOME?= /var/db/boinc
-OPTIONS= SETI_APP "Install SETI@home binary" on \
- AP_APP "Install Astropulse binary" on
+OPTIONS= X11 "Build screensaver" off
.include <bsd.port.pre.mk>
-.if (${OSVERSION} >= 700000)
-CFLAGS+= -mtune=native
+.if !defined(WITHOUT_X11)
+.if !exists(${LOCALBASE}/lib/libboinc_graphics2.a)
+BROKEN=Reinstall net/boinc-client with X11 enabled for screensavers
+.endif
+LIB_DEPENDS+= jpeg.10:${PORTSDIR}/graphics/jpeg \
+ xcb.2:${PORTSDIR}/x11/libxcb
+USE_GL= gl glu glut
+USE_XORG= ice sm x11 xau xext xi xdamage xdmcp xfixes xmu xt xxf86vm
+PLIST_SUB+= X11=""
+.else
+CONFIGURE_ARGS+= --disable-graphics
+PLIST_SUB+= X11="@comment "
.endif
-CXXFLAGS+= ${CFLAGS}
-
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}" \
- CXXFLAGS="${CXXFLAGS}" \
- BOINCDIR="${LOCALBASE}" \
- BOINC_DIR="${LOCALBASE}"
-CONFIGURE_FLAGS+= --disable-static-client --with-boinc-platform=${ARCH}-portbld-freebsd --build=${ARCH}-portbld-freebsd
.if ${OSVERSION} >= 700042
.if ${ARCH} == "sparc64"
BROKEN= Does not compile with GCC 4.2
.endif
+CFLAGS+= -mtune=native
.endif
-.if defined(WITHOUT_SETI_APP) && defined(WITHOUT_AP_APP)
-IGNORE= neither SETI@home nor Astropulse selected
-.endif
+CXXFLAGS+= ${CFLAGS}
+
+CONFIGURE_ENV+= BOINCDIR="${LOCALBASE}"
+
+CONFIGURE_ARGS+= --disable-static-client --with-boinc-platform=${ARCH}-portbld-freebsd --disable-server
SETI_SITE= setiathome.berkeley.edu
-SETI_BINARY= setiathome-${SETI_PORTVERSION}.${ARCH}-portbld-freebsd
-AP_BINARY= astropulse-${AP_PORTVERSION}.${ARCH}-portbld-freebsd
+SETI_BINARY= setiathome-${PORTVERSION:S/.0/./}.${ARCH}-portbld-freebsd
-PLIST_SUB= SETI_BINARY=${SETI_BINARY} \
- AP_BINARY=${AP_BINARY} \
+SUB_FILES= app_info.xml pkg-message
+SUB_LIST= SETI_BINARY=${SETI_BINARY} \
+ SETI_SITE=${SETI_SITE} \
+ SETI_VERSION=${PORTVERSION:S/.//}
+PLIST_SUB+= SETI_BINARY=${SETI_BINARY} \
SETI_SITE=${SETI_SITE} \
BOINC_HOME=${BOINC_HOME}
-do-configure:
-.if !defined(WITHOUT_AP_APP)
- (cd ${WRKDIR}/astropulse/client ; ${REINPLACE_CMD} -E -e "s|/bin/sh|${LOCALBASE}/bin/bash|" ./configure ; ${CONFIGURE_ENV} ./configure ${CONFIGURE_FLAGS})
-.endif
- # always configure seti@home, the astropulse source code relies on it
- (cd ${WRKDIR}/seti_boinc ; ./_autosetup ; ${REINPLACE_CMD} -E -e "s|/bin/sh|${LOCALBASE}/bin/bash|" ./configure ; ${CONFIGURE_ENV} ./configure ${CONFIGURE_FLAGS} --disable-server)
-
-do-build:
- @${ECHO_CMD} "<app_info>" >> ${WRKDIR}/app_info.xml
-.if !defined(WITHOUT_AP_APP)
- (cd ${WRKDIR}/astropulse/client ; ${GMAKE})
- #add app_info tags for astropulse
- @${ECHO_CMD} "<app>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<name>astropulse</name>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "</app>" >> ${WRKDIR}/app_info.xml
-
- @${ECHO_CMD} "<file_info>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<name>${AP_BINARY}</name>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<executable/>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "</file_info>" >> ${WRKDIR}/app_info.xml
-
- @${ECHO_CMD} "<app_version>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<app_name>astropulse</app_name>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<version_num>${AP_PORTVERSION_FULL:S/.//}</version_num>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<file_ref>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<file_name>${AP_BINARY}</file_name>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<main_program/>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "</file_ref>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "</app_version>" >> ${WRKDIR}/app_info.xml
-.endif
-.if !defined(WITHOUT_SETI_APP)
- (cd ${WRKDIR}/seti_boinc ; ${GMAKE})
- #add app_info tags for setiathome
- @${ECHO_CMD} "<app>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<name>setiathome_enhanced</name>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "</app>" >> ${WRKDIR}/app_info.xml
-
- @${ECHO_CMD} "<file_info>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<name>${SETI_BINARY}</name>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<executable/>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "</file_info>" >> ${WRKDIR}/app_info.xml
-
- @${ECHO_CMD} "<app_version>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<app_name>setiathome_enhanced</app_name>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<version_num>${SETI_PORTVERSION_FULL:S/.//}</version_num>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<file_ref>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<file_name>${SETI_BINARY}</file_name>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "<main_program/>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "</file_ref>" >> ${WRKDIR}/app_info.xml
- @${ECHO_CMD} "</app_version>" >> ${WRKDIR}/app_info.xml
-.endif
- @${ECHO_CMD} "</app_info>" >> ${WRKDIR}/app_info.xml
+pre-configure:
+ (cd ${WRKSRC}; ./_autosetup ; ${REINPLACE_CMD} -E -e "s|/bin/sh|${LOCALBASE}/bin/bash|" ./configure)
do-install:
${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects
${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects/${SETI_SITE}
-.if !defined(WITHOUT_SETI_APP)
- ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/seti_boinc/client/${SETI_BINARY} ${BOINC_HOME}/projects/${SETI_SITE}/
- ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/seti_boinc/client/seti_graphics ${BOINC_HOME}/projects/${SETI_SITE}/
-.endif
-.if !defined(WITHOUT_AP_APP)
- ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/astropulse/client/${AP_BINARY} ${BOINC_HOME}/projects/${SETI_SITE}/
- ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/astropulse/client/ap_graphics ${BOINC_HOME}/projects/${SETI_SITE}/
-.endif
+ ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKSRC}/client/${SETI_BINARY} ${BOINC_HOME}/projects/${SETI_SITE}/
+.if !defined(WITHOUT_X11)
+ ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKSRC}/client/seti_graphics ${BOINC_HOME}/projects/${SETI_SITE}/
${INSTALL_DATA} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/app_info.xml ${BOINC_HOME}/projects/${SETI_SITE}/
+.endif
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/astro/boinc-setiathome-enhanced/distinfo b/astro/boinc-setiathome-enhanced/distinfo
index 8a6a7d005370..956a6bc55680 100644
--- a/astro/boinc-setiathome-enhanced/distinfo
+++ b/astro/boinc-setiathome-enhanced/distinfo
@@ -1,6 +1,3 @@
-MD5 (astropulse-5.00.tar.bz2) = d3096d95a9f719c03e3d685c0969010b
-SHA256 (astropulse-5.00.tar.bz2) = 077a76c863374d439a201bb15949f16dbbd27f6075649a88cba9f8ba091c439d
-SIZE (astropulse-5.00.tar.bz2) = 474505
-MD5 (setiathome-6.03.tar.bz2) = df5f0c6f3e5a3a115839d1c9e8328a7f
-SHA256 (setiathome-6.03.tar.bz2) = cd746cb6e2e0ce27769d189dbd6e4f5123dbd9f116385cf9c1306d31a60ec041
-SIZE (setiathome-6.03.tar.bz2) = 620033
+MD5 (setiathome-svn-412.tar.bz2) = 2fc5afd466257c68b048129ea8c24955
+SHA256 (setiathome-svn-412.tar.bz2) = f2e1b5d896c6a2e96e9323c85f2ef74b56b23fae1bbd5afc2133f84bd58319cb
+SIZE (setiathome-svn-412.tar.bz2) = 2411273
diff --git a/astro/boinc-setiathome-enhanced/files/app_info.xml.in b/astro/boinc-setiathome-enhanced/files/app_info.xml.in
new file mode 100644
index 000000000000..dba3218893e9
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/files/app_info.xml.in
@@ -0,0 +1,17 @@
+<app_info>
+<app>
+<name>setiathome_enhanced</name>
+</app>
+<file_info>
+<name>%%SETI_BINARY%%</name>
+<executable/>
+</file_info>
+<app_version>
+<app_name>setiathome_enhanced</app_name>
+<version_num>%%SETI_VERSION%%</version_num>
+<file_ref>
+<file_name>%%SETI_BINARY%%</file_name>
+<main_program/>
+</file_ref>
+</app_version>
+</app_info>
diff --git a/astro/boinc-setiathome-enhanced/files/patch-Makefile.am b/astro/boinc-setiathome-enhanced/files/patch-Makefile.am
new file mode 100644
index 000000000000..237812ef9c51
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orig 2008-02-19 19:50:56.000000000 +0100
++++ Makefile.am 2009-09-09 22:49:11.000000000 +0200
+@@ -8,7 +8,7 @@
+ ACLOCAL_AMFLAGS = -I m4
+
+ if ENABLE_CLIENT
+- CLIENT_SUBDIRS = client tools
++ CLIENT_SUBDIRS = client
+ endif
+
+ if ENABLE_SERVER
diff --git a/astro/boinc-setiathome-enhanced/files/patch-_autosetup b/astro/boinc-setiathome-enhanced/files/patch-_autosetup
new file mode 100644
index 000000000000..768a1cd810ce
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/files/patch-_autosetup
@@ -0,0 +1,13 @@
+Index: _autosetup
+===================================================================
+--- _autosetup (revision 429)
++++ _autosetup (working copy)
+@@ -42,7 +42,7 @@
+ version="0";
+ fi
+ if [ -n "${version}" ]; then
+- version=`echo $version | awk '{ for (i=1;i<=NF;i++) { split($i,j,"."); m=j[1]"."j[2] ; if ((m*1)>0) { print m ; break; } } }'`
++ version=`echo $version | awk '{ for (i=1;i<=NF;i++) { split($i,j,"."); m=j[1]"."j[2] ; if (m ~ /[0-9]+\.[0-9]+/) { print m ; break; } } }'`
+ if [ -z "$version" ]; then version=0; fi
+ success=`echo "$version" "$desired" | awk '{ if ($1 >= $2) { print "yes";} else {print "no";}} '`
+ else
diff --git a/astro/boinc-setiathome-enhanced/files/patch-client_Makefile.am b/astro/boinc-setiathome-enhanced/files/patch-client_Makefile.am
new file mode 100644
index 000000000000..b135d3989600
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/files/patch-client_Makefile.am
@@ -0,0 +1,16 @@
+--- client/Makefile.am.orig 2008-09-10 00:43:08.000000000 +0200
++++ client/Makefile.am 2009-09-09 22:50:54.000000000 +0200
+@@ -50,12 +50,7 @@
+
+
+
+-noinst_PROGRAMS = seti_boinc hires_timer_test
+-
+-hires_timer_test_SOURCES= vector/hires_timer.cpp
+-hires_timer_test_CXXFLAGS=-DTEST_TIMER $(CXXFLAGS) $(CLIENT_C_FLAGS)
+-hires_timer_test_LDFLAGS=$(CLIENT_LD_FLAGS)
+-hires_timer_test_LDADD=$(CLIENT_LD_ADD)
++noinst_PROGRAMS = seti_boinc
+
+ seti_boinc_SOURCES = \
+ main.cpp \
diff --git a/astro/boinc-setiathome-enhanced/files/patch-configure.ac b/astro/boinc-setiathome-enhanced/files/patch-configure.ac
new file mode 100644
index 000000000000..fce298cfbc64
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/files/patch-configure.ac
@@ -0,0 +1,42 @@
+--- configure.ac.orig 2008-12-03 00:00:50.000000000 +0100
++++ configure.ac 2009-09-11 01:48:48.000000000 +0200
+@@ -4,18 +4,11 @@
+
+
+ AC_PREREQ(2.57)
+-AC_INIT(setiathome_enhanced, 6.03, ports@setiathome.ssl.berkeley.edu)
+-svnrev="`svn info | grep Revision:`"
++AC_INIT(setiathome_enhanced, 6.08, ports@setiathome.ssl.berkeley.edu)
+
+-if test -n "${svnrev}" ; then
+- AC_REVISION("${svnrev}")
+- AC_DEFINE_UNQUOTED(SVN_REV,"${svnrev}",
++AC_REVISION([$Revision: 412 $])
++AC_DEFINE(SVN_REV,"$Revision: 412 $",
+ [Define to be the subversion revision number])
+-else
+- AC_REVISION([$Revision: 316 $])
+- AC_DEFINE(SVN_REV,"$Revision: 316 $",
+- [Define to be the subversion revision number])
+-fi
+
+ AC_CANONICAL_TARGET
+ AM_INIT_AUTOMAKE(dist-zip)
+@@ -320,7 +313,7 @@
+ dnl AC_CHECK_LIB([dl], [dlopen],
+ dnl AC_DEFINE([HAVE_LIBDL],[1],[Define to 1 if you have the dl library]))
+ AC_LANG(C++)
+-SAH_CHECK_HEALPIX
++dnl SAH_CHECK_HEALPIX
+
+
+ if test "${ac_cv_cxx_compiler_gnu}" = "yes" ; then
+@@ -408,7 +401,7 @@
+ AM_CONDITIONAL(ENABLE_GUI, [test "${enable_graphics}" = yes])
+ AM_CONDITIONAL(LINUX, [test -n "`echo ${target} | grep linux`"])
+ AM_CONDITIONAL(I386, [test -n "`echo ${target} | grep i.86`"])
+-AM_CONDITIONAL(X86_64, [test -n "`echo ${target} | grep 'x86_64'`"])
++AM_CONDITIONAL(X86_64, [test -n "`echo ${target} | egrep 'x86_64|amd64'`"])
+ AM_CONDITIONAL(PPC, [test -n "`echo ${target} | grep 'powerpc'`" -o -n "`echo ${target} | grep 'ppc'`" ])
+
+ AC_CACHE_SAVE
diff --git a/astro/boinc-setiathome-enhanced/pkg-message b/astro/boinc-setiathome-enhanced/files/pkg-message.in
index ec27395eea77..a9dd221e9967 100644
--- a/astro/boinc-setiathome-enhanced/pkg-message
+++ b/astro/boinc-setiathome-enhanced/files/pkg-message.in
@@ -1,16 +1,16 @@
*****************************************************************************
ATTACHING PROJECT
-Just run boinc_gui, choose Attach, and follow instructions.
-Project URL is setiathome.berkeley.edu
+Just run boinc_gui (if installed), choose Attach, and follow instructions.
+Project URL is %%SETI_SITE%%
MANUAL INSTALLATION
*) If this is your first time in any BOINC project, create a new account at
- http://setiathome.berkeley.edu/create_account_form.php
+ http://%%SETI_SITE%%/create_account_form.php
- *) Or get your account key at http://setiathome.berkeley.edu/get_passwd.php
+ *) Or get your account key at http://%%SETI_SITE%%/get_passwd.php
*) Attach to the project:
cd /var/db/boinc
- boinc_cmd --project_attach setiathome.berkeley.edu <account key>
+ boinc_cmd --project_attach %%SETI_SITE%% <account key>
*****************************************************************************
diff --git a/astro/boinc-setiathome-enhanced/pkg-plist b/astro/boinc-setiathome-enhanced/pkg-plist
index 54711def78f2..594e6dece066 100644
--- a/astro/boinc-setiathome-enhanced/pkg-plist
+++ b/astro/boinc-setiathome-enhanced/pkg-plist
@@ -1,7 +1,5 @@
@cwd %%BOINC_HOME%%/projects
%%SETI_SITE%%/app_info.xml
%%SETI_SITE%%/%%SETI_BINARY%%
-%%SETI_SITE%%/%%AP_BINARY%%
-%%SETI_SITE%%/seti_graphics
-%%SETI_SITE%%/ap_graphics
+%%X11%%%%SETI_SITE%%/seti_graphics
@dirrmtry %%SETI_SITE%%