aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-23 14:23:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-23 14:23:32 +0000
commit456c9202b1eb2e69b837647ee71308060d6d787e (patch)
tree4e8c45a9761d4ffdf6aaa083ad0299d6edbcc257 /astro
parentc1d57744f9dbe0de9e60f95022bbcd3b4b587100 (diff)
downloadports-456c9202b1eb2e69b837647ee71308060d6d787e.tar.gz
ports-456c9202b1eb2e69b837647ee71308060d6d787e.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/gpstk/Makefile47
-rw-r--r--astro/gpstk/distinfo6
-rw-r--r--astro/gpstk/files/patch-Jamrules38
-rw-r--r--astro/gpstk/pkg-plist241
4 files changed, 219 insertions, 113 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
index 42ed7a6f011f..2562d27f567a 100644
--- a/astro/gpstk/Makefile
+++ b/astro/gpstk/Makefile
@@ -5,31 +5,46 @@
# $FreeBSD$
#
-PORTNAME= gpstk
-PORTVERSION= 1.3
-CATEGORIES= astro devel
-MASTER_SITES= SF
-DISTNAME= ${PORTNAME}${PORTVERSION}.src
+PORTNAME= gpstk
+PORTVERSION= 1.5
+CATEGORIES= astro devel
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}${PORTVERSION}.src
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Toolkit for developing GPS applications
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Toolkit for developing GPS applications
-BUILD_DEPENDS= ${LOCALBASE}/bin/jam:${PORTSDIR}/devel/jam
+BUILD_DEPENDS= ${LOCALBASE}/bin/jam:${PORTSDIR}/devel/jam
-USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
-WRKSRC= ${WRKDIR}/${PORTNAME}
-JAM= ${LOCALBASE}/bin/jam
-JAM_ENV= BINDIR=${PREFIX}/bin \
- INCDIR=${PREFIX}/include/$(PORTNAME) \
- LIBDIR=${PREFIX}/lib \
- CC=${CC} C++=${CXX}
+USE_PYTHON_RUN= yes
+USE_LDCONFIG= yes
+
+JAM= ${LOCALBASE}/bin/jam
+JAM_ENV= BINDIR="${PREFIX}/bin" \
+ INCDIR="${PREFIX}/include/$(PORTNAME)" \
+ LIBDIR="${PREFIX}/lib" \
+ CC="${CC}" CCFLAGS="${CFLAGS}" \
+ C++="${CXX}" C++FLAGS="${CXXFLAGS}" \
+ OPTIM="-DHAVE_UINTPTR_T"
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|python2.5|python|g' ${WRKSRC}/apps/reszilla/ordPlot
do-build:
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM}
do-install:
- ${MKDIR} ${PREFIX}/include/${PORTNAME}
+ @${MKDIR} ${PREFIX}/include/${PORTNAME}
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM} install
+.for shlib in geomatics gpstk procframe rxio vplot
+ @${LN} -sf lib${shlib}.so.15 ${PREFIX}/lib/lib${shlib}.so
+.endfor
+ @${STRIP_CMD} `${CAT} ${PLIST} | \
+ ${GREP} '^bin/' | \
+ ${GREP} -E -v 'ddPlot$$|mdpscreen$$|ordPlot$$' | \
+ ${SED} 's:^bin/:${PREFIX}/bin/:g'`
.include <bsd.port.mk>
diff --git a/astro/gpstk/distinfo b/astro/gpstk/distinfo
index 6a42d090649e..4148cfe21fe0 100644
--- a/astro/gpstk/distinfo
+++ b/astro/gpstk/distinfo
@@ -1,3 +1,3 @@
-MD5 (gpstk1.3.src.tar.gz) = 6354aef8bd3f0504f238538c4c475404
-SHA256 (gpstk1.3.src.tar.gz) = 02cd171e74722eafeb44d99e877378c2dbbba6ba1847038fb92c589003f16412
-SIZE (gpstk1.3.src.tar.gz) = 6922759
+MD5 (gpstk1.5.src.tar.gz) = 098dd76b484599366506d7504fe5996a
+SHA256 (gpstk1.5.src.tar.gz) = 2bc699d9eb8d9774fa6a635e0f75da2f38c00e1b700974fe9197b8ba7c867277
+SIZE (gpstk1.5.src.tar.gz) = 7050592
diff --git a/astro/gpstk/files/patch-Jamrules b/astro/gpstk/files/patch-Jamrules
index e16d70802906..c61130b386b3 100644
--- a/astro/gpstk/files/patch-Jamrules
+++ b/astro/gpstk/files/patch-Jamrules
@@ -1,15 +1,6 @@
---- Jamrules.orig Wed Jan 19 19:36:30 2005
-+++ Jamrules Sun Nov 5 09:33:26 2006
-@@ -9,7 +9,7 @@
- KEEPOBJS = true ;
-
- # where to install the .hpp files
--INCDIR = /usr/local/include ;
-+#INCDIR = /usr/local/include ;
-
- # override the built-in EXEMODE
- EXEMODE = 755 ;
-@@ -30,6 +30,10 @@
+--- Jamrules.orig 2008-03-12 00:48:21.000000000 +0900
++++ Jamrules 2009-05-08 23:57:05.000000000 +0900
+@@ -33,6 +33,10 @@
case CYGWIN :
LINKLIBS += -lstdc++ ;
@@ -20,12 +11,21 @@
case LINUX :
LINKLIBS += -lstdc++ ;
CCSHARE_FLAGS = -fPIC ;
-@@ -81,7 +85,7 @@
- # fix does this need to be forward/backslash independent? darn windows.
- BINDIR = [ FDirName $(PREFIX) bin ] ;
- LIBDIR = [ FDirName $(PREFIX) lib ] ;
-- INCDIR = [ FDirName $(PREFIX) include ] ;
-+ INCDIR = [ FDirName $(PREFIX) include gpstk ] ;
+@@ -115,7 +119,7 @@
+ # compiler specific stuff - this is probably actually pretty clumsy
+ if ( $(CC) != gcc )
+ {
+- NEED_GETOPT = true ;
++ #NEED_GETOPT = true ;
}
- # debug - edit this as needed.
+ if $(PREFIX)
+@@ -215,7 +219,7 @@
+ if $(UNIX) && $(OS) != CYGWIN && $(OS) != MACOSX
+ {
+ soname = $(LIBPREFIX)$(<:S=$(SUFLIBSHR)).$(GPSTK_SO_VERSION) ;
+- shlib = $(LIBPREFIX)$(<:S=$(SUFLIBSHR).$(GPSTK_SO_VERSION).0) ;
++ shlib = $(LIBPREFIX)$(<:S=$(SUFLIBSHR)).$(GPSTK_SO_VERSION) ;
+ shrobjs = $(>:S=$(SUFOBJ2)) ;
+ ObjectCcFlags $(shrobjs) : $(CCSHARE_FLAGS) ;
+ ObjectC++Flags $(shrobjs) : $(CCSHARE_FLAGS) ;
diff --git a/astro/gpstk/pkg-plist b/astro/gpstk/pkg-plist
index 8038389f74bd..1f883de8d6dd 100644
--- a/astro/gpstk/pkg-plist
+++ b/astro/gpstk/pkg-plist
@@ -1,60 +1,139 @@
-lib/libgpstk.a
-lib/libgpstk.so
-lib/librxio.a
-lib/librxio.so
+bin/DDBase
+bin/DiscFix
+bin/EditRinex
+bin/IonoBias
+bin/NavMerge
+bin/PRSolve
+bin/ResCor
+bin/RinSum
+bin/RinexDump
+bin/TECMaps
+bin/ash2mdp
+bin/ash2xyz
+bin/ats2mdp
+bin/bc2sp3
+bin/calgps
+bin/compSatVis
+bin/compStaVis
+bin/daa
+bin/ddGen
+bin/ddPlot
+bin/ddmerge
+bin/ephdiff
+bin/fic2rin
+bin/ficacheck
+bin/ficafic
+bin/ficcheck
+bin/ficdiff
+bin/ficfica
+bin/findMoreThan12
+bin/mdp2rinex
+bin/mdpEdit
+bin/mdpscreen
+bin/mdpscreenx
+bin/mdptool
+bin/mergeFIC
+bin/mergeRinMet
+bin/mergeRinNav
+bin/mergeRinObs
+bin/mergeSRI
+bin/mpsolve
+bin/navdmp
+bin/navsum
+bin/novaRinex
+bin/ordClock
+bin/ordEdit
+bin/ordGen
+bin/ordLinEst
+bin/ordPlot
+bin/ordStats
+bin/posInterp
+bin/poscvt
+bin/rfw
+bin/rinexpvt
+bin/rinexthin
+bin/rmwcheck
+bin/rmwdiff
+bin/rnwcheck
+bin/rnwdiff
+bin/rowcheck
+bin/rowdiff
+bin/rstats
+bin/sp3version
+bin/svvis
+bin/timeconvert
+bin/vecsol
+bin/wheresat
include/gpstk/ANSITime.hpp
+include/gpstk/ATSData.hpp
+include/gpstk/ATSStream.hpp
include/gpstk/AlmOrbit.hpp
-include/gpstk/AlmanacStore.hpp
include/gpstk/AshtechALB.hpp
include/gpstk/AshtechData.hpp
include/gpstk/AshtechEPB.hpp
include/gpstk/AshtechMBEN.hpp
include/gpstk/AshtechPBEN.hpp
include/gpstk/AshtechStream.hpp
-include/gpstk/BCEphemerisStore.hpp
+include/gpstk/AstronomicalFunctions.hpp
+include/gpstk/BLQDataReader.hpp
include/gpstk/Bancroft.hpp
include/gpstk/BasicFramework.hpp
+include/gpstk/BasicModel.hpp
+include/gpstk/BasicShape.hpp
include/gpstk/BinUtils.hpp
include/gpstk/BinexData.hpp
include/gpstk/BinexFilterOperators.hpp
include/gpstk/BinexStream.hpp
include/gpstk/BivarStats.hpp
+include/gpstk/BorderLayout.hpp
include/gpstk/CheckPRData.hpp
+include/gpstk/Circle.hpp
include/gpstk/CivilTime.hpp
include/gpstk/ClockModel.hpp
include/gpstk/CodeBuffer.hpp
include/gpstk/CodeSmoother.hpp
+include/gpstk/Color.hpp
include/gpstk/CommandOption.hpp
include/gpstk/CommandOptionParser.hpp
include/gpstk/CommandOptionWithCommonTimeArg.hpp
include/gpstk/CommandOptionWithPositionArg.hpp
include/gpstk/CommandOptionWithTimeArg.hpp
+include/gpstk/Comment.hpp
include/gpstk/CommonTime.hpp
include/gpstk/ComputeCombination.hpp
include/gpstk/ComputeIURAWeights.hpp
include/gpstk/ComputeLC.hpp
include/gpstk/ComputeLI.hpp
include/gpstk/ComputeLdelta.hpp
+include/gpstk/ComputeLinear.hpp
include/gpstk/ComputeMOPSWeights.hpp
include/gpstk/ComputeMelbourneWubbena.hpp
include/gpstk/ComputePC.hpp
include/gpstk/ComputePI.hpp
include/gpstk/ComputePdelta.hpp
+include/gpstk/ComputeTropModel.hpp
+include/gpstk/ComputeWindUp.hpp
+include/gpstk/CorrectObservables.hpp
+include/gpstk/DCinternals.hpp
+include/gpstk/DDid.hpp
include/gpstk/DOP.hpp
include/gpstk/DataHeaders.hpp
include/gpstk/DataStatus.hpp
include/gpstk/DataStructures.hpp
include/gpstk/DayTime.hpp
include/gpstk/DeltaOp.hpp
-include/gpstk/DeviceStream.hpp
+include/gpstk/DiscCorr.hpp
include/gpstk/ECEF.hpp
+include/gpstk/ENUUtil.hpp
+include/gpstk/EPSImage.hpp
+include/gpstk/EarthOrientation.hpp
include/gpstk/EngAlmanac.hpp
include/gpstk/EngEphemeris.hpp
include/gpstk/EngNav.hpp
include/gpstk/EphReader.hpp
include/gpstk/EphemerisRange.hpp
-include/gpstk/EphemerisStore.hpp
include/gpstk/EpochClockModel.hpp
+include/gpstk/Equation.hpp
include/gpstk/Exception.hpp
include/gpstk/Expression.hpp
include/gpstk/ExtractC1.hpp
@@ -68,7 +147,6 @@ include/gpstk/ExtractLC.hpp
include/gpstk/ExtractP1.hpp
include/gpstk/ExtractP2.hpp
include/gpstk/ExtractPC.hpp
-include/gpstk/FDStreamBuff.hpp
include/gpstk/FFBinaryStream.hpp
include/gpstk/FFData.hpp
include/gpstk/FFIdentifier.hpp
@@ -93,6 +171,11 @@ include/gpstk/FileHunter.hpp
include/gpstk/FileSpec.hpp
include/gpstk/FileStore.hpp
include/gpstk/FileUtils.hpp
+include/gpstk/Fillable.hpp
+include/gpstk/Frame.hpp
+include/gpstk/GDCconfiguration.hpp
+include/gpstk/GPSAlmanacStore.hpp
+include/gpstk/GPSEphemerisStore.hpp
include/gpstk/GPSEpochWeekSecond.hpp
include/gpstk/GPSGeoid.hpp
include/gpstk/GPSWeekSecond.hpp
@@ -100,25 +183,41 @@ include/gpstk/GPSWeekZcount.hpp
include/gpstk/GPSZcount.hpp
include/gpstk/GPSZcount29.hpp
include/gpstk/GPSZcount32.hpp
+include/gpstk/GSatID.hpp
include/gpstk/GenXSequence.hpp
include/gpstk/Geodetic.hpp
+include/gpstk/GeodeticFrames.hpp
include/gpstk/GeoidModel.hpp
+include/gpstk/GraphicsConstants.hpp
+include/gpstk/GridLayout.hpp
+include/gpstk/HLayout.hpp
+include/gpstk/Helper.hpp
+include/gpstk/InOutFramework.hpp
include/gpstk/IonoModel.hpp
include/gpstk/IonoModelStore.hpp
include/gpstk/JulianDate.hpp
include/gpstk/LICSDetector.hpp
+include/gpstk/Layout.hpp
+include/gpstk/Line.hpp
include/gpstk/LinearClockModel.hpp
+include/gpstk/LinearCombinations.hpp
include/gpstk/LoopedFramework.hpp
include/gpstk/MDPHeader.hpp
include/gpstk/MDPNavSubframe.hpp
include/gpstk/MDPObsEpoch.hpp
include/gpstk/MDPPVTSolution.hpp
include/gpstk/MDPSelftestStatus.hpp
+include/gpstk/MDPStream.hpp
include/gpstk/MJD.hpp
include/gpstk/MOPSWeight.hpp
+include/gpstk/MSCBase.hpp
include/gpstk/MSCData.hpp
+include/gpstk/MSCHeader.hpp
+include/gpstk/MSCStore.hpp
include/gpstk/MSCStream.hpp
include/gpstk/MWCSDetector.hpp
+include/gpstk/Markable.hpp
+include/gpstk/Marker.hpp
include/gpstk/MathBase.hpp
include/gpstk/Matrix.hpp
include/gpstk/MatrixBase.hpp
@@ -128,10 +227,17 @@ include/gpstk/MatrixImplementation.hpp
include/gpstk/MatrixOperators.hpp
include/gpstk/MetReader.hpp
include/gpstk/MiscMath.hpp
+include/gpstk/ModelObs.hpp
+include/gpstk/ModelObsFixedStation.hpp
include/gpstk/ModeledPR.hpp
include/gpstk/ModeledPseudorangeBase.hpp
include/gpstk/ModeledReferencePR.hpp
+include/gpstk/MoonPosition.hpp
+include/gpstk/NEDUtil.hpp
include/gpstk/NablaOp.hpp
+include/gpstk/Namelist.hpp
+include/gpstk/NovatelData.hpp
+include/gpstk/NovatelStream.hpp
include/gpstk/ORDEpoch.hpp
include/gpstk/ObsClockModel.hpp
include/gpstk/ObsEpochMap.hpp
@@ -139,14 +245,25 @@ include/gpstk/ObsID.hpp
include/gpstk/ObsReader.hpp
include/gpstk/ObsRngDev.hpp
include/gpstk/ObsUtils.hpp
+include/gpstk/OceanLoading.hpp
include/gpstk/OneFreqCSDetector.hpp
include/gpstk/PCSmoother.hpp
include/gpstk/PCodeConst.hpp
include/gpstk/PRSolution.hpp
+include/gpstk/PSImage.hpp
+include/gpstk/PSImageBase.hpp
+include/gpstk/Path.hpp
+include/gpstk/PhaseWindup.hpp
+include/gpstk/PoleTides.hpp
include/gpstk/PolyFit.hpp
+include/gpstk/Polygon.hpp
include/gpstk/Position.hpp
+include/gpstk/PreciseRange.hpp
+include/gpstk/ProcessingClass.hpp
+include/gpstk/ProcessingVector.hpp
include/gpstk/RACRotation.hpp
include/gpstk/RTFileFrame.hpp
+include/gpstk/Rectangle.hpp
include/gpstk/RinexConverters.hpp
include/gpstk/RinexEphemerisStore.hpp
include/gpstk/RinexMetBase.hpp
@@ -167,6 +284,7 @@ include/gpstk/RinexObsID.hpp
include/gpstk/RinexObsStream.hpp
include/gpstk/RinexSatID.hpp
include/gpstk/RinexUtilities.hpp
+include/gpstk/RobustStats.hpp
include/gpstk/RungeKutta4.hpp
include/gpstk/SEMAlmanacStore.hpp
include/gpstk/SEMBase.hpp
@@ -181,22 +299,32 @@ include/gpstk/SP3EphemerisStore.hpp
include/gpstk/SP3Header.hpp
include/gpstk/SP3SatID.hpp
include/gpstk/SP3Stream.hpp
+include/gpstk/SRI.hpp
+include/gpstk/SRIFilter.hpp
include/gpstk/SVExclusionList.hpp
+include/gpstk/SVGImage.hpp
+include/gpstk/SVNumXRef.hpp
include/gpstk/SVPCodeGen.hpp
+include/gpstk/SatDataReader.hpp
include/gpstk/SatID.hpp
+include/gpstk/SatPass.hpp
include/gpstk/SimpleFilter.hpp
include/gpstk/SimpleIURAWeight.hpp
include/gpstk/SimpleKalmanFilter.hpp
+include/gpstk/SolidTides.hpp
include/gpstk/SolverBase.hpp
include/gpstk/SolverLMS.hpp
include/gpstk/SolverWMS.hpp
include/gpstk/SourceID.hpp
include/gpstk/Stats.hpp
+include/gpstk/StochasticModel.hpp
include/gpstk/StringUtils.hpp
+include/gpstk/StrokeStyle.hpp
+include/gpstk/SunPosition.hpp
include/gpstk/SystemTime.hpp
-include/gpstk/TCPStream.hpp
-include/gpstk/TCPStreamBuff.hpp
include/gpstk/TabularEphemerisStore.hpp
+include/gpstk/Text.hpp
+include/gpstk/TextStyle.hpp
include/gpstk/TimeConstants.hpp
include/gpstk/TimeConverters.hpp
include/gpstk/TimeNamedFileStream.hpp
@@ -206,11 +334,16 @@ include/gpstk/Triple.hpp
include/gpstk/TropModel.hpp
include/gpstk/TypeID.hpp
include/gpstk/UnixTime.hpp
+include/gpstk/VGImage.hpp
+include/gpstk/VLayout.hpp
+include/gpstk/VPlotException.hpp
include/gpstk/ValidType.hpp
+include/gpstk/Variable.hpp
include/gpstk/Vector.hpp
include/gpstk/VectorBase.hpp
include/gpstk/VectorBaseOperators.hpp
include/gpstk/VectorOperators.hpp
+include/gpstk/ViewerManager.hpp
include/gpstk/WGS84Geoid.hpp
include/gpstk/WeightBase.hpp
include/gpstk/WxObsMap.hpp
@@ -219,6 +352,7 @@ include/gpstk/X2Sequence.hpp
include/gpstk/XYZ2NED.hpp
include/gpstk/XYZ2NEU.hpp
include/gpstk/Xvt.hpp
+include/gpstk/XvtStore.hpp
include/gpstk/YDSTime.hpp
include/gpstk/YumaAlmanacStore.hpp
include/gpstk/YumaBase.hpp
@@ -226,75 +360,32 @@ include/gpstk/YumaData.hpp
include/gpstk/YumaHeader.hpp
include/gpstk/YumaStream.hpp
include/gpstk/convhelp.hpp
+include/gpstk/format.hpp
include/gpstk/geometry.hpp
-include/gpstk/getopt.h
include/gpstk/gps_constants.hpp
include/gpstk/gpstkplatform.h
include/gpstk/icd_200_constants.hpp
+include/gpstk/index.hpp
include/gpstk/mergePCodeWords.h
+include/gpstk/miscdefs.hpp
include/gpstk/miscenum.hpp
+include/gpstk/random.hpp
+include/gpstk/regex.h
include/gpstk/stl_helpers.hpp
+include/gpstk/xregex2.h
+lib/libgeomatics.a
+lib/libgeomatics.so
+lib/libgeomatics.so.15
+lib/libgpstk.a
+lib/libgpstk.so
+lib/libgpstk.so.15
+lib/libprocframe.a
+lib/libprocframe.so
+lib/libprocframe.so.15
+lib/librxio.a
+lib/librxio.so
+lib/librxio.so.15
+lib/libvplot.a
+lib/libvplot.so
+lib/libvplot.so.15
@dirrm include/gpstk
-bin/DDBase
-bin/DiscFix
-bin/EditRinex
-bin/IonoBias
-bin/NavMerge
-bin/PRSolve
-bin/ResCor
-bin/RinSum
-bin/RinexDump
-bin/TECMaps
-bin/ash2mdp
-bin/bc2sp3
-bin/calgps
-bin/daa
-bin/ddGen
-bin/ddPlot
-bin/ddmerge
-bin/ephdiff
-bin/fic2rin
-bin/ficacheck
-bin/ficafic
-bin/ficcheck
-bin/ficdiff
-bin/ficfica
-bin/findMoreThan12
-bin/mdp2rinex
-bin/mdptool
-bin/mergeFIC
-bin/mergeRinMet
-bin/mergeRinNav
-bin/mergeRinObs
-bin/mergeSRI
-bin/mpsolve
-bin/navdmp
-bin/novaRinex
-bin/ordClock
-bin/ordEdit
-bin/ordGen
-bin/ordLinEst
-bin/ordPlot
-bin/ordStats
-bin/posInterp
-bin/poscvt
-bin/rfw
-bin/rinexpvt
-bin/rinexthin
-bin/rmwcheck
-bin/rmwdiff
-bin/rnwcheck
-bin/rnwdiff
-bin/rowcheck
-bin/rowdiff
-bin/rstats
-bin/rtAshtech
-bin/sp3version
-bin/tcptest
-bin/timeconvert
-bin/tnl
-bin/tsrif
-bin/tsrifsu
-bin/tsriftu
-bin/vecsol
-bin/wheresat