aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-23 00:42:13 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-23 00:42:13 +0000
commit7ef396a3cf4e8b953f4dd90d27ebe80ce28cdba7 (patch)
treeea903ccb5eec9463f7ee0783ff8b7126d111e404 /astro
parentcf8562750b6cfed6c4c0e2ac2efe88d34ad507cf (diff)
downloadports-7ef396a3cf4e8b953f4dd90d27ebe80ce28cdba7.tar.gz
ports-7ef396a3cf4e8b953f4dd90d27ebe80ce28cdba7.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/xplanet/Makefile79
-rw-r--r--astro/xplanet/distinfo2
-rw-r--r--astro/xplanet/pkg-comment1
-rw-r--r--astro/xplanet/pkg-descr10
-rw-r--r--astro/xplanet/pkg-plist8
5 files changed, 100 insertions, 0 deletions
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
new file mode 100644
index 000000000000..a3178696ee14
--- /dev/null
+++ b/astro/xplanet/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: xplanet
+# Version required: 0.45
+# Date created: 22 Feb 2000
+# Whom: darius@dons.net.au
+#
+# $FreeBSD$
+#
+
+DISTNAME= xplanet-0.45
+CATEGORIES= astro x11
+MASTER_SITES= http://www.wrightflyer.org/~hari/xplanet/ \
+ http://www.radcyberzine.com/xglobe/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} photo_1600.jpg
+
+MAINTAINER= andrews@technologist.com
+
+LIB_DEPENDS= Imlib.5:${PORTSDIR}/graphics/imlib \
+ GL.14:${PORTSDIR}/graphics/Mesa3
+
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-map-extension=jpg
+MAN1= xplanet.1 xplanetbg.1
+
+.include <bsd.port.pre.mk>
+
+.if (!defined(USE_TK80) && !defined(USE_TK81) && !defined(USE_TK82) && !defined(USE_TK83))
+.if exists(${LOCALBASE}/bin/wish8.3)
+USE_TK83= yes
+.elif exists(${LOCALBASE}/bin/wish8.2)
+USE_TK82= yes
+.elif exists(${LOCALBASE}/bin/wish8.1)
+USE_TK81= yes
+.else
+USE_TK80= yes
+.endif
+.endif
+
+.if defined(USE_TK80)
+RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
+WISH= ${LOCALBASE}/bin/wish8.0
+TKVERMSG= "Using Tk 8.0"
+.endif
+
+.if defined(USE_TK81)
+RUN_DEPENDS= wish8.1:${PORTSDIR}/x11-toolkits/tk81
+WISH= ${LOCALBASE}/bin/wish8.1
+TKVERMSG= "Using Tk 8.1"
+.endif
+
+.if defined(USE_TK82)
+RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
+WISH= ${LOCALBASE}/bin/wish8.2
+TKVERMSG= "Using Tk 8.2"
+.endif
+
+.if defined(USE_TK83)
+RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+WISH= ${LOCALBASE}/bin/wish8.3
+TKVERMSG= "Using Tk 8.3"
+.endif
+
+CONFIGURE_ENV+= WISH=${WISH}
+
+pre-fetch:
+ @${ECHO} ${TKVERMSG}
+ @${ECHO} "Define USE_TK80, USE_TK81, USE_TK82, or USE_Tk83"
+ @${ECHO} "To use a different version of TK"
+
+pre-build:
+ @${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/auxfiles.h
+
+post-install:
+ @${INSTALL_DATA} ${DISTDIR}/photo_1600.jpg ${PREFIX}/share/xplanet/earth.jpg
+
+.include <bsd.port.post.mk>
diff --git a/astro/xplanet/distinfo b/astro/xplanet/distinfo
new file mode 100644
index 000000000000..0de03d04f71d
--- /dev/null
+++ b/astro/xplanet/distinfo
@@ -0,0 +1,2 @@
+MD5 (xplanet-0.45.tar.gz) = 17314d79c99c68104183b7b6b19f8f48
+MD5 (photo_1600.jpg) = 220cea978ce224c29dd0c1eb080ddb24
diff --git a/astro/xplanet/pkg-comment b/astro/xplanet/pkg-comment
new file mode 100644
index 000000000000..f330ef185567
--- /dev/null
+++ b/astro/xplanet/pkg-comment
@@ -0,0 +1 @@
+Draw pictures of the earth textured by an image
diff --git a/astro/xplanet/pkg-descr b/astro/xplanet/pkg-descr
new file mode 100644
index 000000000000..ec6abc514396
--- /dev/null
+++ b/astro/xplanet/pkg-descr
@@ -0,0 +1,10 @@
+Xplanet was inspired by Xearth, which renders an image of the earth into the X
+root window. Xplanet uses the Imlib library to read user supplied maps of the
+earth (or another planet). Orthographic and mercator projections can be
+rendered to the root window or saved to a file. An image that the user can
+rotate interactively can be popped up in a window using OpenGL or Mesa.
+
+WWW: http://www.wrightflyer.org/~hari/xplanet/
+Author: Hari Nair <hari@almuni.caltech.edu>
+
+--Will <andrews@technologist.com>
diff --git a/astro/xplanet/pkg-plist b/astro/xplanet/pkg-plist
new file mode 100644
index 000000000000..58ebacb076ba
--- /dev/null
+++ b/astro/xplanet/pkg-plist
@@ -0,0 +1,8 @@
+bin/xplanet
+bin/xplanetbg
+bin/tkxplanet
+share/xplanet/earth.jpg
+share/xplanet/earth-markers.txt
+share/xplanet/mars-markers.txt
+share/xplanet/moon-markers.txt
+@dirrm share/xplanet