aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2006-02-23 10:40:44 +0000
committerAde Lovett <ade@FreeBSD.org>2006-02-23 10:40:44 +0000
commit8503536d3896846d823f7f76be54e0a99da8d8b6 (patch)
tree1a89e4038216ead71b008f2a5091474964e1c341 /astro
parentc20d04e3929dbe1763fc1dfaaa677c2353cd7883 (diff)
downloadports-8503536d3896846d823f7f76be54e0a99da8d8b6.tar.gz
ports-8503536d3896846d823f7f76be54e0a99da8d8b6.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-setiathome/Makefile2
-rw-r--r--astro/celestia/Makefile2
-rw-r--r--astro/glunarclock/Makefile2
-rw-r--r--astro/gpsdrive/Makefile4
-rw-r--r--astro/gpsdrive/pkg-plist2
-rw-r--r--astro/libnova/Makefile4
-rw-r--r--astro/libnova/pkg-plist1
7 files changed, 10 insertions, 7 deletions
diff --git a/astro/boinc-setiathome/Makefile b/astro/boinc-setiathome/Makefile
index 3e3bc115ec20..55fd5f26e37a 100644
--- a/astro/boinc-setiathome/Makefile
+++ b/astro/boinc-setiathome/Makefile
@@ -76,7 +76,7 @@ FIND_SETI_BINARY=(cd ${WRKSRC}/client; make -V CLIENT_PROG)
pre-configure:
${TOUCH} ${WRKSRC}/missing
- cd ${WRKSRC}; ${ACLOCAL} -I ${LOCALBASE}/share/libtool${LIBTOOL_VERSION}/libltdl -I m4
+ cd ${WRKSRC}; ${ACLOCAL} -I ${LIBTOOL_SHAREDIR}/libltdl -I m4
do-install:
${MKDIR} ${BOINC_HOME}/projects/${SETI_SITE}
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index c8d132d84c9a..52e0888ed019 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -18,7 +18,7 @@ COMMENT= Scriptable space flight simulator for X
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
PLIST= ${WRKDIR}/plist
PORTDOCS= AUTHORS CelestiaKeyAssignments.txt ChangeLog \
coding-standards.html devguide.txt \
diff --git a/astro/glunarclock/Makefile b/astro/glunarclock/Makefile
index bc1d4691dc50..32246b5fcc59 100644
--- a/astro/glunarclock/Makefile
+++ b/astro/glunarclock/Makefile
@@ -21,7 +21,7 @@ USE_X_PREFIX= yes
USE_GNOME= gail gnomehack gnomepanel gnomeprefix gnometarget intlhack
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_OMF= yes
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index f1f6e7eb5792..fd847cf0e673 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gpsdrive
PORTVERSION= 2.09
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= astro
MASTER_SITES= http://www.gpsdrive.cc/ \
http://gpsdrive.teachlinux.com/
@@ -22,7 +22,7 @@ USE_PERL5= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk20
-USE_AUTOTOOLS= libtool:15:inc
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
diff --git a/astro/gpsdrive/pkg-plist b/astro/gpsdrive/pkg-plist
index f91e77f9cd78..e03b3b88f1e3 100644
--- a/astro/gpsdrive/pkg-plist
+++ b/astro/gpsdrive/pkg-plist
@@ -13,9 +13,11 @@ bin/gpssql_restore.sh
bin/wpcvt
bin/wpget
lib/libfly.a
+lib/libfly.la
lib/libfly.so
lib/libfly.so.2
lib/libnautic.a
+lib/libnautic.la
lib/libnautic.so
lib/libnautic.so.2
share/applications/gpsdrive.desktop
diff --git a/astro/libnova/Makefile b/astro/libnova/Makefile
index df4ffa9649db..33e95dcade13 100644
--- a/astro/libnova/Makefile
+++ b/astro/libnova/Makefile
@@ -8,7 +8,7 @@
PORTNAME= libnova
PORTVERSION= 0.11.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Astronomical Calculation Library
USE_GNOME= gnometarget lthack
-USE_AUTOTOOLS= libtool:15
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
diff --git a/astro/libnova/pkg-plist b/astro/libnova/pkg-plist
index aa47c07161af..fa911489a387 100644
--- a/astro/libnova/pkg-plist
+++ b/astro/libnova/pkg-plist
@@ -34,5 +34,6 @@ include/libnova/hyperbolic_motion.h
lib/libnova-0.11.so
lib/libnova-0.11.so.0
lib/libnova.a
+lib/libnova.la
lib/libnova.so
@dirrm include/libnova/