aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-06-10 22:03:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-06-10 22:03:56 +0000
commit92d656c84826275ab2ec391b54c36cd8fc50cf30 (patch)
treeecda66d40f0800b4d47db9d19e71f1548707e715 /astro
parent0f11dc56f2084bcf3fb40e2790cd7a5a5f632657 (diff)
downloadports-92d656c84826275ab2ec391b54c36cd8fc50cf30.tar.gz
ports-92d656c84826275ab2ec391b54c36cd8fc50cf30.zip
- Preserve version 1.4.4 of astro/gpsbabel as astro/gpsbabel14
Newer gpsbabel version needlessly pulls in heavyweight dependencies (such as qt4-gui, qt4-webkit) via qt4-linguist, and until that's resolved, it's useful to keep around older version which doesn't have such problem. PR: 190791 Approved by: dev2@heesakkers.info (maintainer)
Notes
Notes: svn path=/head/; revision=357391
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/gpsbabel14/Makefile28
-rw-r--r--astro/gpsbabel14/distinfo2
-rw-r--r--astro/gpsbabel14/files/patch-libusb31
-rw-r--r--astro/gpsbabel14/pkg-descr11
5 files changed, 73 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index fb4933cedd18..b42c63756d28 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -22,6 +22,7 @@
SUBDIR += gmapcatcher
SUBDIR += google-earth
SUBDIR += gpsbabel
+ SUBDIR += gpsbabel14
SUBDIR += gpscorrelate
SUBDIR += gpsd
SUBDIR += gpsdrive
diff --git a/astro/gpsbabel14/Makefile b/astro/gpsbabel14/Makefile
new file mode 100644
index 000000000000..781ff8defe38
--- /dev/null
+++ b/astro/gpsbabel14/Makefile
@@ -0,0 +1,28 @@
+# Created by: Laurent Courty
+# $FreeBSD$
+
+PORTNAME= gpsbabel
+PORTVERSION= 1.4.4
+CATEGORIES= astro geography
+MASTER_SITES= https://secure.ohos.nl/downloads/ \
+ LOCAL/beech
+PKGNAMESUFFIX= 14
+
+MAINTAINER= dev2@heesakkers.info
+COMMENT= GPS file translating tool (pre-qt version)
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
+
+USE_AUTOTOOLS= autoconf
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-expathdr=${LOCALBASE}/include \
+ --with-libexpat=${LOCALBASE}/lib
+
+PLIST_FILES= bin/gpsbabel
+
+CONFLICTS= gpsbabel-[0-9]*
+
+.include <bsd.port.mk>
diff --git a/astro/gpsbabel14/distinfo b/astro/gpsbabel14/distinfo
new file mode 100644
index 000000000000..466f8aa9697c
--- /dev/null
+++ b/astro/gpsbabel14/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gpsbabel-1.4.4.tar.gz) = 9dd2a06e887cb286c9a07164a8f2ede11aed1147e6419007370c528412321944
+SIZE (gpsbabel-1.4.4.tar.gz) = 7811264
diff --git a/astro/gpsbabel14/files/patch-libusb b/astro/gpsbabel14/files/patch-libusb
new file mode 100644
index 000000000000..4bf7613de5d0
--- /dev/null
+++ b/astro/gpsbabel14/files/patch-libusb
@@ -0,0 +1,31 @@
+--- configure.in.orig 2008-10-31 15:43:21.000000000 +0300
++++ configure.in 2009-03-07 01:08:46.000000000 +0300
+@@ -170,6 +169,28 @@
+ AC_DEFINE(HAVE_LIBUSB, 1)
+ CFLAGS="$CFLAGS -Imac/libusb/"
+ ;;
++ *-*-freebsd*)
++ GBSER=gbser_posix.o
++ AC_MSG_CHECKING(for libusb)
++ if test "$with_libusb" = no ; then
++ AC_MSG_RESULT(check not done)
++ OSJEEPS=jeeps/gpsusbstub.o
++ else
++ OLDFLAGS=$LDFLAGS
++ OCFLAGS=$CFLAGS
++ LDFLAGS="$LDFLAGS -lusb"
++ CFLAGS="$OCFLAGS"
++
++ AC_CHECK_LIB([usb], [usb_interrupt_read],
++ AC_DEFINE(HAVE_LIBUSB, 1, [Defined if you have libusb])
++ [USB_CFLAGS=""]
++ [USB_LIBS="-lusb"]
++# ,[AC_MSG_ERROR([libusb is needed])]
++ )
++ OSJEEPS=jeeps/gpslibusb.o
++ CFLAGS="$OCFLAGS"
++ fi
++ ;;
+ *)
+ GBSER=gbser_posix.o
+ AC_MSG_CHECKING(for libusb)
diff --git a/astro/gpsbabel14/pkg-descr b/astro/gpsbabel14/pkg-descr
new file mode 100644
index 000000000000..8e6d12435228
--- /dev/null
+++ b/astro/gpsbabel14/pkg-descr
@@ -0,0 +1,11 @@
+GPSBabel converts waypoints, tracks, and routes from one format to another,
+whether that format is a common mapping format like Delorme, Streets and Trips,
+or even a serial upload or download to a GPS unit such as those from Garmin and
+Magellan. By flattening the Tower of Babel that the authors of various programs
+for manipulating GPS data have imposed upon us, it returns to us the ability
+to freely move our own waypoint data between the programs and hardware we
+choose to use.
+It contains extensive data manipulation abilities making it a convenient for
+server-side processing or as the backend for other tools.
+
+WWW: http://www.gpsbabel.org/