aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-04-07 14:25:15 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-04-07 15:05:55 +0000
commitc71776b7673dd9fcbc84a187f2c76ab813f939f5 (patch)
treeb62bef720a86121756c4efae5179d96458e0434c /astro
parentff9b4950645a8910bc7f36d1ad6434205ab993ef (diff)
downloadports-c71776b7673dd9fcbc84a187f2c76ab813f939f5.tar.gz
ports-c71776b7673dd9fcbc84a187f2c76ab813f939f5.zip
astro/py-spktype01 et al.: fix the dependency on PYNUMPY
Some ports, like astro/py-spktype01, uses the undefined variable ${NUMPY} in their _DEPENDS fields and this must be replaced by the correct ${PYNUMPY}. PR: 254740 Reported by: Bojan Petrovic Approved by: QA blanket for the ports that I do not maintain
Diffstat (limited to 'astro')
-rw-r--r--astro/py-jplephem/Makefile5
-rw-r--r--astro/py-spktype01/Makefile5
-rw-r--r--astro/py-spktype21/Makefile5
3 files changed, 9 insertions, 6 deletions
diff --git a/astro/py-jplephem/Makefile b/astro/py-jplephem/Makefile
index 1793a559a74c..1ecfc593a17b 100644
--- a/astro/py-jplephem/Makefile
+++ b/astro/py-jplephem/Makefile
@@ -3,6 +3,7 @@
PORTNAME= jplephem
PORTVERSION= 2.15
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= astro python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,8 +12,8 @@ COMMENT= Python version of NASA DE4xx ephemerides
LICENSE= MIT
-BUILD_DEPENDS= ${NUMPY}
-RUN_DEPENDS= ${NUMPY}
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY}
TEST_DEPENDS= bash:shells/bash \
${PYTHON_PKGNAMEPREFIX}unittest2>0:devel/py-unittest2@${PY_FLAVOR}
diff --git a/astro/py-spktype01/Makefile b/astro/py-spktype01/Makefile
index 37242cfca00f..da47c3ddd62d 100644
--- a/astro/py-spktype01/Makefile
+++ b/astro/py-spktype01/Makefile
@@ -2,6 +2,7 @@
PORTNAME= spktype01
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= astro python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,8 +11,8 @@ COMMENT= Supporting module for jplephem to handle data type 1
LICENSE= MIT
-BUILD_DEPENDS= ${NUMPY}
-RUN_DEPENDS= ${NUMPY} \
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}jplephem>0:astro/py-jplephem@${PY_FLAVOR}
USE_GITHUB= yes
diff --git a/astro/py-spktype21/Makefile b/astro/py-spktype21/Makefile
index 5a9174ded8c1..0d7d729f5ea9 100644
--- a/astro/py-spktype21/Makefile
+++ b/astro/py-spktype21/Makefile
@@ -2,6 +2,7 @@
PORTNAME= spktype21
PORTVERSION= 0.1.0
+PORTREVISION= 1
CATEGORIES= astro python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,8 +11,8 @@ COMMENT= Supporting module for jplephem to handle data type 21
LICENSE= MIT
-BUILD_DEPENDS= ${NUMPY}
-RUN_DEPENDS= ${NUMPY} \
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}jplephem>0:astro/py-jplephem@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}spktype01>0:astro/py-spktype01@${PY_FLAVOR} \
py.test:devel/py-pytest@${PY_FLAVOR}