aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 14:20:29 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 14:31:01 +0000
commitcb8b43a5e2c03b1e9b8ffd5ab86b823b91ef17bd (patch)
treefdcbcc321d476525fd593278b7f522e5fa08bcdc /astro
parentdc17463a3f66cc05359fac8a58342b5fe2291de3 (diff)
downloadports-cb8b43a5e2c03b1e9b8ffd5ab86b823b91ef17bd.tar.gz
ports-cb8b43a5e2c03b1e9b8ffd5ab86b823b91ef17bd.zip
astro/py-horoscopegenerator: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
Diffstat (limited to 'astro')
-rw-r--r--astro/py-horoscopegenerator/Makefile6
-rw-r--r--astro/py-horoscopegenerator/files/patch-setup.py11
2 files changed, 15 insertions, 2 deletions
diff --git a/astro/py-horoscopegenerator/Makefile b/astro/py-horoscopegenerator/Makefile
index 23eb06835f69..2c40fb9b5976 100644
--- a/astro/py-horoscopegenerator/Makefile
+++ b/astro/py-horoscopegenerator/Makefile
@@ -1,6 +1,6 @@
PORTNAME= horoscopegenerator
PORTVERSION= 0.1.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= astro python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,10 +12,12 @@ WWW= https://github.com/mouse-reeve/horoscope-generator
LICENSE= MIT
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nltk>=0:textproc/py-nltk@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/astro/py-horoscopegenerator/files/patch-setup.py b/astro/py-horoscopegenerator/files/patch-setup.py
new file mode 100644
index 000000000000..641af8ec0499
--- /dev/null
+++ b/astro/py-horoscopegenerator/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2015-10-12 21:38:11 UTC
++++ setup.py
+@@ -9,7 +9,7 @@ setup(
+ long_description = f.read()
+
+ setup(
+- name='HoroscopeGenerator',
++ name='horoscopegenerator',
+ version='0.1.8',
+
+ description='Generates horoscopes',