aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-05-29 12:45:06 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-05-29 12:45:06 +0000
commitce8c2d1fdaf9594c27b4d2a346789083827f9238 (patch)
tree7f085d83aa25fe609f76303addc189d709e34de7 /astro
parentcb66c59c7b2be3407ea1047c8102cc2890b51cda (diff)
downloadports-ce8c2d1fdaf9594c27b4d2a346789083827f9238.tar.gz
ports-ce8c2d1fdaf9594c27b4d2a346789083827f9238.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/gnuastro/Makefile6
-rw-r--r--astro/gnuastro/distinfo6
-rw-r--r--astro/gnuastro/files/patch-bin_fits_keywords.c11
-rw-r--r--astro/gnuastro/files/patch-lib_fits.c41
-rw-r--r--astro/gnuastro/pkg-plist5
5 files changed, 63 insertions, 6 deletions
diff --git a/astro/gnuastro/Makefile b/astro/gnuastro/Makefile
index 9277512268f1..095901691999 100644
--- a/astro/gnuastro/Makefile
+++ b/astro/gnuastro/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gnuastro
-PORTVERSION= 0.11
+PORTVERSION= 0.12
CATEGORIES= astro
MASTER_SITES= GNU
@@ -28,6 +28,10 @@ PORTDOCS= AUTHORS ChangeLog NEWS README THANKS
OPTIONS_DEFINE= DOCS
+post-patch:
+ @${REINPLACE_CMD} -e 's,cflags_add="-O3",:,' \
+ ${WRKSRC}/configure
+
post-install:
@${FIND} ${STAGEDIR}${PREFIX}/etc -name \*.conf \
-exec ${MV} '{}' '{}.sample' \;
diff --git a/astro/gnuastro/distinfo b/astro/gnuastro/distinfo
index 476956efba31..eed71d837953 100644
--- a/astro/gnuastro/distinfo
+++ b/astro/gnuastro/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1574693798
-SHA256 (gnuastro-0.11.tar.lz) = 7bcc22311e69db17351a476df01dfd31009b0db06e2b6d525338efb3b0603e30
-SIZE (gnuastro-0.11.tar.lz) = 3490088
+TIMESTAMP = 1589989283
+SHA256 (gnuastro-0.12.tar.lz) = ced7ab6d3dca6913fc8df649070dc3a496b67e975b14e57a64e81c2c0e0bf37a
+SIZE (gnuastro-0.12.tar.lz) = 3533517
diff --git a/astro/gnuastro/files/patch-bin_fits_keywords.c b/astro/gnuastro/files/patch-bin_fits_keywords.c
new file mode 100644
index 000000000000..eaf2eab258e8
--- /dev/null
+++ b/astro/gnuastro/files/patch-bin_fits_keywords.c
@@ -0,0 +1,11 @@
+--- bin/fits/keywords.c.orig 2020-05-15 16:58:42 UTC
++++ bin/fits/keywords.c
+@@ -413,6 +413,8 @@ keywords_date_to_seconds(struct fitsparams *p, fitsfil
+ /* Return the number of seconds (and subseconds) that it corresponds
+ to. */
+ seconds=gal_fits_key_date_to_seconds(fitsdate, &subsecstr, &subsec);
++ if(seconds==GAL_BLANK_SIZE_T)
++ error(EXIT_FAILURE, 0, "the time string couldn't be interpretted");
+
+ /* Print the result (for the sub-seconds, print everything after the */
+ if( !p->cp.quiet )
diff --git a/astro/gnuastro/files/patch-lib_fits.c b/astro/gnuastro/files/patch-lib_fits.c
new file mode 100644
index 000000000000..88244d9a798e
--- /dev/null
+++ b/astro/gnuastro/files/patch-lib_fits.c
@@ -0,0 +1,41 @@
+--- lib/fits.c.orig 2020-05-15 16:58:42 UTC
++++ lib/fits.c
+@@ -1023,6 +1023,7 @@ gal_fits_key_date_to_seconds(char *fitsdate, char **su
+ time_t t;
+ char *tmp;
+ struct tm tp;
++ size_t seconds;
+ void *outptr=subsec;
+
+ /* Fill in the 'tp' elements with values read from the string. */
+@@ -1044,14 +1045,23 @@ gal_fits_key_date_to_seconds(char *fitsdate, char **su
+ tmp);
+ }
+
+- /* Convert the 'tm' structure to 'time_t'. Note that the system's
+- timezone and daylight saving need to be subtracted from the output of
+- 'mktime'. Otherwise the result will be different on different
+- host-system timezones (which is not what we want here: bug #57995). */
+- t=mktime(&tp)-timezone-daylight;
++ /* Convert the contents of the 'tm' structure to 'time_t' (a positive
++ integer) with 'mktime'. Note that by design, the system's timezone is
++ included in the returned value of 'mktime' (leading to situations like
++ bug #57995). But it writes the given time's timezone (number of
++ seconds ahead of UTC) in the 'tm_gmtoff' element of its input.
+
+- /* Return the value and set the output pointer. */
+- return (size_t)t;
++ IMPORTANT NOTE: the timezone that is calculated by 'mktime' (in
++ 'tp.tm_gmtoff') belongs to the time that is already within 'tp' (this
++ is exactly what we want!). So for example when daylight saving is
++ activated at run-time, but at the time inside 'tp', there was no
++ daylight saving, the value of 'tp.tm_gmtoff' will be different from
++ the 'timezone' global variable. */
++ t=mktime(&tp);
++
++ /* Calculate the seconds and return it. */
++ seconds = (t == (time_t)(-1)) ? GAL_BLANK_SIZE_T : (t+tp.tm_gmtoff);
++ return seconds;
+ }
+
+
diff --git a/astro/gnuastro/pkg-plist b/astro/gnuastro/pkg-plist
index aaff89433fee..007b86fb1440 100644
--- a/astro/gnuastro/pkg-plist
+++ b/astro/gnuastro/pkg-plist
@@ -64,11 +64,12 @@ include/gnuastro/tiff.h
include/gnuastro/tile.h
include/gnuastro/txt.h
include/gnuastro/type.h
+include/gnuastro/units.h
include/gnuastro/wcs.h
lib/libgnuastro.a
lib/libgnuastro.so
-lib/libgnuastro.so.9
-lib/libgnuastro.so.9.0.0
+lib/libgnuastro.so.10
+lib/libgnuastro.so.10.0.0
libdata/pkgconfig/gnuastro.pc
man/man1/astarithmetic.1.gz
man/man1/astbuildprog.1.gz