aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-12 21:42:19 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-12 21:42:19 +0000
commite4f0c42ffcdc08fc7db35cb69324c41ce7a8f4e1 (patch)
treef7aec3f2acddb92b3a794a9de611c0cd2cf95b20 /astro
parent3b099900ffd246d14f906932505f6aef45d93780 (diff)
downloadports-e4f0c42ffcdc08fc7db35cb69324c41ce7a8f4e1.tar.gz
ports-e4f0c42ffcdc08fc7db35cb69324c41ce7a8f4e1.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/phoon/Makefile8
-rw-r--r--astro/phoon/files/patch-Makefile32
-rw-r--r--astro/phoon/files/patch-astro.h4
-rw-r--r--astro/phoon/files/patch-phoon.c4
4 files changed, 37 insertions, 11 deletions
diff --git a/astro/phoon/Makefile b/astro/phoon/Makefile
index 5fa4a28e6150..f311dd3fbc34 100644
--- a/astro/phoon/Makefile
+++ b/astro/phoon/Makefile
@@ -13,13 +13,7 @@ COMMENT= Displays the phase of the moon
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
- BINDIR=${LOCALBASE}/bin \
- MANDIR=${MANPREFIX}/man/man1
-
-NO_STAGE= yes
-MAN1= phoon.1
-PLIST_FILES= bin/phoon
+PLIST_FILES= bin/phoon man/man1/phoon.1.gz
pre-patch:
@${REINPLACE_CMD} -e 's|gmtoff = !!!;||g' \
diff --git a/astro/phoon/files/patch-Makefile b/astro/phoon/files/patch-Makefile
new file mode 100644
index 000000000000..f01683bd8fab
--- /dev/null
+++ b/astro/phoon/files/patch-Makefile
@@ -0,0 +1,32 @@
+--- ./Makefile.orig 2003-01-21 04:04:36.000000000 +0100
++++ ./Makefile 2014-02-12 22:39:19.404018490 +0100
+@@ -1,15 +1,15 @@
+ # Makefile for phoon
+
+-BINDIR = /usr/local/bin
+-MANDIR = /usr/local/man/man1
++BINDIR = $(DESTDIR)$(PREFIX)/bin
++MANDIR = $(DESTDIR)$(MANPREFIX)/man/man1
+
+ DEFINES = -DOS_BSD
+ #DEFINES = -DOS_SYSV
+
+-CC = gcc
+-CFLAGS = -O $(DEFINES)
++CC ?= gcc
++CFLAGS += $(DEFINES)
+
+-LDFLAGS = -s
++#LDFLAGS = -s
+
+
+ all: phoon
+@@ -24,7 +24,7 @@
+ astro.o: astro.h
+
+ install: all
+- rm -f $(BINDIR)/phoon
++ strip phoon
+ cp phoon $(BINDIR)
+ rm -f $(MANDIR)/phoon.1
+ cp phoon.1 $(MANDIR)
diff --git a/astro/phoon/files/patch-astro.h b/astro/phoon/files/patch-astro.h
index 9c1eec562f52..22929650029c 100644
--- a/astro/phoon/files/patch-astro.h
+++ b/astro/phoon/files/patch-astro.h
@@ -1,5 +1,5 @@
---- astro.h.orig Sun Mar 6 22:43:59 2005
-+++ astro.h Sun Mar 6 22:44:05 2005
+--- ./astro.h.orig 2003-01-28 01:55:32.000000000 +0100
++++ ./astro.h 2014-02-12 22:38:52.437019902 +0100
@@ -43,4 +43,4 @@
*/
extern double phase( double pdate, double* pphase, double* mage, double* dist, double* angdia, double* sudist, double* suangdia );
diff --git a/astro/phoon/files/patch-phoon.c b/astro/phoon/files/patch-phoon.c
index af5de8cb327b..b59e6679f2cf 100644
--- a/astro/phoon/files/patch-phoon.c
+++ b/astro/phoon/files/patch-phoon.c
@@ -1,5 +1,5 @@
---- phoon.c.orig Sun Mar 6 22:33:22 2005
-+++ phoon.c Sun Mar 6 22:33:45 2005
+--- ./phoon.c.orig 2005-05-20 21:10:24.000000000 +0200
++++ ./phoon.c 2014-02-12 22:38:52.438019914 +0100
@@ -354,7 +354,7 @@
struct tm* tmP;
double jd, pctphase, angphase, cphase, aom, cdist, cangdia, csund, csuang;