aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-24 07:17:34 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-24 07:17:34 +0000
commitfd14ff637e764c2099849ec4f08a3405887d119a (patch)
tree22a30f382701bf09edd4bc08db781e414daec968 /astro
parent0c6a2f48fb9b392029a87a7e75423b9bdff78fa5 (diff)
downloadports-fd14ff637e764c2099849ec4f08a3405887d119a.tar.gz
ports-fd14ff637e764c2099849ec4f08a3405887d119a.zip
add pp3 1.3.2
PP3 creates celestial charts
Notes
Notes: svn path=/head/; revision=96516
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/pp3/Makefile37
-rw-r--r--astro/pp3/distinfo1
-rw-r--r--astro/pp3/pkg-descr5
-rw-r--r--astro/pp3/pkg-plist103
5 files changed, 147 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index d7a4a55afec3..3cf4c4a32c7e 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -40,6 +40,7 @@
SUBDIR += p5-SETI-Stats
SUBDIR += phoon
SUBDIR += planets
+ SUBDIR += pp3
SUBDIR += py-metar
SUBDIR += pyweather
SUBDIR += rmap
diff --git a/astro/pp3/Makefile b/astro/pp3/Makefile
new file mode 100644
index 000000000000..bc894486787f
--- /dev/null
+++ b/astro/pp3/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: pp3
+# Date created: Dec 24, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pp3
+PORTVERSION= 1.3.2
+CATEGORIES= astro
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PP3 creates celestial charts
+
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+USE_BZIP2= yes
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${CXX} ${CXXFLAGS} -DPP3DATA=\"${DATADIR}\" pp3.cc -o pp3
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pp3 ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.dat ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/pp3.ps ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/astro/pp3/distinfo b/astro/pp3/distinfo
new file mode 100644
index 000000000000..3f621d020b48
--- /dev/null
+++ b/astro/pp3/distinfo
@@ -0,0 +1 @@
+MD5 (pp3-1.3.2.tar.bz2) = 94225d3492b57f3edbf39ab72452811e
diff --git a/astro/pp3/pkg-descr b/astro/pp3/pkg-descr
new file mode 100644
index 000000000000..ccfc986073d9
--- /dev/null
+++ b/astro/pp3/pkg-descr
@@ -0,0 +1,5 @@
+PP3 creates celestial charts. It generates resolution independent maps of very
+high graphical quality. They can be used for example as illustrations in books
+or on web pages. You may use own databases or free ones from the Internet.
+
+WWW: http://pp3.sourceforge.net/
diff --git a/astro/pp3/pkg-plist b/astro/pp3/pkg-plist
new file mode 100644
index 000000000000..30e78dda3c5a
--- /dev/null
+++ b/astro/pp3/pkg-plist
@@ -0,0 +1,103 @@
+bin/pp3
+%%DATADIR%%/boundaries.dat
+%%DATADIR%%/lines.dat
+%%DATADIR%%/milkyway.dat
+%%DATADIR%%/nebulae.dat
+%%DATADIR%%/stars.dat
+@dirrm %%DATADIR%%
+%%PORTDOCS%%%%DOCSDIR%%/pp3.ps
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/andromeda.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/antlia.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/apus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/aquarius.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/aquila.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/ara.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/aries.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/auriga.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/bootes.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/caelum.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/camelopardalis.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/cancer.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/canes_venatici.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/canis_major.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/canis_minor.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/capricornus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/carina.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/cassiopeia.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/centaurus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/cepheus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/cetus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/chamaeleon.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/circinus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/columba.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/coma_berenices.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/corona_australis.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/corona_borealis.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/corvus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/crater.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/crux.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/cygnus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/delphinus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/dorado.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/draco.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/equuleus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/eridanus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/fornax.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/gemini.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/grus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/hercules.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/horologium.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/hydra.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/hydrus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/indus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/lacerta.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/leo.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/leo_minor.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/lepus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/libra.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/lupus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/lynx.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/lyra.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/mensa.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/microscopium.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/monoceros.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/musca.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/nh.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/norma.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/octans.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/ophiuchus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/orion.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/pavo.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/pegasus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/perseus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/phoenix.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/pictor.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/pisces.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/piscis_austrinus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/puppis.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/pyxis.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/reticulum.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/sagitta.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/sagittarius.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/scorpius.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/sculptor.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/scutum.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/serpens.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/sextans.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/taurus.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/telescopium.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/triangulum.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/triangulum_australe.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/tucana.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/ursa_major.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/ursa_minor.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/vela.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/virgo.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/volans.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/vulpecula.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/wiki-convert-sky-chart.scm
+%%PORTDOCS%%%%EXAMPLESDIR%%/wiki.pp3
+%%PORTDOCS%%%%EXAMPLESDIR%%/wiki.tex
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%