aboutsummaryrefslogtreecommitdiff
path: root/audio/adplay
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-05-31 21:24:38 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-05-31 21:24:38 +0000
commit17f5e78f0aa955101045aca96ab73de13b460f3a (patch)
treeade380fef889d59bb29996ab38320449382876f6 /audio/adplay
parent165b7a397f7d14491f2ff6c24b811022089c0f16 (diff)
downloadports-17f5e78f0aa955101045aca96ab73de13b460f3a.tar.gz
ports-17f5e78f0aa955101045aca96ab73de13b460f3a.zip
- Use USE_GCC=3.4+ for upcoming audio/ocp release.
PR: ports/81703 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=136563
Diffstat (limited to 'audio/adplay')
-rw-r--r--audio/adplay/Makefile5
-rw-r--r--audio/adplay/files/getopt.h82
2 files changed, 86 insertions, 1 deletions
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index e1b8a10ee2ac..823a36ba68d7 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -7,7 +7,7 @@
PORTNAME= adplay
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= adplug
@@ -20,6 +20,7 @@ LIB_DEPENDS= adplug-1.5.1:${PORTSDIR}/audio/libadplug
PLIST_FILES= bin/adplay
GNU_CONFIGURE= yes
+USE_GCC= 3.4+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -36,6 +37,8 @@ MAN1= adplay.1
post-patch:
.if ${OSVERSION} > 500000
${RM} ${WRKSRC}/src/getopt.h
+.else
+ ${CP} ${FILESDIR}/getopt.h ${WRKSRC}/src/
.endif
do-install:
diff --git a/audio/adplay/files/getopt.h b/audio/adplay/files/getopt.h
new file mode 100644
index 000000000000..67cdaf36ba3a
--- /dev/null
+++ b/audio/adplay/files/getopt.h
@@ -0,0 +1,82 @@
+/*-
+ * Copyright (c) 2000 The NetBSD Foundation, Inc.
+ * All rights reserved.
+ *
+ * This code is derived from software contributed to The NetBSD Foundation
+ * by Dieter Baron and Thomas Klausner.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ * 3. All advertising materials mentioning features or use of this software
+ * must display the following acknowledgement:
+ * This product includes software developed by the NetBSD
+ * Foundation, Inc. and its contributors.
+ * 4. Neither the name of The NetBSD Foundation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND CONTRIBUTORS
+ * ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
+ * TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS
+ * BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#ifndef _GETOPT_H_
+#define _GETOPT_H_
+
+#include <sys/cdefs.h>
+
+/*
+ * GNU-like getopt_long()/getopt_long_only() with 4.4BSD optreset extension.
+ * getopt() is declared here too for GNU programs.
+ */
+#define no_argument 0
+#define required_argument 1
+#define optional_argument 2
+
+struct option {
+ /* name of long option */
+ const char *name;
+ /*
+ * one of no_argument, required_argument, and optional_argument:
+ * whether option takes an argument
+ */
+ int has_arg;
+ /* if not NULL, set *flag to val when option found */
+ int *flag;
+ /* if flag not NULL, value to set *flag to; else return value */
+ int val;
+};
+
+__BEGIN_DECLS
+int getopt_long(int, char * const *, const char *,
+ const struct option *, int *);
+int getopt_long_only(int, char * const *, const char *,
+ const struct option *, int *);
+#ifndef _GETOPT_DECLARED
+#define _GETOPT_DECLARED
+int getopt(int, char * const [], const char *);
+
+extern char *optarg; /* getopt(3) external variables */
+extern int optind, opterr, optopt;
+#endif
+#ifndef _OPTRESET_DECLARED
+#define _OPTRESET_DECLARED
+extern int optreset; /* getopt(3) externalvariable */
+#endif
+__END_DECLS
+
+#endif /* !_GETOPT_H_ */