aboutsummaryrefslogtreecommitdiff
path: root/audio/adplay
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-10 19:50:23 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-10 19:50:23 +0000
commit3b7bd0a1490f574288fc9a02617a19cf238254e0 (patch)
treec05d182f965de6bace293ed87ece71bd45e7c422 /audio/adplay
parent913e08e52dca0eafb130dc0942c6275a178095ea (diff)
downloadports-3b7bd0a1490f574288fc9a02617a19cf238254e0.tar.gz
ports-3b7bd0a1490f574288fc9a02617a19cf238254e0.zip
Fix problems with missing libs when the linker enforces explicit linking
(a* to d* categories) PR: 192062
Notes
Notes: svn path=/head/; revision=364564
Diffstat (limited to 'audio/adplay')
-rw-r--r--audio/adplay/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index 1ff497127589..2a1e20d2d318 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -3,7 +3,7 @@
PORTNAME= adplay
PORTVERSION= 1.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= SF/adplug/AdPlay_UNIX/${PORTVERSION}:main \
SF/adplug/Database/2006-07-06:db
@@ -19,13 +19,14 @@ LIB_DEPENDS= libadplug.so:${PORTSDIR}/audio/libadplug \
libbinio.so:${PORTSDIR}/devel/libbinio
GNU_CONFIGURE= yes
+USES= libtool
WANT_SDL= yes
DBFILE= adplug.db
DBVERSION= 2006-07-07
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libbinio
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lbinio
CONFIGURE_ARGS+= --sharedstatedir=${DATADIR}
@@ -43,6 +44,7 @@ CONFIGURE_ARGS+= --disable-output-sdl
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's/-lstdc++//g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|^\(adplug_data_dir.*\)/.*|\1|' \
${WRKSRC}/src/Makefile.in
@${RM} ${WRKSRC}/src/getopt.h