aboutsummaryrefslogtreecommitdiff
path: root/audio/adplay
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-22 12:31:35 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-22 12:31:35 +0000
commitafcce3aafb26a442d6bef8c3c5bea3ee7c75f660 (patch)
treee104cdb676df5b3f5a77f1a69ef4fd3c6bed01b7 /audio/adplay
parentf78e7c214c5496aa451fc153f8892d750cd851e0 (diff)
downloadports-afcce3aafb26a442d6bef8c3c5bea3ee7c75f660.tar.gz
ports-afcce3aafb26a442d6bef8c3c5bea3ee7c75f660.zip
Add optional SDL output support.
Notes
Notes: svn path=/head/; revision=163091
Diffstat (limited to 'audio/adplay')
-rw-r--r--audio/adplay/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index 8aeac17ca42f..4fee9d6d6789 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -7,7 +7,7 @@
PORTNAME= adplay
PORTVERSION= 1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= adplug
@@ -21,6 +21,7 @@ COMMENT= AdLib player using adplug library
LIB_DEPENDS= adplug-2.0.0:${PORTSDIR}/audio/libadplug
GNU_CONFIGURE= yes
+WANT_SDL= yes
USE_GCC= 3.4+
DBFILE= adplug.db
@@ -38,8 +39,14 @@ MAN1= adplay.1
PLIST_FILES= bin/adplay %%DATADIR%%/adplug.db
PLIST_DIRS= %%DATADIR%%
+OPTIONS= SDL "Build with SDL output support" off
+
.include <bsd.port.pre.mk>
+.if defined(WITH_SDL)
+USE_SDL= sdl mixer
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|^\(adplug_data_dir.*\)/.*|\1|' \
${WRKSRC}/src/Makefile.in