aboutsummaryrefslogtreecommitdiff
path: root/audio/adplay
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-08 10:50:02 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-08 10:50:02 +0000
commitc465c849a502ae9c63b73f0e40fd28459bd8ea13 (patch)
tree6829275b329b71b8c3eff538da1c668c6509b81b /audio/adplay
parent20a43c10f533f8d2aad4a6cd44ebda9fe2d14db3 (diff)
downloadports-c465c849a502ae9c63b73f0e40fd28459bd8ea13.tar.gz
ports-c465c849a502ae9c63b73f0e40fd28459bd8ea13.zip
audio/adplay: fix build on GCC architectures
Use C++11 compiler: /usr/local/lib/libadplug.so: undefined reference to `std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >::append(char const*)@GLIBCXX_3.4.21' MFH: 2020Q3 (fix build blanket)
Notes
Notes: svn path=/head/; revision=541485
Diffstat (limited to 'audio/adplay')
-rw-r--r--audio/adplay/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index cbc131c980bb..26379a2402b3 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libadplug.so:audio/libadplug \
libbinio.so:devel/libbinio
-USES= autoreconf libtool pkgconfig
+USES= autoreconf compiler:c++11-lang libtool pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= adplug