aboutsummaryrefslogtreecommitdiff
path: root/audio/adplay
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2007-04-21 12:45:05 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2007-04-21 12:45:05 +0000
commitda356db143d04ac3fb7496eff8adf65c6080be6e (patch)
tree0f7488c7d73d76ccaa6fcc30389c13d7811948a0 /audio/adplay
parent23cf828e5415d658c2a3414863753c7faa3c44bd (diff)
downloadports-da356db143d04ac3fb7496eff8adf65c6080be6e.tar.gz
ports-da356db143d04ac3fb7496eff8adf65c6080be6e.zip
Update to 1.6
Notes
Notes: svn path=/head/; revision=190537
Diffstat (limited to 'audio/adplay')
-rw-r--r--audio/adplay/Makefile7
-rw-r--r--audio/adplay/distinfo6
-rw-r--r--audio/adplay/files/getopt.h82
-rw-r--r--audio/adplay/files/patch-src_adplay.cc21
4 files changed, 7 insertions, 109 deletions
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index 2878d9a64dc3..09e9201b33f4 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= adplay
-PORTVERSION= 1.5
-PORTREVISION= 4
+PORTVERSION= 1.6
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= adplug
@@ -18,7 +17,7 @@ EXTRACT_ONLY= ${PORTNAME}-${DISTVERSIONPREFIX}${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= AdLib player using adplug library
-LIB_DEPENDS= adplug-2.0.1.0:${PORTSDIR}/audio/libadplug
+LIB_DEPENDS= adplug-2.1:${PORTSDIR}/audio/libadplug
GNU_CONFIGURE= yes
WANT_SDL= yes
@@ -45,6 +44,8 @@ OPTIONS= SDL "Build with SDL output support" off
.if defined(WITH_SDL)
USE_SDL= sdl mixer
+.else
+CONFIGURE_ARGS+= --disable-output-sdl
.endif
post-patch:
diff --git a/audio/adplay/distinfo b/audio/adplay/distinfo
index 8ca2ad8528ef..8863253da767 100644
--- a/audio/adplay/distinfo
+++ b/audio/adplay/distinfo
@@ -1,6 +1,6 @@
-MD5 (adplay-1.5.tar.gz) = 159edf8e4d6290752ab21df8f3dc7f3e
-SHA256 (adplay-1.5.tar.gz) = 8124693ebbbc3f99eae36b76fa5fff74aaf09ad66dc40ced17f4502860427fbb
-SIZE (adplay-1.5.tar.gz) = 339687
+MD5 (adplay-1.6.tar.gz) = ccec12e1e98020be5d1bbd79e58a04e8
+SHA256 (adplay-1.6.tar.gz) = 19f7ea654c6996b1a7dcd03ce0018ad9b88308ab67c488090fa0485902f0e9cd
+SIZE (adplay-1.6.tar.gz) = 357880
MD5 (adplug.db) = 5cbd3df5537700f28c350dbe08695c28
SHA256 (adplug.db) = 7db721bf259b7768556c3ddcb6a704a1093bb01a6373b519b27cdcfd8e88bd32
SIZE (adplug.db) = 3184
diff --git a/audio/adplay/files/getopt.h b/audio/adplay/files/getopt.h
deleted file mode 100644
index 67cdaf36ba3a..000000000000
--- a/audio/adplay/files/getopt.h
+++ /dev/null
@@ -1,82 +0,0 @@
-/*-
- * Copyright (c) 2000 The NetBSD Foundation, Inc.
- * All rights reserved.
- *
- * This code is derived from software contributed to The NetBSD Foundation
- * by Dieter Baron and Thomas Klausner.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- * 3. All advertising materials mentioning features or use of this software
- * must display the following acknowledgement:
- * This product includes software developed by the NetBSD
- * Foundation, Inc. and its contributors.
- * 4. Neither the name of The NetBSD Foundation nor the names of its
- * contributors may be used to endorse or promote products derived
- * from this software without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND CONTRIBUTORS
- * ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
- * TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS
- * BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
- * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
- * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
- * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
- * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
- * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
-#ifndef _GETOPT_H_
-#define _GETOPT_H_
-
-#include <sys/cdefs.h>
-
-/*
- * GNU-like getopt_long()/getopt_long_only() with 4.4BSD optreset extension.
- * getopt() is declared here too for GNU programs.
- */
-#define no_argument 0
-#define required_argument 1
-#define optional_argument 2
-
-struct option {
- /* name of long option */
- const char *name;
- /*
- * one of no_argument, required_argument, and optional_argument:
- * whether option takes an argument
- */
- int has_arg;
- /* if not NULL, set *flag to val when option found */
- int *flag;
- /* if flag not NULL, value to set *flag to; else return value */
- int val;
-};
-
-__BEGIN_DECLS
-int getopt_long(int, char * const *, const char *,
- const struct option *, int *);
-int getopt_long_only(int, char * const *, const char *,
- const struct option *, int *);
-#ifndef _GETOPT_DECLARED
-#define _GETOPT_DECLARED
-int getopt(int, char * const [], const char *);
-
-extern char *optarg; /* getopt(3) external variables */
-extern int optind, opterr, optopt;
-#endif
-#ifndef _OPTRESET_DECLARED
-#define _OPTRESET_DECLARED
-extern int optreset; /* getopt(3) externalvariable */
-#endif
-__END_DECLS
-
-#endif /* !_GETOPT_H_ */
diff --git a/audio/adplay/files/patch-src_adplay.cc b/audio/adplay/files/patch-src_adplay.cc
deleted file mode 100644
index 600fdf958a82..000000000000
--- a/audio/adplay/files/patch-src_adplay.cc
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/adplay.cc.orig Fri May 6 19:23:17 2005
-+++ src/adplay.cc Fri May 6 19:23:24 2005
-@@ -25,16 +25,15 @@
- #include <adplug/adplug.h>
- #include <adplug/emuopl.h>
- #include <adplug/kemuopl.h>
-+#include <getopt.h>
-
- /*
-- * Apple (OS X) and Sun systems declare getopt in unistd.h, other systems
-- * (Linux) use getopt.h.
-- */
- #if defined ( __APPLE__ ) || ( defined (__SVR4) && defined (__sun) )
- # include <unistd.h>
- #else
- # include "getopt.h"
- #endif
-+*/
-
- #include "defines.h"
- #include "output.h"