aboutsummaryrefslogtreecommitdiff
path: root/audio/aften
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-04-10 16:12:05 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-04-10 16:12:05 +0000
commit2383f20ce6b08213b76ec028b0b9f6432dd72221 (patch)
treed5d6cce64eda71fa5f0e45611f3f3f0a8447992c /audio/aften
parent14b4ac648c247a47fc2f00a9d1cd47942723e6b6 (diff)
downloadports-2383f20ce6b08213b76ec028b0b9f6432dd72221.tar.gz
ports-2383f20ce6b08213b76ec028b0b9f6432dd72221.zip
Aften is an audio encoder which generates compressed audio streams based
on ATSC A/52 specification. This type of audio is also known as AC-3 or Dolby(R) Digital and is one of the audio codecs used in DVD-Video content. WWW: http://aften.sourceforge.net/
Notes
Notes: svn path=/head/; revision=252529
Diffstat (limited to 'audio/aften')
-rw-r--r--audio/aften/Makefile58
-rw-r--r--audio/aften/distinfo3
-rw-r--r--audio/aften/files/patch-libaften__cpu_caps.h10
-rw-r--r--audio/aften/pkg-descr6
-rw-r--r--audio/aften/pkg-plist15
5 files changed, 92 insertions, 0 deletions
diff --git a/audio/aften/Makefile b/audio/aften/Makefile
new file mode 100644
index 000000000000..649283cae144
--- /dev/null
+++ b/audio/aften/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: aften
+# Date created: April 3, 2010
+# Whom: Gabor Zahemszky <Gabor@Zahemszky.HU>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aften
+PORTVERSION= 0.0.8
+CATEGORIES= audio
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= Gabor@Zahemszky.HU
+COMMENT= ATSC A/52 audio encoder
+
+USE_BZIP2= yes
+
+BUILDDIR= ${WRKSRC}/portbuild
+BUILD_WRKSRC= ${BUILDDIR}
+INSTALL_WRKSRC= ${BUILDDIR}
+
+USE_CMAKE= yes
+CMAKE_ARGS+= -DCMAKE_INSTALL_PREFIX:STRING="${PREFIX}"
+
+OPTIONS= SHARED_LIB "Build with shared library" off \
+ CXX_BINDINGS "Build with C++ bindings" off \
+ DOUBLE "Use double precision" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SHARED_LIB)
+CMAKE_ARGS+= -DSHARED:BOOL=ON
+.endif
+
+.if defined(WITH_CXX_BINDINGS)
+CMAKE_ARGS+= -DBINDINGS_CXX:BOOL=ON
+PLIST_SUB+= CXX=""
+.else
+PLIST_SUB+= CXX="@comment "
+.endif
+
+.if defined(WITH_SHARED_LIB) || defined(WITH_CXX_BINDINGS)
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+PLIST_SUB+= LIBS=""
+USE_LDCONFIG= yes
+.else
+PLIST_SUB+= LIBS="@comment "
+.endif
+
+.if defined(WITH_DOUBLE)
+CMAKE_ARGS+= -DDOUBLE:BOOL=ON
+.endif
+
+do-configure:
+ @${MKDIR} ${BUILDDIR}
+ @cd ${BUILDDIR}; ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ..
+
+.include <bsd.port.post.mk>
diff --git a/audio/aften/distinfo b/audio/aften/distinfo
new file mode 100644
index 000000000000..3e9694c30a29
--- /dev/null
+++ b/audio/aften/distinfo
@@ -0,0 +1,3 @@
+MD5 (aften-0.0.8.tar.bz2) = fde67146879febb81af3d95a62df8840
+SHA256 (aften-0.0.8.tar.bz2) = 87cc847233bb92fbd5bed49e2cdd6932bb58504aeaefbfd20ecfbeb9532f0c0a
+SIZE (aften-0.0.8.tar.bz2) = 80865
diff --git a/audio/aften/files/patch-libaften__cpu_caps.h b/audio/aften/files/patch-libaften__cpu_caps.h
new file mode 100644
index 000000000000..df018924efc2
--- /dev/null
+++ b/audio/aften/files/patch-libaften__cpu_caps.h
@@ -0,0 +1,10 @@
+--- ./libaften/cpu_caps.h.orig 2007-08-11 18:13:25.000000000 +0200
++++ ./libaften/cpu_caps.h 2010-04-03 00:31:40.000000000 +0200
+@@ -26,6 +26,7 @@
+ #include "ppc_cpu_caps.h"
+ #else
+ static inline void cpu_caps_detect(void){}
++static inline void apply_simd_restrictions(__unused AftenSimdInstructions *simd_instructions){}
+ #endif
+
+ #endif /* CPU_CAPS_H */
diff --git a/audio/aften/pkg-descr b/audio/aften/pkg-descr
new file mode 100644
index 000000000000..cce1f3658fca
--- /dev/null
+++ b/audio/aften/pkg-descr
@@ -0,0 +1,6 @@
+Aften is an audio encoder which generates compressed audio streams based
+on ATSC A/52 specification. This type of audio is also known as AC-3 or
+Dolby(R) Digital and is one of the audio codecs used in DVD-Video
+content.
+
+WWW: http://aften.sourceforge.net/
diff --git a/audio/aften/pkg-plist b/audio/aften/pkg-plist
new file mode 100644
index 000000000000..54867cb8fa2d
--- /dev/null
+++ b/audio/aften/pkg-plist
@@ -0,0 +1,15 @@
+@comment $FreeBSD$
+bin/aften
+bin/wavfilter
+bin/wavinfo
+bin/wavrms
+include/aften/aften.h
+%%CXX%%include/aften/aftenxx.h
+include/aften/aften-types.h
+%%LIBS%%lib/libaften.so.%%PORTVERSION%%
+%%LIBS%%lib/libaften.so.0
+%%LIBS%%lib/libaften.so
+%%LIBS%%%%CXX%%lib/libaftenxx.so.%%PORTVERSION%%
+%%LIBS%%%%CXX%%lib/libaftenxx.so.0
+%%LIBS%%%%CXX%%lib/libaftenxx.so
+@dirrm include/aften