aboutsummaryrefslogtreecommitdiff
path: root/audio/alac
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-08 07:57:21 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-08 07:57:21 +0000
commitc6f554d2265c5313c00d4a1683c42d5acea05bce (patch)
treef309cd7ff9fa2eced1325f8486142fee825d8e16 /audio/alac
parent5d53cceff69b98788ba992084860f99efdfd0464 (diff)
downloadports-c6f554d2265c5313c00d4a1683c42d5acea05bce.tar.gz
ports-c6f554d2265c5313c00d4a1683c42d5acea05bce.zip
Add audio/alac
Basic decoder for Apple Lossless Audio Codec files (ALAC)
Notes
Notes: svn path=/head/; revision=130593
Diffstat (limited to 'audio/alac')
-rw-r--r--audio/alac/Makefile39
-rw-r--r--audio/alac/distinfo2
-rw-r--r--audio/alac/pkg-descr3
3 files changed, 44 insertions, 0 deletions
diff --git a/audio/alac/Makefile b/audio/alac/Makefile
new file mode 100644
index 000000000000..809312de605c
--- /dev/null
+++ b/audio/alac/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: alac
+# Date created: 2005-03-08
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alac
+PORTVERSION= 0.1.0
+CATEGORIES= audio
+MASTER_SITES= http://crazney.net/programs/itunes/files/
+DISTNAME= ${PORTNAME}_decoder-${PORTVERSION}
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Basic decoder for Apple Lossless Audio Codec files (ALAC)
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_decoder
+ALL_TARGET= alac
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/alac
+PORTDOCS= README
+
+post-patch:
+.if !defined(WITH_DEBUG)
+ @${REINPLACE_CMD} -e 's|-ggdb||' \
+ ${WRKSRC}/${MAKEFILE}
+.endif
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|-O3|${CFLAGS}|' \
+ ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/alac ${PREFIX}/bin/
+.if !defined(WITHOUT_PORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/alac/distinfo b/audio/alac/distinfo
new file mode 100644
index 000000000000..4f724d1f71be
--- /dev/null
+++ b/audio/alac/distinfo
@@ -0,0 +1,2 @@
+MD5 (alac_decoder-0.1.0.tar.gz) = f554fc11ee41a30bc5baf15a0fd07256
+SIZE (alac_decoder-0.1.0.tar.gz) = 13207
diff --git a/audio/alac/pkg-descr b/audio/alac/pkg-descr
new file mode 100644
index 000000000000..51e9f6dc5bc7
--- /dev/null
+++ b/audio/alac/pkg-descr
@@ -0,0 +1,3 @@
+Basic decoder for Apple Lossless Audio Codec files (ALAC)
+
+WWW: http://crazney.net/programs/itunes/alac.html