aboutsummaryrefslogtreecommitdiff
path: root/audio/alsa-plugins
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-11-29 04:54:21 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-11-29 04:54:21 +0000
commit27f51d17e1560992c17a93764355dababf357a15 (patch)
treea22dc5c012e797a5f46d39979b6a8670a0d59335 /audio/alsa-plugins
parent1d6a1e22fbe4e92f69651e4f31320b5139f131a1 (diff)
downloadports-27f51d17e1560992c17a93764355dababf357a15.tar.gz
ports-27f51d17e1560992c17a93764355dababf357a15.zip
audio/alsa-plugins: disable BUFSZ_P2 after r545611
$ aplay foo.wav Playing WAVE 'foo.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo Assertion failed: (err >= 0), function set_params, file aplay.c, line 1353. Aborted by signal Abort trap... $ veloren [...] Panic Payload: "build_output_stream failed with all supported formats: BackendSpecific { err: BackendSpecificError { description: \"ALSA function \\\'snd_pcm_hw_params_set_period_time_near\\\' failed with error \\\'EINVAL: Invalid argument\\\'\" } }" PanicInfo: panicked at 'build_output_stream failed with all supported formats: BackendSpecific { err: BackendSpecificError { description: "ALSA function \'snd_pcm_hw_params_set_period_time_near\' failed with error \'EINVAL: Invalid argument\'" } }', cargo-crates/rodio-0.13.0/src/stream.rs:202:22 Game version: v0.8.0 [2020-11-28]
Notes
Notes: svn path=/head/; revision=556547
Diffstat (limited to 'audio/alsa-plugins')
-rw-r--r--audio/alsa-plugins/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/audio/alsa-plugins/Makefile b/audio/alsa-plugins/Makefile
index 027f10093f18..a151ef1fc91e 100644
--- a/audio/alsa-plugins/Makefile
+++ b/audio/alsa-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= alsa-plugins
PORTVERSION= 1.1.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio
MASTER_SITES= ftp://ftp.alsa-project.org/pub/plugins/ \
GENTOO
@@ -21,7 +21,7 @@ EXTRA_PATCHES+= ${FILESDIR}/alsa-plugins.patch
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${.CURDIR}/../alsa-lib/files
-OPTIONS_DEFAULT=BUFSZ_P2 IO_PTR
+OPTIONS_DEFAULT=IO_PTR
OPTIONS_DEFINE= JACK FFMPEG PULSEAUDIO SAMPLERATE SPEEX
OPTIONS_SUB= yes