aboutsummaryrefslogtreecommitdiff
path: root/audio/alure
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-06 08:59:47 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-06 08:59:47 +0000
commit465ebd5cd473d577c63e328346bffdee64e1e941 (patch)
tree17a86f310b109b2566f9a53e163f6f82a086c4a1 /audio/alure
parentdf904fa6a5afa2d492d3ac262a1a8eae4aebb4d4 (diff)
downloadports-465ebd5cd473d577c63e328346bffdee64e1e941.tar.gz
ports-465ebd5cd473d577c63e328346bffdee64e1e941.zip
audio/alure: fix build on GCC architectures
C++11 compiler is necessary: /usr/local/lib/libopenal.so: undefined reference to `std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >::_M_mutate(unsigned long, unsigned long, char const*, unsigned long)@GLIBCXX_3.4.21' Approved by: mentors (implicit approval)
Notes
Notes: svn path=/head/; revision=519121
Diffstat (limited to 'audio/alure')
-rw-r--r--audio/alure/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/alure/Makefile b/audio/alure/Makefile
index b20324cb736f..227e5e6ed236 100644
--- a/audio/alure/Makefile
+++ b/audio/alure/Makefile
@@ -13,7 +13,7 @@ COMMENT= Utility library to help manage common tasks with OpenAL
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake openal:soft pkgconfig
+USES= cmake compiler:c++11-lang openal:soft pkgconfig
USE_LDCONFIG= yes
LLD_UNSAFE= yes # lld disallows preemption of protected visibility syms
CMAKE_OFF= BUILD_DOCS BUILD_STATIC