aboutsummaryrefslogtreecommitdiff
path: root/audio/alure
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-07-14 18:07:37 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-07-14 18:07:37 +0000
commitaa606f395796e853dbfe9974d8e20809c2f7d620 (patch)
tree25ee3a2a4613c3f6e1227ddbd1697d8325cd9d2a /audio/alure
parent474f7ff57676a81d21086a8c988429108e4802c2 (diff)
downloadports-aa606f395796e853dbfe9974d8e20809c2f7d620.tar.gz
ports-aa606f395796e853dbfe9974d8e20809c2f7d620.zip
Notes
Diffstat (limited to 'audio/alure')
-rw-r--r--audio/alure/Makefile41
-rw-r--r--audio/alure/pkg-plist39
2 files changed, 19 insertions, 61 deletions
diff --git a/audio/alure/Makefile b/audio/alure/Makefile
index bbfa8c2ca7c0..f4bcd9d62eeb 100644
--- a/audio/alure/Makefile
+++ b/audio/alure/Makefile
@@ -1,9 +1,9 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= alure
PORTVERSION= 1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://kcat.strangesoft.net/alure-releases/
@@ -12,90 +12,78 @@ COMMENT= Utility library to help manage common tasks with OpenAL
LICENSE= MIT
-LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
+USES= cmake pkgconfig
USE_OPENAL= soft
USE_LDCONFIG= yes
-USES= cmake
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-OPTIONS_DEFINE= VORBIS FLAC MPG123 DUMB MODPLUG FLUIDSYNTH DOCS EXAMPLES
+PORTDOCS= *
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= DOCS EXAMPLES STATIC VORBIS FLAC MPG123 DUMB MODPLUG FLUIDSYNTH
OPTIONS_DEFAULT= VORBIS FLAC DUMB
DUMB_DESC= DUMB audio library decoding support
MODPLUG_DESC= MOD decoding via ModPlug
FLUIDSYNTH_DESC= MIDI support via FluidSynth
+OPTIONS_SUB= yes
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MVORBIS}
-PLIST_SUB+= VORBIS=""
LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
PLUGIN_OPTIONS_CMAKE+= -DUSE_VORBIS:BOOL=TRUE
.else
-PLIST_SUB+= VORBIS="@comment "
PLUGIN_OPTIONS_CMAKE+= -DUSE_VORBIS:BOOL=FALSE
.endif
.if ${PORT_OPTIONS:MFLAC}
-PLIST_SUB+= FLAC=""
LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
PLUGIN_OPTIONS_CMAKE+= -DUSE_FLAC:BOOL=TRUE
.else
-PLIST_SUB+= FLAC="@comment "
PLUGIN_OPTIONS_CMAKE+= -DUSE_FLAC:BOOL=FALSE
.endif
.if ${PORT_OPTIONS:MMPG123}
-PLIST_SUB+= MPG123=""
LIB_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
PLUGIN_OPTIONS_CMAKE+= -DUSE_MPG123:BOOL=TRUE
.else
-PLIST_SUB+= mpg123="@comment "
PLUGIN_OPTIONS_CMAKE+= -DUSE_MPG123:BOOL=FALSE
.endif
.if ${PORT_OPTIONS:MDUMB}
-PLIST_SUB+= DUMB=""
BUILD_DEPENDS+= ${LOCALBASE}/include/dumb.h:${PORTSDIR}/audio/dumb-allegro
PLUGIN_OPTIONS_CMAKE+= -DUSE_DUMB:BOOL=TRUE
.else
-PLIST_SUB+= DUMB="@comment "
PLUGIN_OPTIONS_CMAKE+= -DUSE_DUMB:BOOL=FALSE
.endif
.if ${PORT_OPTIONS:MMODPLUG}
-PLIST_SUB+= MODPLUG=""
BUILD_DEPENDS+= ${LOCALBASE}/include/libmodplug/modplug.h:${PORTSDIR}/audio/libmodplug
PLUGIN_OPTIONS_CMAKE+= -DUSE_MODPLUG:BOOL=TRUE
.else
-PLIST_SUB+= MODPLUG="@comment "
PLUGIN_OPTIONS_CMAKE+= -DUSE_MODPLUG:BOOL=FALSE
.endif
.if ${PORT_OPTIONS:MFLUIDSYNTH}
-PLIST_SUB+= FLUIDSYNTH=""
LIB_DEPENDS+= fluidsynth:${PORTSDIR}/audio/fluidsynth
PLUGIN_OPTIONS_CMAKE+= -DUSE_FLUIDSYNTH:BOOL=TRUE
.else
-PLIST_SUB+= FLUIDSYNTH="@comment "
PLUGIN_OPTIONS_CMAKE+= -DUSE_FLUIDSYNTH:BOOL=FALSE
.endif
.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= NaturalDocs:${PORTSDIR}/devel/naturaldocs
-PLIST_SUB+= PORTDOCS=""
-.else
-PLIST_SUB+= PORTDOCS="@comment "
.endif
post-patch:
@${REINPLACE_CMD} -e 's|lib$${LIB_SUFFIX}/pkgconfig|$${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|' \
-e 's|"ModPlug support (for IT/XM/S3M/MOD)" OFF)|"ModPlug support (for IT/XM/S3M/MOD)" ON)|' \
${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e 's|/lib/pkgconfig|/libdata/pkgconfig|' \
- ${WRKSRC}/XCompile.txt
.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} \
@@ -108,10 +96,15 @@ post-patch:
@${REINPLACE_CMD} -i '' -e '/INSTALL(DIRECTORY "$${ALURE_SOURCE_DIR}/,+2d' ${WRKSRC}/CMakeLists.txt
.endif
+.if ! ${PORT_OPTIONS:MSTATIC}
+ @${REINPLACE_CMD} -e 's|"Build the static version of the library" ON)|"Build the static version of the library" OFF)|' \
+ ${WRKSRC}/CMakeLists.txt
+.endif
+
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>
diff --git a/audio/alure/pkg-plist b/audio/alure/pkg-plist
index 9fc54a75c248..3095ca3313e7 100644
--- a/audio/alure/pkg-plist
+++ b/audio/alure/pkg-plist
@@ -2,45 +2,10 @@ bin/alurecdplay
bin/alureplay
bin/alurestream
include/AL/alure.h
-lib/libalure-static.a
+%%STATIC%%lib/libalure-static.a
lib/libalure.so
lib/libalure.so.1
lib/libalure.so.1.2.0
-libdata/pkgconfig/alure-static.pc
+%%STATIC%%libdata/pkgconfig/alure-static.pc
libdata/pkgconfig/alure.pc
-%%PORTDOCS%%%%DOCSDIR%%/html/files/alure-cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/files/buffer-cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/files/istream-cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/files/stream-cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/files/streamplay-cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/index/Functions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/index/General.html
-%%PORTDOCS%%%%DOCSDIR%%/html/javascript/main.js
-%%PORTDOCS%%%%DOCSDIR%%/html/javascript/searchdata.js
-%%PORTDOCS%%%%DOCSDIR%%/html/search/FunctionsA.html
-%%PORTDOCS%%%%DOCSDIR%%/html/search/GeneralA.html
-%%PORTDOCS%%%%DOCSDIR%%/html/search/GeneralF.html
-%%PORTDOCS%%%%DOCSDIR%%/html/search/GeneralM.html
-%%PORTDOCS%%%%DOCSDIR%%/html/search/GeneralS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/search/NoResults.html
-%%PORTDOCS%%%%DOCSDIR%%/html/styles/1.css
-%%PORTDOCS%%%%DOCSDIR%%/html/styles/2.css
-%%PORTDOCS%%%%DOCSDIR%%/html/styles/main.css
-%%PORTDOCS%%%%DOCSDIR%%/naturaldocs/CustomStyle.css
-%%PORTDOCS%%%%DOCSDIR%%/naturaldocs/Languages.txt
-%%PORTDOCS%%%%DOCSDIR%%/naturaldocs/Menu.txt
-%%PORTDOCS%%%%DOCSDIR%%/naturaldocs/Topics.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/alurecdplay.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/alureplay.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/alurestream.c
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/naturaldocs
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/styles
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/search
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/javascript
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/index
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/files
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry include/AL