aboutsummaryrefslogtreecommitdiff
path: root/audio/aqualung
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-07-20 18:08:55 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-07-20 18:08:55 +0000
commit734e5b04e244dba4a3b5b9c7c168ef70fad1b4cc (patch)
treea931e8df7999b6629f9f57ff5d79d98125dfb639 /audio/aqualung
parent4d04fd0c9402c508a56ff9e5d0edc053e7637d51 (diff)
downloadports-734e5b04e244dba4a3b5b9c7c168ef70fad1b4cc.tar.gz
ports-734e5b04e244dba4a3b5b9c7c168ef70fad1b4cc.zip
audio/aqualung: Add SNDIO option
This makes enabling the sndio backend explicit. Currently configure automatically enables the sndio backend when audio/sndio is installed in the build environment. PR: 220503 Approved by: portmaster@bsdforge.com (maintainter timeout, 2 weeks)
Notes
Notes: svn path=/head/; revision=446284
Diffstat (limited to 'audio/aqualung')
-rw-r--r--audio/aqualung/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/aqualung/Makefile b/audio/aqualung/Makefile
index 84e707e3000f..988ecacd6940 100644
--- a/audio/aqualung/Makefile
+++ b/audio/aqualung/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aqualung
PORTVERSION= 1.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= SF
@@ -40,7 +40,7 @@ CONFIGURE_ARGS= --with-ifp=no
DESKTOP_ENTRIES="Aqualung" "" "${DATADIR}/general.png" "aqualung" \
"Audio;AudioVideo;GTK;" ""
-OPTIONS_DEFINE= ALSA DOCS JACK PULSEAUDIO
+OPTIONS_DEFINE= ALSA DOCS JACK PULSEAUDIO SNDIO
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_CONFIGURE_ON= --with-alsa=yes
@@ -51,5 +51,8 @@ JACK_CONFIGURE_OFF= --with-jack=no
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_ON= --with-pulse=yes
PULSEAUDIO_CONFIGURE_OFF= --with-pulse=no
+SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
+SNDIO_CONFIGURE_ON= --with-sndio=yes
+SNDIO_CONFIGURE_OFF= --with-sndio=no
.include <bsd.port.mk>