aboutsummaryrefslogtreecommitdiff
path: root/audio/arss
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /audio/arss
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'audio/arss')
-rw-r--r--audio/arss/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/arss/Makefile b/audio/arss/Makefile
index 1cff001d41bc..37f2be960266 100644
--- a/audio/arss/Makefile
+++ b/audio/arss/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libfftw3.so:math/fftw3
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USES= cmake
+USES= cmake:insource
USE_LDCONFIG= ${PREFIX}/lib
CFLAGS+= -L${LOCALBASE}/lib -I${LOCALBASE}/include
CMAKE_C_FLAGS= ${CFLAGS}