aboutsummaryrefslogtreecommitdiff
path: root/audio/asmixer
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-27 09:20:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-27 09:20:04 +0000
commitd4aa27bf925c0bee3e19ecec6038c6fbae90dc6e (patch)
treeb02c77e24db41f0f4820687cd792e5913008ffb7 /audio/asmixer
parent47be6df457c9854136f05a31f5331bfe36de1265 (diff)
downloadports-d4aa27bf925c0bee3e19ecec6038c6fbae90dc6e.tar.gz
ports-d4aa27bf925c0bee3e19ecec6038c6fbae90dc6e.zip
- Update MASTER_SITES
- Add LICENSE - Stage support PR: 187063
Notes
Notes: svn path=/head/; revision=346293
Diffstat (limited to 'audio/asmixer')
-rw-r--r--audio/asmixer/Makefile37
-rw-r--r--audio/asmixer/files/patch-asmixer.c12
2 files changed, 24 insertions, 25 deletions
diff --git a/audio/asmixer/Makefile b/audio/asmixer/Makefile
index 44844f1f0e56..db549e2c0c8f 100644
--- a/audio/asmixer/Makefile
+++ b/audio/asmixer/Makefile
@@ -3,28 +3,39 @@
PORTNAME= asmixer
PORTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio afterstep
-MASTER_SITES= http://www.tigr.net/afterstep/download/asmixer/
+MASTER_SITES= AFTERSTEP/apps/asmix/ \
+ http://tigr.net/afterstep/download/asmixer/
MAINTAINER= ports@FreeBSD.org
COMMENT= Mixer control for AfterStep window manager
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2014-03-07
-
-MAN1= ${PORTNAME}.1x
-NO_STAGE= yes
-PLIST_FILES= bin/asmixer
+LICENSE= GPLv2
USE_XORG= xpm x11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-xpm \
- --with-xpm-includes=${LOCALBASE} \
- --with-xpm-library=${LOCALBASE}
+ --with-xpm-includes=${LOCALBASE}/include \
+ --with-xpm-library=${LOCALBASE}/lib
+
+PLIST_FILES= bin/asmixer man/man1/asmixer.1.gz
+
+post-patch:
+.for i in asmixer.c configure autoconf/config.h.in
+ @${REINPLACE_CMD} -e \
+ 's|machine/soundcard.h|sys/soundcard.h| ; \
+ s|MACHINE_SOUNDCARD_H|SYS_SOUNDCARD_H| ; \
+ /sys\/syslimits.h/d' ${WRKSRC}/${i}
+.endfor
+
+post-build:
+ @${LN} -sf asmixer.man ${WRKSRC}/asmixer.1
-post-install:
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man \
- ${MAN1PREFIX}/man/man1/${PORTNAME}.1x
+do-install:
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} asmixer \
+ ${STAGEDIR}${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_MAN} asmixer.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1)
.include <bsd.port.mk>
diff --git a/audio/asmixer/files/patch-asmixer.c b/audio/asmixer/files/patch-asmixer.c
deleted file mode 100644
index 7d2d51e2fd57..000000000000
--- a/audio/asmixer/files/patch-asmixer.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- asmixer.c.orig Sun Aug 31 15:23:26 2003
-+++ asmixer.c Sun Aug 31 15:24:45 2003
-@@ -31,8 +31,8 @@
- #include <unistd.h>
-
- #ifdef __FreeBSD__
--#include <sys/syslimits.h>
- #include <sys/param.h>
-+#include <sys/soundcard.h>
- #endif
-
- #include <sys/mount.h>