aboutsummaryrefslogtreecommitdiff
path: root/audio/asterisk-espeak
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-09-20 18:10:54 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-09-20 18:10:54 +0000
commitb9755e9b5168cb78fa0685e422de2f6e04966407 (patch)
tree5d3fb74f15375e335f323e647e868964cfc55904 /audio/asterisk-espeak
parent0d793aa06e15f65ec3de65da4280ed04b458438c (diff)
downloadports-b9755e9b5168cb78fa0685e422de2f6e04966407.tar.gz
ports-b9755e9b5168cb78fa0685e422de2f6e04966407.zip
eSpeak For Asterisk provides the "Espeak" dialplan application,
which allows you to use the Espeak speech synthesizer with Asterisk. This module invokes the Espeak TTS engine locally, and uses it to render text to speech. WWW: https://zaf.github.io/Asterisk-eSpeak/
Notes
Notes: svn path=/head/; revision=422533
Diffstat (limited to 'audio/asterisk-espeak')
-rw-r--r--audio/asterisk-espeak/Makefile46
-rw-r--r--audio/asterisk-espeak/distinfo3
-rw-r--r--audio/asterisk-espeak/files/patch-Makefile59
-rw-r--r--audio/asterisk-espeak/pkg-descr6
-rw-r--r--audio/asterisk-espeak/pkg-plist2
5 files changed, 116 insertions, 0 deletions
diff --git a/audio/asterisk-espeak/Makefile b/audio/asterisk-espeak/Makefile
new file mode 100644
index 000000000000..e2601e07097e
--- /dev/null
+++ b/audio/asterisk-espeak/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= asterisk-espeak
+PORTVERSION= 3.0
+DISTVERSIONPREFIX= v
+CATEGORIES= audio
+
+MAINTAINER= madpilot@FreeBSD.org
+COMMENT= Espeak dialplan application for Asterisk
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libespeak.so:audio/espeak \
+ libsamplerate.so:audio/libsamplerate
+
+USE_GITHUB= yes
+GH_ACCOUNT= zaf
+GH_PROJECT= Asterisk-Espeak
+
+USES= compiler gmake localbase
+INSTALL_TARGET= install samples
+WRKSRC= ${WRKDIR}/Asterisk-eSpeak-${PORTVERSION}
+
+OPTIONS_SINGLE= ASTVER
+OPTIONS_SINGLE_ASTVER= ASTERISK11 ASTERISK13
+OPTIONS_DEFAULT= ASTERISK13
+
+ASTERISK11_DESC= Depend on Asterisk 11
+ASTERISK13_DESC= Depend on Asterisk 13
+
+ASTERISK11_BUILD_DEPENDS= asterisk:net/asterisk11
+ASTERISK11_RUN_DEPENDS= asterisk:net/asterisk11
+
+ASTERISK13_BUILD_DEPENDS= asterisk:net/asterisk13
+ASTERISK13_RUN_DEPENDS= asterisk:net/asterisk13
+
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == clang
+CFLAGS+= -fblocks
+.endif
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/asterisk/modules/app_espeak.so
+
+.include <bsd.port.post.mk>
diff --git a/audio/asterisk-espeak/distinfo b/audio/asterisk-espeak/distinfo
new file mode 100644
index 000000000000..9bc0620fd35c
--- /dev/null
+++ b/audio/asterisk-espeak/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474384491
+SHA256 (zaf-Asterisk-Espeak-v3.0_GH0.tar.gz) = 47c7629853ad54a2f3b50a5407db356ab7806f5fa40f9811a129208d6eeec398
+SIZE (zaf-Asterisk-Espeak-v3.0_GH0.tar.gz) = 13758
diff --git a/audio/asterisk-espeak/files/patch-Makefile b/audio/asterisk-espeak/files/patch-Makefile
new file mode 100644
index 000000000000..29faa9c4d015
--- /dev/null
+++ b/audio/asterisk-espeak/files/patch-Makefile
@@ -0,0 +1,59 @@
+--- Makefile.orig 2016-03-19 11:15:32 UTC
++++ Makefile
+@@ -7,30 +7,15 @@
+ # at the top of the source tree.
+
+ INSTALL=install
+-ASTLIBDIR:=$(shell awk '/moddir/{print $$3}' /etc/asterisk/asterisk.conf)
+-ifeq ($(strip $(ASTLIBDIR)),)
+- MODULES_DIR=$(INSTALL_PREFIX)/usr/lib/asterisk/modules
+-else
+- MODULES_DIR=$(INSTALL_PREFIX)$(ASTLIBDIR)
+-endif
+-ASTETCDIR=$(INSTALL_PREFIX)/etc/asterisk
++MODULES_DIR=$(PREFIX)/lib/asterisk/modules
++ASTETCDIR=$(PREFIX)/etc/asterisk
+ SAMPLENAME=espeak.conf.sample
+-CONFNAME=$(basename $(SAMPLENAME))
+-
+-CC=gcc
+-OPTIMIZE=-O2
+-DEBUG=-g
++CONFNAME=$(SAMPLENAME)
+
+-LIBS+=-lespeak -lsamplerate
++LIBS+=$(LDFLAGS) -lespeak -lsamplerate
+ CFLAGS+=-pipe -fPIC -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -D_REENTRANT -D_GNU_SOURCE
+
+ all: _all
+- @echo " +-------- app_espeak Build Complete --------+"
+- @echo " + app_espeak has successfully been built, +"
+- @echo " + and can be installed by running: +"
+- @echo " + +"
+- @echo " + make install +"
+- @echo " +-------------------------------------------+"
+
+ _all: app_espeak.so
+
+@@ -46,21 +31,7 @@ clean:
+ install: _all
+ $(INSTALL) -m 755 -d $(DESTDIR)$(MODULES_DIR)
+ $(INSTALL) -m 755 app_espeak.so $(DESTDIR)$(MODULES_DIR)
+- @echo " +---- app_espeak Installation Complete -----+"
+- @echo " + +"
+- @echo " + app_espeak has successfully been installed+"
+- @echo " + If you would like to install the sample +"
+- @echo " + configuration file run: +"
+- @echo " + +"
+- @echo " + make samples +"
+- @echo " +-------------------------------------------+"
+
+ samples:
+ @mkdir -p $(DESTDIR)$(ASTETCDIR)
+- @if [ -f $(DESTDIR)$(ASTETCDIR)/$(CONFNAME) ]; then \
+- echo "Backing up previous config file as $(CONFNAME).old";\
+- mv -f $(DESTDIR)$(ASTETCDIR)/$(CONFNAME) $(DESTDIR)$(ASTETCDIR)/$(CONFNAME).old ; \
+- fi ;
+ $(INSTALL) -m 644 $(SAMPLENAME) $(DESTDIR)$(ASTETCDIR)/$(CONFNAME)
+- @echo " ------- app_esepak confing Installed --------"
+-
diff --git a/audio/asterisk-espeak/pkg-descr b/audio/asterisk-espeak/pkg-descr
new file mode 100644
index 000000000000..f49fac719a89
--- /dev/null
+++ b/audio/asterisk-espeak/pkg-descr
@@ -0,0 +1,6 @@
+eSpeak For Asterisk provides the "Espeak" dialplan application,
+which allows you to use the Espeak speech synthesizer with Asterisk.
+This module invokes the Espeak TTS engine locally, and uses it to
+render text to speech.
+
+WWW: https://zaf.github.io/Asterisk-eSpeak/
diff --git a/audio/asterisk-espeak/pkg-plist b/audio/asterisk-espeak/pkg-plist
new file mode 100644
index 000000000000..564e0e7c9cd5
--- /dev/null
+++ b/audio/asterisk-espeak/pkg-plist
@@ -0,0 +1,2 @@
+@sample etc/asterisk/espeak.conf.sample
+lib/asterisk/modules/app_espeak.so