aboutsummaryrefslogtreecommitdiff
path: root/audio/asterisk-flite
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-03 13:17:01 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-03 13:17:01 +0000
commitedc70d0b5e6cdce044f76d93ef839bb332e90fa9 (patch)
tree2f39b7241f095fb21e91cf333dc1517553f0e13d /audio/asterisk-flite
parent216079a0fe9e82434cf04c432ce9e2f97724f4de (diff)
downloadports-edc70d0b5e6cdce044f76d93ef839bb332e90fa9.tar.gz
ports-edc70d0b5e6cdce044f76d93ef839bb332e90fa9.zip
audio/asterisk-flite: fix build on GCC architectures
C11 compiler is necessary: In file included from /usr/local/include/asterisk/vector.h:22, from /usr/local/include/asterisk/stringfields.h:178, from /usr/local/include/asterisk/app.h:26, from app_flite.c:42: /usr/local/include/asterisk/lock.h: In function 'ast_atomic_fetchadd_int': /usr/local/include/asterisk/lock.h:752: error: '__ATOMIC_RELAXED' undeclared (first use in this function) /usr/local/include/asterisk/lock.h:752: error: (Each undeclared identifier is reported only once /usr/local/include/asterisk/lock.h:752: error: for each function it appears in.) /usr/local/include/asterisk/lock.h: In function 'ast_atomic_dec_and_test': /usr/local/include/asterisk/lock.h:762: error: '__ATOMIC_RELAXED' undeclared (first use in this function) MFH: 2020Q1 (build fix blanket)
Notes
Notes: svn path=/head/; revision=521937
Diffstat (limited to 'audio/asterisk-flite')
-rw-r--r--audio/asterisk-flite/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/asterisk-flite/Makefile b/audio/asterisk-flite/Makefile
index 04eca6056cd9..88f1d3b5fd3e 100644
--- a/audio/asterisk-flite/Makefile
+++ b/audio/asterisk-flite/Makefile
@@ -26,7 +26,7 @@ asterisk16_CONFLICTS_INSTALL= asterisk13-flite
asterisk16_BUILD_DEPENDS= asterisk:net/asterisk16
asterisk16_RUN_DEPENDS= asterisk:net/asterisk16
-USES= compiler gmake localbase
+USES= compiler:c11 gmake localbase
INSTALL_TARGET= install samples
USE_GITHUB= yes