aboutsummaryrefslogtreecommitdiff
path: root/audio/asunder/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-05 12:25:33 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-05 12:25:33 +0000
commitb5027d723e34b24792317b6bc90f1adbdbf82d21 (patch)
tree20465f8e22d37fd7af6aff9c019aa33a24d76d96 /audio/asunder/Makefile
parent584bb5e3a7260c9b560489a044201c135d282b55 (diff)
downloadports-b5027d723e34b24792317b6bc90f1adbdbf82d21.tar.gz
ports-b5027d723e34b24792317b6bc90f1adbdbf82d21.zip
Support stage
Use options helpers Add missing desktop-file-utils
Notes
Notes: svn path=/head/; revision=350223
Diffstat (limited to 'audio/asunder/Makefile')
-rw-r--r--audio/asunder/Makefile49
1 files changed, 13 insertions, 36 deletions
diff --git a/audio/asunder/Makefile b/audio/asunder/Makefile
index f89c4e0462ab..2d80040a0bfd 100644
--- a/audio/asunder/Makefile
+++ b/audio/asunder/Makefile
@@ -3,6 +3,7 @@
PORTNAME= asunder
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://littlesvr.ca/asunder/releases/
@@ -18,49 +19,25 @@ RUN_DEPENDS= ${LOCALBASE}/bin/cdparanoia:${PORTSDIR}/audio/cdparanoia
OPTIONS_DEFINE= LAME OGG FLAC OPUS WAVPACK APE WINDOWS_CHARS NLS DOCS
OPUS_DESC= OPUS support
OPTIONS_DEFAULT= LAME OGG FLAC
+OPTIONS_SUB= yes
WINDOWS_CHARS_DESC= Allow Windows special chars in filenames
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-NO_STAGE= yes
-USES= gettext gmake pkgconfig
+USES= gettext gmake desktop-file-utils pkgconfig tar:bzip2
USE_GNOME= gtk20
PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README TODO
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MLAME}
-RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
-.endif
-
-.if ${PORT_OPTIONS:MOGG}
-RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
-.endif
-
-.if ${PORT_OPTIONS:MFLAC}
-RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
-.endif
+LAME_RUN_DEPENDS= lame:${PORTSDIR}/audio/lame
+OGG_RUN_DEPENDS= oggenc:${PORTSDIR}/audio/vorbis-tools
+FLAC_RUN_DEPENDS= flac:${PORTSDIR}/audio/flac
+OPUS_RUN_DEPENDS= opusenc:${PORTSDIR}/audio/opus-tools
+WAVPACK_RUN_DEPENDS= wavpack:${PORTSDIR}/audio/wavpack
+APE_RUN_DEPENDS= mac:${PORTSDIR}/audio/mac
+NLS_CONFIGURE_ENABLE= yes
-.if ${PORT_OPTIONS:MOPUS}
-RUN_DEPENDS+= opusenc:${PORTSDIR}/audio/opus-tools
-.endif
-
-.if ${PORT_OPTIONS:MWAVPACK}
-RUN_DEPENDS+= wavpack:${PORTSDIR}/audio/wavpack
-.endif
-
-.if ${PORT_OPTIONS:MAPE}
-RUN_DEPENDS+= mac:${PORTSDIR}/audio/mac
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-PLIST_SUB+= NLS=''
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS='@comment '
-.endif
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's/^itlocaledir = .*/itlocaledir = @datarootdir@\/locale/' ${WRKSRC}/po/Makefile.in.in
@@ -70,8 +47,8 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>