aboutsummaryrefslogtreecommitdiff
path: root/audio/asunder/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-08 20:36:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-08 20:36:55 +0000
commitcfb2f7fab25682a7a7caf9ea8264ecdddaefe753 (patch)
tree6b7115894e9fe2ae7ad8f6f980625574527e9d5c /audio/asunder/Makefile
parent68f390a529369adac8c8744e1599a75be65a5ae5 (diff)
downloadports-cfb2f7fab25682a7a7caf9ea8264ecdddaefe753.tar.gz
ports-cfb2f7fab25682a7a7caf9ea8264ecdddaefe753.zip
- Add OPTIONS handling
PR: 116451 Submitted by: volker@vwsoft.com Approved by: maintainer
Notes
Notes: svn path=/head/; revision=201123
Diffstat (limited to 'audio/asunder/Makefile')
-rw-r--r--audio/asunder/Makefile21
1 files changed, 20 insertions, 1 deletions
diff --git a/audio/asunder/Makefile b/audio/asunder/Makefile
index 88844c18f2b6..1b489ed74d2f 100644
--- a/audio/asunder/Makefile
+++ b/audio/asunder/Makefile
@@ -6,6 +6,7 @@
PORTNAME= asunder
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://littlesvr.ca/asunder/releases/
@@ -15,8 +16,26 @@ COMMENT= A lightweight GTK+ CD ripper
LIB_DEPENDS= cddb.4:${PORTSDIR}/audio/libcddb
RUN_DEPENDS= ${LOCALBASE}/bin/cdparanoia:${PORTSDIR}/audio/cdparanoia
+OPTIONS= LAME "lame support" on \
+ OGG "ogg-vorbis support" on \
+ FLAC "FLAC support" on
+
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_GNOME= gtk20
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LAME)
+RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
+.endif
+
+.if defined(WITH_OGG)
+RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
+.endif
+
+.if defined(WITH_FLAC)
+RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
+.endif
+
+.include <bsd.port.post.mk>