aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity-devel/files
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2006-10-06 18:29:58 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2006-10-06 18:29:58 +0000
commit96905e7c7d3153770fcb7165d99fab2c0fed21b3 (patch)
tree7b5eaebaadee9395d8d633434ee09b3899de5957 /audio/audacity-devel/files
parent2366078d57af3b13be5d9a453404ffb1d3ad5f61 (diff)
downloadports-96905e7c7d3153770fcb7165d99fab2c0fed21b3.tar.gz
ports-96905e7c7d3153770fcb7165d99fab2c0fed21b3.zip
Notes
Diffstat (limited to 'audio/audacity-devel/files')
-rw-r--r--audio/audacity-devel/files/patch-Makefile.in14
-rw-r--r--audio/audacity-devel/files/patch-libnyquist-Makefile.in36
-rw-r--r--audio/audacity-devel/files/patch-libnyquist-switches.h11
-rw-r--r--audio/audacity-devel/files/patch-libnyquist-term.c11
-rw-r--r--audio/audacity-devel/files/patch-libresample-Makefile.in11
-rw-r--r--audio/audacity-devel/files/patch-portaudio-pa_unix.c29
-rw-r--r--audio/audacity-devel/files/patch-portaudio-pa_unix.h11
-rw-r--r--audio/audacity-devel/files/patch-portaudio-pa_unix_oss.c11
-rw-r--r--audio/audacity-devel/files/patch-portmixer-px_unix_oss.c11
9 files changed, 145 insertions, 0 deletions
diff --git a/audio/audacity-devel/files/patch-Makefile.in b/audio/audacity-devel/files/patch-Makefile.in
new file mode 100644
index 000000000000..b60ff9e8b2c5
--- /dev/null
+++ b/audio/audacity-devel/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in.orig Tue Nov 30 21:49:32 2004
++++ Makefile.in Tue Nov 30 21:50:05 2004
+@@ -31,9 +31,11 @@
+ $(INSTALL) -d $(DESTDIR)$(DATADIR)/$(AUDACITY_NAME)
+ -test -f audacity-1.2-help.htb && $(INSTALL) -m 644 audacity-1.2-help.htb \
+ $(DESTDIR)$(DATADIR)/$(AUDACITY_NAME)/audacity-1.2-help.htb
++ifeq ($(DOC),yes)
+ $(INSTALL) -d $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)
+ $(INSTALL) -m 644 README.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/README.txt
+ $(INSTALL) -m 644 LICENSE.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/LICENSE.txt
++endif
+
+ # install manpage
+ $(INSTALL) -d $(DESTDIR)$(MANDIR)/man1
diff --git a/audio/audacity-devel/files/patch-libnyquist-Makefile.in b/audio/audacity-devel/files/patch-libnyquist-Makefile.in
new file mode 100644
index 000000000000..2f57bbaf95bb
--- /dev/null
+++ b/audio/audacity-devel/files/patch-libnyquist-Makefile.in
@@ -0,0 +1,36 @@
+--- lib-src/libnyquist/Makefile.in.orig Tue Dec 2 19:32:18 2003
++++ lib-src/libnyquist/Makefile.in Tue Dec 2 19:32:42 2003
+@@ -465,13 +465,13 @@
+ cc -c cmt/userio.c -o cmt/userio.o $(CFLAGS)
+
+ misc/intgen: misc/intgen.c
+- cd misc; make intgen
++ cd misc; $(MAKE) intgen
+
+ misc/unpacker: misc/unpacker.c misc/convert.c
+- cd misc; make unpacker
++ cd misc; $(MAKE) unpacker
+
+ misc/packer: misc/packer.c misc/convert.c
+- cd misc; make packer
++ cd misc; $(MAKE) packer
+
+ nyqsrc/sndfnintptrs.h: $(NYQHDRS) snd/snd.h misc/intgen
+ $(INTGEN) nyqsrc/sndfnint $(NYQHDRS)
+@@ -481,14 +481,14 @@
+
+ clean:
+ rm -f libnyquist.a
+- cd misc; make clean
++ cd misc; $(MAKE) clean
+ rm -f $(OBJECTS)
+ # Note that these files are machine-generated:
+ rm -f nyqsrc/sndfnintptrs.h nyqsrc/sndfnint.c nyqsrc/sndfnintdefs.h
+ rm -f nyqsrc/seqfnintptrs.h nyqsrc/seqfnint.c nyqsrc/seqfnintdefs.h
+
+ cleaner: clean
+- cd misc; make cleaner
++ cd misc; $(MAKE) cleaner
+ rm -f *.backup */*.backup
+ rm -f *~ */*.*~
+ rm -f *.save */*.save
diff --git a/audio/audacity-devel/files/patch-libnyquist-switches.h b/audio/audacity-devel/files/patch-libnyquist-switches.h
new file mode 100644
index 000000000000..4cd74add2be3
--- /dev/null
+++ b/audio/audacity-devel/files/patch-libnyquist-switches.h
@@ -0,0 +1,11 @@
+--- lib-src/libnyquist/sys/switches.h.orig Tue Dec 2 19:14:40 2003
++++ lib-src/libnyquist/sys/switches.h Tue Dec 2 19:16:20 2003
+@@ -39,7 +39,7 @@
+ */
+ #define nyquist_printf printf
+
+-#if __APPLE__ && __GNUC__ /* Mac OS X */
++#if (__FreeBSD__ || __APPLE__) && __GNUC__ /* Mac OS X */
+ #define NEED_ULONG 1
+ #else
+ #include <sys/types.h>
diff --git a/audio/audacity-devel/files/patch-libnyquist-term.c b/audio/audacity-devel/files/patch-libnyquist-term.c
new file mode 100644
index 000000000000..5e33f81c2f38
--- /dev/null
+++ b/audio/audacity-devel/files/patch-libnyquist-term.c
@@ -0,0 +1,11 @@
+--- lib-src/libnyquist/sys/term.c.orig Tue Dec 2 19:17:30 2003
++++ lib-src/libnyquist/sys/term.c Tue Dec 2 19:17:51 2003
+@@ -40,7 +40,7 @@
+ #else
+
+ #include <termios.h>
+-#ifndef __APPLE__
++#if !defined(__APPLE__) && !defined(__FreeBSD__)
+ #include <asm/ioctls.h>
+ #endif
+ #include <signal.h>
diff --git a/audio/audacity-devel/files/patch-libresample-Makefile.in b/audio/audacity-devel/files/patch-libresample-Makefile.in
new file mode 100644
index 000000000000..bcb4513bcd20
--- /dev/null
+++ b/audio/audacity-devel/files/patch-libresample-Makefile.in
@@ -0,0 +1,11 @@
+--- lib-src/libresample/Makefile.in.orig Tue Dec 2 19:46:02 2003
++++ lib-src/libresample/Makefile.in Tue Dec 2 19:46:25 2003
+@@ -6,7 +6,7 @@
+ CC = @CC@
+ CFLAGS = @CFLAGS@ -Wall
+
+-LIBS = @LIBS@ -lm
++LIBS = @LDFLAGS@ @LIBS@ -lm
+
+ AR = @AR@
+ RANLIB = @RANLIB@
diff --git a/audio/audacity-devel/files/patch-portaudio-pa_unix.c b/audio/audacity-devel/files/patch-portaudio-pa_unix.c
new file mode 100644
index 000000000000..ff3c8ca818fd
--- /dev/null
+++ b/audio/audacity-devel/files/patch-portaudio-pa_unix.c
@@ -0,0 +1,29 @@
+--- lib-src/portaudio/pa_unix_oss/pa_unix.c.orig Tue Nov 30 21:18:35 2004
++++ lib-src/portaudio/pa_unix_oss/pa_unix.c Tue Nov 30 21:33:58 2004
+@@ -422,7 +422,7 @@
+ maxPri = sched_get_priority_max(SCHEDULER_POLICY);
+ if( schp.sched_priority > maxPri ) schp.sched_priority = maxPri;
+
+- if (sched_setscheduler(0, SCHEDULER_POLICY, &schp) != 0)
++ if (pthread_setschedparam(pahsc->pahsc_WatchDogThread, SCHEDULER_POLICY, &schp) != 0)
+ {
+ ERR_RPT(("PaHost_WatchDogProc: cannot set watch dog priority!\n"));
+ goto killAudio;
+@@ -465,7 +465,7 @@
+ lowerAudio:
+ {
+ struct sched_param schat = { 0 };
+- if( sched_setscheduler(pahsc->pahsc_AudioThreadPID, SCHED_OTHER, &schat) != 0)
++ if( pthread_setschedparam(pahsc->pahsc_AudioThread, SCHED_OTHER, &schat) != 0)
+ {
+ ERR_RPT(("PaHost_WatchDogProc: failed to lower audio priority. errno = %d\n", errno ));
+ /* Fall through into killing audio thread. */
+@@ -585,7 +585,7 @@
+ sched_get_priority_min(SCHEDULER_POLICY)) / 2;
+ schp.sched_priority = pahsc->pahsc_AudioPriority;
+
+- if (sched_setscheduler(0, SCHEDULER_POLICY, &schp) != 0)
++ if (pthread_setschedparam(pahsc->pahsc_AudioThread, SCHEDULER_POLICY, &schp) != 0)
+ {
+ DBUG(("PortAudio: only superuser can use real-time priority.\n"));
+ }
diff --git a/audio/audacity-devel/files/patch-portaudio-pa_unix.h b/audio/audacity-devel/files/patch-portaudio-pa_unix.h
new file mode 100644
index 000000000000..e4a44ff9a1bf
--- /dev/null
+++ b/audio/audacity-devel/files/patch-portaudio-pa_unix.h
@@ -0,0 +1,11 @@
+--- lib-src/portaudio/pa_unix_oss/pa_unix.h.orig Tue Dec 2 19:56:56 2003
++++ lib-src/portaudio/pa_unix_oss/pa_unix.h Tue Dec 2 19:58:33 2003
+@@ -82,7 +82,7 @@
+ #define MAX_TIMEOUT_MSEC (1000)
+
+ /************************************************* Definitions ********/
+-#ifdef __linux__
++#if defined(__linux__) || defined(__FreeBSD__)
+ #define DEVICE_NAME_BASE "/dev/dsp"
+ #else
+ #define DEVICE_NAME_BASE "/dev/audio"
diff --git a/audio/audacity-devel/files/patch-portaudio-pa_unix_oss.c b/audio/audacity-devel/files/patch-portaudio-pa_unix_oss.c
new file mode 100644
index 000000000000..43b2d587cca5
--- /dev/null
+++ b/audio/audacity-devel/files/patch-portaudio-pa_unix_oss.c
@@ -0,0 +1,11 @@
+--- lib-src/portaudio/pa_unix_oss/pa_unix_oss.c.orig Tue Dec 2 19:57:13 2003
++++ lib-src/portaudio/pa_unix_oss/pa_unix_oss.c Tue Dec 2 19:57:47 2003
+@@ -42,6 +42,8 @@
+
+ #ifdef __linux__
+ #include <linux/soundcard.h>
++#elif defined(__FreeBSD__)
++#include <sys/soundcard.h>
+ #else
+ #include <machine/soundcard.h> /* JH20010905 */
+ #endif
diff --git a/audio/audacity-devel/files/patch-portmixer-px_unix_oss.c b/audio/audacity-devel/files/patch-portmixer-px_unix_oss.c
new file mode 100644
index 000000000000..f55e651d1176
--- /dev/null
+++ b/audio/audacity-devel/files/patch-portmixer-px_unix_oss.c
@@ -0,0 +1,11 @@
+--- lib-src/portmixer/px_unix_oss/px_unix_oss.c.orig Tue Dec 2 20:06:55 2003
++++ lib-src/portmixer/px_unix_oss/px_unix_oss.c Tue Dec 2 20:07:09 2003
+@@ -37,6 +37,8 @@
+
+ #ifdef __linux__
+ #include <linux/soundcard.h>
++#elif defined(__FreeBSD__)
++#include <sys/soundcard.h>
+ #else
+ #include <machine/soundcard.h> /* JH20010905 */
+ #endif