aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-03 08:52:28 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-03 08:52:28 +0000
commit426395554560c4e8dcce61e274f14f8ea11b638e (patch)
tree41db5b98b47c23a1e415e4814460feaf30b44702 /audio/audacity
parent3906f44bbc81630fe2beff7e667edb33687185ea (diff)
downloadports-426395554560c4e8dcce61e274f14f8ea11b638e.tar.gz
ports-426395554560c4e8dcce61e274f14f8ea11b638e.zip
audio/audacity: fix build on non-x86
Audacity by default adds --enable-sse on all architectures, which breaks anything but i386 and amd64. Add SSE option to every architecture, but still enable by default only on amd64 and i386. This will add --disable-sse to CONFIGURE_ARGS, which fixes build. PR: 238140 Approved by: xxjack12xx@gmail.com (maintainer), tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D20422
Notes
Notes: svn path=/head/; revision=503360
Diffstat (limited to 'audio/audacity')
-rw-r--r--audio/audacity/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index c1e68773171b..93294395abc6 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -12,9 +12,6 @@ COMMENT= GUI editor for digital audio waveforms
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BROKEN_aarch64= fails to configure: checking whether C++ compiler accepts -msse... no
-BROKEN_powerpc64= fails to build
-
BUILD_DEPENDS= autogen:devel/autogen \
bash:shells/bash \
cmake:devel/cmake
@@ -43,12 +40,10 @@ USE_GITHUB= yes
OPTIONS_DEFINE= DEBUG DOCS DYNLOAD FFMPEG FLAC ID3TAG LADSPA LAME LV2 \
MAD MOD_NYQ_BENCH MOD_SCRIPT_PIPE NLS SBSMS SOUNDTOUCH \
- STATIC_WX TWOLAME VAMP VORBIS VST
+ SSE STATIC_WX TWOLAME VAMP VORBIS VST
OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD SBSMS SOUNDTOUCH TWOLAME VAMP \
VORBIS VST
-OPTIONS_DEFINE_amd64= SSE
-OPTIONS_DEFINE_i386= SSE
OPTIONS_DEFAULT_amd64= SSE
OPTIONS_DEFAULT_i386= ${MACHINE_CPU:tu:MSSE}