aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-19 08:43:50 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-19 08:43:50 +0000
commitf6a643b0da544ad4acabcfdfbc7d1467c97f146a (patch)
tree886d50e8a181508101665401fe196bc321a0fc5d /audio/audacity
parent908b9c959091abf9d70271bb6c312492f0a5d3a6 (diff)
downloadports-f6a643b0da544ad4acabcfdfbc7d1467c97f146a.tar.gz
ports-f6a643b0da544ad4acabcfdfbc7d1467c97f146a.zip
audio/audacity: fix build on non-x86
Disable MMX/SSE/SSE2 on non-x86. Include cstring in allegro.h to make memcpy() available. PR: 248076 Approved by: xxjack12xx@gmail.com (maintainer) MFH: 2020Q3 (build fix blanket)
Notes
Notes: svn path=/head/; revision=542544
Diffstat (limited to 'audio/audacity')
-rw-r--r--audio/audacity/Makefile8
-rw-r--r--audio/audacity/files/patch-lib-src_portsmf_allegro.h10
2 files changed, 18 insertions, 0 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 73f750cae3a6..ca20f7476c2b 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -126,6 +126,14 @@ VORBIS_LIB_DEPENDS= libogg.so:audio/libogg \
VST_CMAKE_BOOL= audacity_use_vst
+.include <bsd.port.options.mk>
+
+.if ${ARCH} != amd64 && ${ARCH} != i386
+CMAKE_ARGS+= -DHAVE_MMX:BOOL=OFF \
+ -DHAVE_SSE:BOOL=OFF \
+ -DHAVE_SSE2:BOOL=OFF
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,Python2,Python${PYTHON_MAJOR_VER}, ; \
/CMAKE_CXX_STANDARD/s,14,11,' ${WRKSRC}/CMakeLists.txt
diff --git a/audio/audacity/files/patch-lib-src_portsmf_allegro.h b/audio/audacity/files/patch-lib-src_portsmf_allegro.h
new file mode 100644
index 000000000000..747f85b03f78
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src_portsmf_allegro.h
@@ -0,0 +1,10 @@
+--- lib-src/portsmf/allegro.h.orig 2020-07-18 17:54:26 UTC
++++ lib-src/portsmf/allegro.h
+@@ -51,6 +51,7 @@
+ #include <assert.h>
+ #include <istream>
+ #include <ostream>
++#include <cstring>
+
+ #define ALG_EPS 0.000001 // epsilon
+ #define ALG_DEFAULT_BPM 100.0 // default tempo