aboutsummaryrefslogtreecommitdiff
path: root/audio/aumix/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-12-08 22:48:37 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-12-08 22:48:37 +0000
commita0d0aed67b9c5c6a89b6f0aac2bf0e0033d807a4 (patch)
treefa0b2f37b095216b653e6b274957454aa7f6757f /audio/aumix/Makefile
parentb4ba727c515d5f92366daeb629726cb482de7612 (diff)
downloadports-a0d0aed67b9c5c6a89b6f0aac2bf0e0033d807a4.tar.gz
ports-a0d0aed67b9c5c6a89b6f0aac2bf0e0033d807a4.zip
Notes
Diffstat (limited to 'audio/aumix/Makefile')
-rw-r--r--audio/aumix/Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/audio/aumix/Makefile b/audio/aumix/Makefile
index d957fd4b3ef1..b2f7545b4047 100644
--- a/audio/aumix/Makefile
+++ b/audio/aumix/Makefile
@@ -31,11 +31,26 @@ MAN1= aumix.1 xaumix.1
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgtk12}!=""
+pre-extract:
+.if !defined(WITH_GTK2) && !defined(WITHOUT_ALL)
+ @${ECHO_CMD}
+ @${ECHO_CMD} "****** To enable use of GTK+ 2.0, interrupt the ******"
+ @${ECHO_CMD} "****** build now, set WITH_GTK2, and start again. ******"
+ @${ECHO_CMD}
+ @sleep 3
+.endif
+
+.if (${HAVE_GNOME:Mgtk12}!="") && !defined(WITHOUT_ALL) && \
+ !defined(WITHOUT_GTK)&& !defined(WITH_GTK2)
USE_GNOME= gtk12
PKGNAMESUFFIX= -gtk
-.else
CONFIGURE_ARGS+=--without-gtk
+.elif defined(WITH_GTK2)
+PKGNAMESUFFIX= -gtk
+LIB_DEPENDS+= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+CONFIGURE_ARGS+=--without-gtk1
+.else
+CONFIGURE_ARGS+=--without-gtk --without-gtk1
.endif
.include <bsd.port.post.mk>