aboutsummaryrefslogtreecommitdiff
path: root/audio/aylet
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-05-09 07:08:33 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-05-09 07:08:33 +0000
commit1a3d515c20f5e7c00f8dccd13aee42ab6b6380fa (patch)
tree3cbbbaa9c59f5d56ff94463314e37e3b76e79b07 /audio/aylet
parent06a9a2b68e7b00fd287eb8461733206efb671112 (diff)
downloadports-1a3d515c20f5e7c00f8dccd13aee42ab6b6380fa.tar.gz
ports-1a3d515c20f5e7c00f8dccd13aee42ab6b6380fa.zip
Properly resurect aylet this time via repocopy in order to retain history. This
commit corrects r440435. Requested by: danfe
Notes
Notes: svn path=/head/; revision=440472
Diffstat (limited to 'audio/aylet')
-rw-r--r--audio/aylet/Makefile30
-rw-r--r--audio/aylet/distinfo3
-rw-r--r--audio/aylet/files/patch-Makefile38
-rw-r--r--audio/aylet/pkg-descr6
4 files changed, 77 insertions, 0 deletions
diff --git a/audio/aylet/Makefile b/audio/aylet/Makefile
new file mode 100644
index 000000000000..2c1777a65469
--- /dev/null
+++ b/audio/aylet/Makefile
@@ -0,0 +1,30 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aylet
+PORTVERSION= 0.5
+PORTREVISION= 3
+CATEGORIES= audio
+MASTER_SITES= http://www.worldofspectrum.org/pub/sinclair/music/players-unix/ \
+ LOCAL/ehaupt
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Aylet plays music files in the .ay format
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gettext-runtime pkgconfig
+
+OPTIONS_DEFINE= GUI
+OPTIONS_DEFAULT=GUI
+OPTIONS_SUB= yes
+
+GUI_USE= XORG=x11,xext,xi GNOME=gtk12
+
+ALL_TARGET= aylet
+GUI_ALL_TARGET= xaylet
+
+PLIST_FILES= bin/aylet %%GUI%%bin/xaylet man/man1/aylet.1.gz
+
+.include <bsd.port.mk>
diff --git a/audio/aylet/distinfo b/audio/aylet/distinfo
new file mode 100644
index 000000000000..87d1499a08b0
--- /dev/null
+++ b/audio/aylet/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1494173493
+SHA256 (aylet-0.5.tar.gz) = c8c428a63abe5087b0345709a9a8034c2e6873b6071d9f7b05578aae0f3a4f72
+SIZE (aylet-0.5.tar.gz) = 43577
diff --git a/audio/aylet/files/patch-Makefile b/audio/aylet/files/patch-Makefile
new file mode 100644
index 000000000000..bbb4aead136b
--- /dev/null
+++ b/audio/aylet/files/patch-Makefile
@@ -0,0 +1,38 @@
+--- Makefile.orig 2005-12-18 03:05:08 UTC
++++ Makefile
+@@ -2,7 +2,7 @@
+
+ # You need an ANSI C compiler. gcc is probably best.
+ #
+-CC=gcc
++CC?=gcc
+
+ # Compiler options (and sound driver) to use. This one is for Linux,
+ # and other OSS-using systems.
+@@ -19,10 +19,10 @@ CURSES_LIB=-lncurses
+
+ # dest for make install
+ #
+-PREFIX=/usr/local
+-BINDIR=$(PREFIX)/bin
++PREFIX?=/usr/local
++BINDIR=$(DESTDIR)$(PREFIX)/bin
+ XBINDIR=$(BINDIR)
+-MANDIR=$(PREFIX)/man/man1
++MANDIR=$(DESTDIR)$(PREFIX)/man/man1
+
+ # if you want the X version to be installed in the usual X executables
+ # directory, uncomment this (altering if necessary):
+@@ -52,10 +52,9 @@ installdirs:
+ /bin/sh ./mkinstalldirs $(BINDIR) $(XBINDIR) $(MANDIR)
+
+ install: installdirs
+- if [ -f aylet ]; then install -m 755 aylet $(BINDIR); fi
+- if [ -f xaylet ]; then install -m 755 xaylet $(XBINDIR); fi
++ if [ -f aylet ]; then strip aylet; install -m 755 aylet $(BINDIR); fi
++ if [ -f xaylet ]; then strip xaylet; install -m 755 xaylet $(XBINDIR); fi
+ install -m 644 aylet.1 $(MANDIR)
+- ln -sf $(MANDIR)/aylet.1 $(MANDIR)/xaylet.1
+
+ uninstall:
+ $(RM) $(BINDIR)/aylet $(XBINDIR)/xaylet
diff --git a/audio/aylet/pkg-descr b/audio/aylet/pkg-descr
new file mode 100644
index 000000000000..a251520478de
--- /dev/null
+++ b/audio/aylet/pkg-descr
@@ -0,0 +1,6 @@
+Aylet plays music files in the `.ay' format. These files are essentially
+wrappers around bits of Z80 code which play music on the Sinclair ZX Spectrum
+128's sound hardware - either the beeper, or (eponymously) the AY-3-8912 sound
+chip. Files using the Amstrad CPC ports are also supported.
+
+WWW: http://www.worldofspectrum.org/