aboutsummaryrefslogtreecommitdiff
path: root/audio/baresip
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-06-13 06:22:21 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-06-13 06:22:21 +0000
commiteecd79041123495098018a5b8d7e8d34152a87f6 (patch)
treeb77402e9c2d41b1ba43d4148cf6694f99c407712 /audio/baresip
parent78254ff1e5ba948c3239ab3557e1c2db3c22c567 (diff)
downloadports-eecd79041123495098018a5b8d7e8d34152a87f6.tar.gz
ports-eecd79041123495098018a5b8d7e8d34152a87f6.zip
audio/re:
- Update to 0.4.16 - Organise pkg-plist alphabetically audio/rem: - Update to 0.4.7 - Organise pkg-plist alphabetically audio/baresip: - Update to 0.4.19 - Remove CELT option (no longer supported upstream - replaced by OPUS) - Add EXAMPLES option to install new ${WRKSRC}/docs/examples - Update minimum required versions of audio/re and audio/rem [1] Changes this release: https://github.com/alfredh/baresip/blob/v0.4.19/docs/ChangeLog [1] https://github.com/alfredh/baresip/blob/v0.4.19/docs/README#L324 This upate also allows baresip to build successfully once multimedia/ffmpeg is updated to 3.0.x. Note that multimedia/ffmpeg is currently still on the 2.8.x branch, however this patch is backwards compatible with ffmpeg 2.8.x. Reported by: antoine (via exp-run) Reviewed by: mat (mentor) Approved by: crees (maintainer), adamw (mentor) Differential Revision: https://reviews.freebsd.org/D6822
Notes
Notes: svn path=/head/; revision=416830
Diffstat (limited to 'audio/baresip')
-rw-r--r--audio/baresip/Makefile23
-rw-r--r--audio/baresip/Makefile.depends1
-rw-r--r--audio/baresip/distinfo5
3 files changed, 14 insertions, 15 deletions
diff --git a/audio/baresip/Makefile b/audio/baresip/Makefile
index 1c2a11953a3b..b2e5bdeb7b47 100644
--- a/audio/baresip/Makefile
+++ b/audio/baresip/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= baresip
-PORTVERSION= 0.4.8
-PORTREVISION= 4
+PORTVERSION= 0.4.19
CATEGORIES= audio
MASTER_SITES= http://www.creytiv.com/pub/
@@ -12,8 +11,8 @@ COMMENT= Small SIP client
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/docs/COPYING
-BUILD_DEPENDS= re>=0.4.6:audio/re \
- rem>=0.4.4:audio/rem
+BUILD_DEPENDS= re>=0.4.14:audio/re \
+ rem>=0.4.7:audio/rem
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= gmake pkgconfig
@@ -23,10 +22,11 @@ MAKE_ARGS= MOD_AUTODETECT=""
PLIST_FILES= bin/baresip
PORTDATA= *
PORTDOCS= *
+PORTEXAMPLES= *
#OPTIONS_NOT_YET_WORKING= ALSA BV32 G722_1 PLC ISAC OPENGLES
-OPTIONS_DEFINE= CELT CONS DOCS FFMPEG G711 G722 G726 GSM GSTREAMER ILBC L16 \
- OPUS OSS PORTAUDIO SDL SNDFILE SPEEX SRTP STDIO UUID V4L V4L2 X11 \
+OPTIONS_DEFINE= CONS DOCS EXAMPLES FFMPEG G711 G722 G726 GSM GSTREAMER ILBC \
+ L16 OPUS OSS PORTAUDIO SDL SNDFILE SPEEX SRTP STDIO UUID V4L V4L2 X11 \
DTLS_SRTP AUBRIDGE VIDBRIDGE HTTPD DSHOW DIRECTFB ACCOUNT \
NATPMP SDL MIW SNAPSHOT SELFVIEW VUMETER AULOOP CONTACT \
MENU PRESENCE SYSLOG VIDLOOP
@@ -34,7 +34,6 @@ OPTIONS_DEFAULT=CONS G711 G722 G726 L16
AULOOP_DESC= Audio-loop test module
BV32_DESC= BroadVoice32 Wideband Audio codec
-CELT_DESC= Celt support [broken]
CONTACT_DESC= Contacts module
CONS_DESC= Console input driver
DTLS_SRTP_DESC= DTLS Secure RTP module [broken]
@@ -84,7 +83,7 @@ MAKE_ARGS+= USE_$s=yes
MAKE_ARGS+= HAVE_SPEEXDSP=yes
.endif
-.for o in CELT SRTP V4L DTLS_SRTP V4L2 X11
+.for o in SRTP V4L DTLS_SRTP V4L2 X11
. if ${PORT_OPTIONS:M$o}
BROKEN= OPTIONS marked as BROKEN have not been updated to the new Baresip API
. endif
@@ -106,8 +105,6 @@ post-patch:
${ECHO_CMD} ".PHONY: showmodules" >> ${WRKSRC}/Makefile
${ECHO_CMD} "showmodules:" >> ${WRKSRC}/Makefile
${ECHO_CMD} ' @${ECHO_CMD} $$(MODULES)' >> ${WRKSRC}/Makefile
- ${REINPLACE_CMD} 's,-lcelt[0-9]*,$$(pkg-config --libs celt),' \
- ${WRKSRC}/modules/celt/module.mk
${REINPLACE_CMD} 's,-lportaudio[0-9]*,-L${LOCALBASE}/lib -lportaudio,' \
${WRKSRC}/modules/portaudio/module.mk
@@ -124,7 +121,9 @@ post-install:
${STAGEDIR}${PREFIX}/lib/baresip/modules; \
${ECHO_CMD} lib/${PORTNAME}/modules/$$m.so >> ${TMPPLIST}; \
done
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ ${MV} ${STAGEDIR}${DOCSDIR}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ ${RMDIR} ${STAGEDIR}${DOCSDIR}/examples
.include <bsd.port.mk>
diff --git a/audio/baresip/Makefile.depends b/audio/baresip/Makefile.depends
index 39b20a99c45a..2dbc5bc24e01 100644
--- a/audio/baresip/Makefile.depends
+++ b/audio/baresip/Makefile.depends
@@ -2,7 +2,6 @@
ALSA_DEPEND= ${LOCALBASE}/include/alsa/asoundlib.h:audio/alsa-lib
BV32_DEPEND= # nonexistent
-CELT_DEPEND= ${LOCALBASE}/include/celt/celt.h:audio/celt
CONS_DEPEND= # unnecessary
DTLS_SRTP_DEPEND= # unnecessary
EVDEV_DEPEND=
diff --git a/audio/baresip/distinfo b/audio/baresip/distinfo
index bf6ad9d396c5..4370463cd41d 100644
--- a/audio/baresip/distinfo
+++ b/audio/baresip/distinfo
@@ -1,2 +1,3 @@
-SHA256 (baresip-0.4.8.tar.gz) = f13f63aa27bd565dcd08d5fd56cc5eae9043495b27513a7e488bd2935c2932f7
-SIZE (baresip-0.4.8.tar.gz) = 360486
+TIMESTAMP = 1465682412
+SHA256 (baresip-0.4.19.tar.gz) = bb8c62da225d7ee30ad371e6e0cd0f4bb663635e73b8c09cd43b054b981eb0d1
+SIZE (baresip-0.4.19.tar.gz) = 449660