aboutsummaryrefslogtreecommitdiff
path: root/audio/bcg729
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-17 10:43:16 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-17 10:43:16 +0000
commitfa4a8de0b25cd897b144e9b6e590b41b8f7996fa (patch)
tree1f2238380dfc9c1a03e0390c86b6ddf51f40f05c /audio/bcg729
parent85c1338e3ddb219fa28d0ab3106436816fcdcd75 (diff)
downloadports-fa4a8de0b25cd897b144e9b6e590b41b8f7996fa.tar.gz
ports-fa4a8de0b25cd897b144e9b6e590b41b8f7996fa.zip
Create a separate port for the Mediastreamer plugin in audio/bcg729
Approved by: madpilot
Notes
Notes: svn path=/head/; revision=384149
Diffstat (limited to 'audio/bcg729')
-rw-r--r--audio/bcg729/Makefile16
-rw-r--r--audio/bcg729/files/patch-Makefile.am11
-rw-r--r--audio/bcg729/files/patch-include_bcg729_Makefile.am13
-rw-r--r--audio/bcg729/files/patch-src_Makefile.am11
-rw-r--r--audio/bcg729/pkg-descr2
-rw-r--r--audio/bcg729/pkg-plist4
6 files changed, 4 insertions, 53 deletions
diff --git a/audio/bcg729/Makefile b/audio/bcg729/Makefile
index 27e1f1a3961b..5e773e82bbf7 100644
--- a/audio/bcg729/Makefile
+++ b/audio/bcg729/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bcg729
PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= SAVANNAH/linphone/plugins/sources
@@ -14,19 +14,9 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-strict
+CONFIGURE_ARGS= --disable-msplugin --disable-strict
INSTALL_TARGET= install-strip
-USES= autoreconf libtool pkgconfig
+USES= libtool pathfix pkgconfig
USE_LDCONFIG= yes
-OPTIONS_DEFINE= MEDIASTREAMER
-OPTIONS_DEFAULT= MEDIASTREAMER
-
-MEDIASTREAMER_DESC= Mediastreamer(linphone) support
-
-OPTIONS_SUB= yes
-MEDIASTREAMER_CONFIGURE_ENABLE= msplugin
-MEDIASTREAMER_LIB_DEPENDS= libortp.so:${PORTSDIR}/net/ortp \
- libmediastreamer_base.so:${PORTSDIR}/net/mediastreamer
-
.include <bsd.port.mk>
diff --git a/audio/bcg729/files/patch-Makefile.am b/audio/bcg729/files/patch-Makefile.am
deleted file mode 100644
index 4a227edc7caa..000000000000
--- a/audio/bcg729/files/patch-Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.am.orig 2015-02-25 20:45:18 UTC
-+++ Makefile.am
-@@ -10,7 +10,7 @@ endif
- if RUN_TESTS
- SUBDIRS += test
- endif
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = libbcg729.pc
-
- rpm:
diff --git a/audio/bcg729/files/patch-include_bcg729_Makefile.am b/audio/bcg729/files/patch-include_bcg729_Makefile.am
deleted file mode 100644
index a30d64f5e9f7..000000000000
--- a/audio/bcg729/files/patch-include_bcg729_Makefile.am
+++ /dev/null
@@ -1,13 +0,0 @@
---- include/bcg729/Makefile.am.orig 2015-03-12 20:39:23 UTC
-+++ include/bcg729/Makefile.am
-@@ -2,9 +2,6 @@ bcg729_includedir=$(includedir)/bcg729
-
- public_headers=encoder.h decoder.h
-
--bcg729_include_HEADERS=
--if !BUILD_MSBCG729
--bcg729_include_HEADERS+=$(public_headers)
--endif
-+bcg729_include_HEADERS=$(public_headers)
-
- EXTRA_DIST=$(public_headers)
diff --git a/audio/bcg729/files/patch-src_Makefile.am b/audio/bcg729/files/patch-src_Makefile.am
deleted file mode 100644
index a84c6bb55977..000000000000
--- a/audio/bcg729/files/patch-src_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.am.orig 2015-03-12 20:39:18 UTC
-+++ src/Makefile.am
-@@ -1,8 +1,4 @@
--if BUILD_MSBCG729
--noinst_LTLIBRARIES = libbcg729.la
--else
- lib_LTLIBRARIES = libbcg729.la
--endif
-
- libbcg729_la_SOURCES= LP2LSPConversion.c \
- LPSynthesisFilter.c \
diff --git a/audio/bcg729/pkg-descr b/audio/bcg729/pkg-descr
index 16542e106634..1bf6f9c31b15 100644
--- a/audio/bcg729/pkg-descr
+++ b/audio/bcg729/pkg-descr
@@ -7,4 +7,4 @@ It can be executed on many platforms, including both ARM and x86 with very
decent performances. libbcg729 supports concurrent channel encoding/decoding
for multi-call applications such as conferencing.
-WWW: http://www.linphone.org/technical-corner/bcg729.html
+WWW: https://www.linphone.org/technical-corner/bcg729.html
diff --git a/audio/bcg729/pkg-plist b/audio/bcg729/pkg-plist
index 462ba016d067..5fcf3b9f1f35 100644
--- a/audio/bcg729/pkg-plist
+++ b/audio/bcg729/pkg-plist
@@ -4,8 +4,4 @@ lib/libbcg729.a
lib/libbcg729.so
lib/libbcg729.so.0
lib/libbcg729.so.0.0.0
-%%MEDIASTREAMER%%lib/mediastreamer/plugins/libmsbcg729.a
-%%MEDIASTREAMER%%lib/mediastreamer/plugins/libmsbcg729.so
-%%MEDIASTREAMER%%lib/mediastreamer/plugins/libmsbcg729.so.0
-%%MEDIASTREAMER%%lib/mediastreamer/plugins/libmsbcg729.so.0.0.0
libdata/pkgconfig/libbcg729.pc