aboutsummaryrefslogtreecommitdiff
path: root/audio/blop
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-05-01 21:02:51 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-05-01 21:02:51 +0000
commit4b32a0c05543bbe9b118e0f5ffb5b008397856c8 (patch)
treeaf851536a3da593e8ee4ce443b22d15adc89d120 /audio/blop
parent21c6bef5c952ca3410a25a88d9d496083eb7221e (diff)
downloadports-4b32a0c05543bbe9b118e0f5ffb5b008397856c8.tar.gz
ports-4b32a0c05543bbe9b118e0f5ffb5b008397856c8.zip
Update to 0.2.7
USE_GETOPT_LONG PR: 51510 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=79959
Diffstat (limited to 'audio/blop')
-rw-r--r--audio/blop/Makefile19
-rw-r--r--audio/blop/distinfo2
-rw-r--r--audio/blop/files/patch-src-sequencer.so.c37
-rw-r--r--audio/blop/files/patch-src-sequencer16_1677.so.c27
-rw-r--r--audio/blop/files/patch-src-sequencer32_1676.so.c27
-rw-r--r--audio/blop/files/patch-src-sequencer64_1675.so.c27
-rw-r--r--audio/blop/pkg-plist1
7 files changed, 50 insertions, 90 deletions
diff --git a/audio/blop/Makefile b/audio/blop/Makefile
index 2657c18f4be6..ed04c1c37703 100644
--- a/audio/blop/Makefile
+++ b/audio/blop/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= blop
-PORTVERSION= 0.2.6
+PORTVERSION= 0.2.7
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,16 +14,19 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Bandlimited oscillator plugins for LADSPA-aware audio applications
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
-.if !exists(/usr/include/getopt.h)
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lgnugetopt"
-.endif
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=
-CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
- --with-ladspa-prefix="${LOCALBASE}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-ladspa-prefix="${LOCALBASE}"
+
+post-patch:
+ @${REINPLACE_CMD} 's|-pipe -Wall -O3 |\$$CFLAGS |g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|\$$(LIBS)|\$$(LIBS) \$$(LDFLAGS)|g ; \
+ s|-lc | |g'
pre-build:
cd ${WRKSRC}/src; ${GMAKE} sawtooth_data.h square_data.h parabola_data.h
diff --git a/audio/blop/distinfo b/audio/blop/distinfo
index efd81d05cb0c..e39782ed294d 100644
--- a/audio/blop/distinfo
+++ b/audio/blop/distinfo
@@ -1 +1 @@
-MD5 (blop-0.2.6.tar.gz) = 09af3065164045d7792eb9f159b24d12
+MD5 (blop-0.2.7.tar.gz) = cc40f5eeb03c6657349c700d2dc9e382
diff --git a/audio/blop/files/patch-src-sequencer.so.c b/audio/blop/files/patch-src-sequencer.so.c
new file mode 100644
index 000000000000..934dc85bac29
--- /dev/null
+++ b/audio/blop/files/patch-src-sequencer.so.c
@@ -0,0 +1,37 @@
+--- src/sequencer.so.c.orig Mon Feb 17 04:20:44 2003
++++ src/sequencer.so.c Fri Apr 25 02:44:42 2003
+@@ -136,6 +136,8 @@
+ void runSequencer(LADSPA_Handle instance,
+ unsigned long sample_count)
+ {
++ int i, rst;
++ unsigned long s;
+ Sequencer *plugin = (Sequencer *)instance;
+
+ /* Gate */
+@@ -167,9 +169,7 @@
+
+ unsigned int step_index = plugin->step_index;
+ unsigned int loop_index = lrintf(loop_steps);
+- int rst = lrintf(reset);
+- int i;
+- unsigned long s;
++ rst = lrintf(reset);
+
+ loop_index = loop_index == 0 ? 1 : loop_index;
+ loop_index = loop_index > SEQUENCER_MAX_INPUTS ? SEQUENCER_MAX_INPUTS : loop_index;
+@@ -223,12 +223,12 @@
+ void (*run_functions[])(LADSPA_Handle,
+ unsigned long) = {runSequencer};
+
+- sequencer_descriptors = (LADSPA_Descriptor **)calloc(SEQUENCER_VARIANT_COUNT, sizeof(LADSPA_Descriptor));
+-
+ char label[12];
+ char name[33];
+ char loop_point_label[20];
+ char value_label[14];
++
++ sequencer_descriptors = (LADSPA_Descriptor **)calloc(SEQUENCER_VARIANT_COUNT, sizeof(LADSPA_Descriptor));
+
+ /* Mmmm. Lovely... */
+ sprintf(label, "%s%d", "sequencer", SEQUENCER_MAX_INPUTS);
diff --git a/audio/blop/files/patch-src-sequencer16_1677.so.c b/audio/blop/files/patch-src-sequencer16_1677.so.c
deleted file mode 100644
index 6217362fcbf7..000000000000
--- a/audio/blop/files/patch-src-sequencer16_1677.so.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/sequencer16_1677.so.c.orig Tue Feb 11 09:18:27 2003
-+++ src/sequencer16_1677.so.c Tue Feb 11 09:18:44 2003
-@@ -132,6 +132,8 @@
- void runSequencer(LADSPA_Handle instance,
- unsigned long sample_count)
- {
-+ int i,rst;
-+ unsigned long s;
- Sequencer *plugin = (Sequencer *)instance;
-
- /* Gate */
-@@ -165,14 +167,11 @@
- unsigned int loop_index = f_round_i(loop_steps);
- loop_index = loop_index == 0 ? 1 : loop_index;
- loop_index = loop_index > 16 ? 16 : loop_index;
-- int rst = f_round_i(reset);
-- int i;
-+ rst = f_round_i(reset);
-
- for (i = 0; i < 16; i++) {
- values[i] = *(plugin->values[i]);
- }
--
-- unsigned long s;
-
- for (s = 0; s < sample_count; s++) {
- if (gate[s] > 0.0f) {
diff --git a/audio/blop/files/patch-src-sequencer32_1676.so.c b/audio/blop/files/patch-src-sequencer32_1676.so.c
deleted file mode 100644
index b17cdc6c6bd5..000000000000
--- a/audio/blop/files/patch-src-sequencer32_1676.so.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/sequencer32_1676.so.c.orig Tue Feb 11 09:17:55 2003
-+++ src/sequencer32_1676.so.c Tue Feb 11 09:18:15 2003
-@@ -132,6 +132,8 @@
- void runSequencer(LADSPA_Handle instance,
- unsigned long sample_count)
- {
-+ int i,rst;
-+ unsigned long s;
- Sequencer *plugin = (Sequencer *)instance;
-
- /* Gate */
-@@ -165,14 +167,11 @@
- unsigned int loop_index = f_round_i(loop_steps);
- loop_index = loop_index == 0 ? 1 : loop_index;
- loop_index = loop_index > 32 ? 32 : loop_index;
-- int rst = f_round_i(reset);
-- int i;
-+ rst = f_round_i(reset);
-
- for (i = 0; i < 32; i++) {
- values[i] = *(plugin->values[i]);
- }
--
-- unsigned long s;
-
- for (s = 0; s < sample_count; s++) {
- if (gate[s] > 0.0f) {
diff --git a/audio/blop/files/patch-src-sequencer64_1675.so.c b/audio/blop/files/patch-src-sequencer64_1675.so.c
deleted file mode 100644
index f77dcc760049..000000000000
--- a/audio/blop/files/patch-src-sequencer64_1675.so.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/sequencer64_1675.so.c.orig Tue Feb 11 09:17:22 2003
-+++ src/sequencer64_1675.so.c Tue Feb 11 09:17:46 2003
-@@ -132,6 +132,8 @@
- void runSequencer(LADSPA_Handle instance,
- unsigned long sample_count)
- {
-+ int i,rst;
-+ unsigned long s;
- Sequencer *plugin = (Sequencer *)instance;
-
- /* Gate */
-@@ -165,14 +167,11 @@
- unsigned int loop_index = f_round_i(loop_steps);
- loop_index = loop_index == 0 ? 1 : loop_index;
- loop_index = loop_index > 64 ? 64 : loop_index;
-- int rst = f_round_i(reset);
-- int i;
-+ rst = f_round_i(reset);
-
- for (i = 0; i < 64; i++) {
- values[i] = *(plugin->values[i]);
- }
--
-- unsigned long s;
-
- for (s = 0; s < sample_count; s++) {
- if (gate[s] > 0.0f) {
diff --git a/audio/blop/pkg-plist b/audio/blop/pkg-plist
index 8989970e697b..379a42772faa 100644
--- a/audio/blop/pkg-plist
+++ b/audio/blop/pkg-plist
@@ -16,3 +16,4 @@ lib/ladspa/square_1643.so
lib/ladspa/sum_1665.so
lib/ladspa/sync_square_1678.so
lib/ladspa/triangle_1649.so
+@unexec rmdir %D/lib/ladspa 2>/dev/null || true