aboutsummaryrefslogtreecommitdiff
path: root/audio/bristol
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-10-01 21:52:42 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-10-01 21:52:42 +0000
commit2bf029bae6d5b0ebbf78cfaf0b0a78c9349ba229 (patch)
treef3bcd5583c91283bc59bb633749182db6dc98249 /audio/bristol
parent6b92a312242e68ff5fe26224dd18259b7a3c1a28 (diff)
downloadports-2bf029bae6d5b0ebbf78cfaf0b0a78c9349ba229.tar.gz
ports-2bf029bae6d5b0ebbf78cfaf0b0a78c9349ba229.zip
Bristol is an emulation package for a number of different 'classic'
synthesisers including additive, subtractive and a few organs. The application consists of the engine, which is called bristol, and its own GUI library called brighton that represents all the emulations. WWW: http://bristol.sourceforge.net/ PR: ports/169861 Submitted by: pjm <pierrejacqes.mimifir@gmail.com>
Notes
Notes: svn path=/head/; revision=305142
Diffstat (limited to 'audio/bristol')
-rw-r--r--audio/bristol/Makefile34
-rw-r--r--audio/bristol/distinfo2
-rw-r--r--audio/bristol/files/patch-bin_startBristol.in44
-rw-r--r--audio/bristol/files/patch-bristol-bristol.c14
-rw-r--r--audio/bristol/files/patch-libbristolaudio-audioEngine.c13
-rw-r--r--audio/bristol/files/patch-libbristolaudio-audioGUIOSS.c12
-rw-r--r--audio/bristol/pkg-descr7
-rw-r--r--audio/bristol/pkg-plist32
8 files changed, 158 insertions, 0 deletions
diff --git a/audio/bristol/Makefile b/audio/bristol/Makefile
new file mode 100644
index 000000000000..7da91e491360
--- /dev/null
+++ b/audio/bristol/Makefile
@@ -0,0 +1,34 @@
+# Created by: pjm <pierrejacqes.mimifir@gmail.com>
+# $FreeBSD$
+
+PORTNAME= bristol
+PORTVERSION= 0.60.10
+CATEGORIES= audio
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.60
+
+MAINTAINER= pierrejacques.mimifir@gmail.com
+COMMENT= Vintage synthesiers emulation for electric pianos and organs
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= jack:${PORTSDIR}/audio/jack \
+ fluidsynth:${PORTSDIR}/audio/fluidsynth
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui qmake_build moc_build uic_build rcc_build linguist_build
+
+CONFIGURE_ARGS+= --disable-alsa --enable-oss \
+ --enable-jack-default-audio \
+ --enable-jack-default-midi \
+ --disable-version-check
+
+MAKE_JOBS_SAFE= yes
+
+MAN1= bristol.1 bristoljackstats.1
+MLINKS= bristol.1 brighton.1 bristol.1 startBristol.1
+
+PORTDATA= *
+
+.include <bsd.port.mk>
diff --git a/audio/bristol/distinfo b/audio/bristol/distinfo
new file mode 100644
index 000000000000..c264c7795a73
--- /dev/null
+++ b/audio/bristol/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bristol-0.60.10.tar.gz) = a39cee4d7d59422b67a55620ae17f5b4aff162bf39077e70c5799bde7eb1191c
+SIZE (bristol-0.60.10.tar.gz) = 4206356
diff --git a/audio/bristol/files/patch-bin_startBristol.in b/audio/bristol/files/patch-bin_startBristol.in
new file mode 100644
index 000000000000..2ef201ac8607
--- /dev/null
+++ b/audio/bristol/files/patch-bin_startBristol.in
@@ -0,0 +1,44 @@
+--- bin/startBristol.in.orig 2012-04-27 13:07:18.000000000 +0200
++++ bin/startBristol.in 2012-09-24 13:30:26.589848964 +0200
+@@ -39,14 +39,19 @@
+ #PORT=5028
+ # Randomise the port numbers, can be overridden by -port which would be a
+ # requirement for multitimbral
+-PORT=`date +%N`
+-PORT=`expr $PORT % 65536` >/dev/null 2>&1
+-if [ -z $PORT ]; then
+- PORT=`date +%s`
++UNAME=`uname`
++if [ "${UNAME}x" = "FreeBSDx" ]; then
++ PORT=`jot -r 1 1025 65536`
++else
++ PORT=`date +%N`
+ PORT=`expr $PORT % 65536` >/dev/null 2>&1
+-fi
+-if [ $PORT -lt 1024 ]; then
+- PORT=`expr $PORT + 5028`
++ if [ -z $PORT ]; then
++ PORT=`date +%s`
++ PORT=`expr $PORT % 65536` >/dev/null 2>&1
++ fi
++ if [ $PORT -lt 1024 ]; then
++ PORT=`expr $PORT + 5028`
++ fi
+ fi
+
+ valgrind=0
+@@ -497,12 +502,12 @@
+ fi
+ else
+ echo checking availability of TCP port $PORT
+- netstat -taln | awk '{print $4}' | grep $PORT > /dev/null
++ netstat -a -f inet -p tcp -ln | grep $PORT > /dev/null
+ while [ $? -eq 0 ]; do
+ echo -n "port looked busy, trying "
+ PORT=`expr $PORT + 1`
+ echo $PORT
+- netstat -taln | grep $PORT > /dev/null
++ netstat -a -f inet -p tcp -ln | grep $PORT > /dev/null
+ done
+ if [ ${PORT} -lt 1024 -a ${USER} != "root" ]; then
+ echo you may not have permissions for ports less than 1024
diff --git a/audio/bristol/files/patch-bristol-bristol.c b/audio/bristol/files/patch-bristol-bristol.c
new file mode 100644
index 000000000000..e98e58d1f7a3
--- /dev/null
+++ b/audio/bristol/files/patch-bristol-bristol.c
@@ -0,0 +1,14 @@
+--- bristol/bristol.c.orig 2012-04-27 13:04:28.000000000 +0200
++++ bristol/bristol.c 2012-09-24 15:43:08.299853839 +0200
+@@ -27,7 +27,11 @@
+ #include <unistd.h>
+ #include <pthread.h>
+ #include <sys/types.h>
++#ifdef __FreeBSD__
++#include <sys/wait.h>
++#else
+ #include <wait.h>
++#endif
+
+ #if defined(linux)
+ #include <sched.h>
diff --git a/audio/bristol/files/patch-libbristolaudio-audioEngine.c b/audio/bristol/files/patch-libbristolaudio-audioEngine.c
new file mode 100644
index 000000000000..c8802e81d6cf
--- /dev/null
+++ b/audio/bristol/files/patch-libbristolaudio-audioEngine.c
@@ -0,0 +1,13 @@
+--- libbristolaudio/audioEngine.c.orig 2012-04-27 13:04:29.000000000 +0200
++++ libbristolaudio/audioEngine.c 2012-09-24 15:41:49.609845763 +0200
+@@ -59,8 +59,10 @@
+ #include <fcntl.h>
+ #ifdef SUBFRAGMENT
+ #include <stdlib.h>
++#ifndef __FreeBSD__
+ #include <malloc.h>
+ #endif
++#endif
+
+ #include <sys/ioctl.h>
+
diff --git a/audio/bristol/files/patch-libbristolaudio-audioGUIOSS.c b/audio/bristol/files/patch-libbristolaudio-audioGUIOSS.c
new file mode 100644
index 000000000000..cc07057ab980
--- /dev/null
+++ b/audio/bristol/files/patch-libbristolaudio-audioGUIOSS.c
@@ -0,0 +1,12 @@
+--- libbristolaudio/audioGUIOSS.c.orig 2012-04-27 13:04:29.000000000 +0200
++++ libbristolaudio/audioGUIOSS.c 2012-09-24 15:42:10.570849586 +0200
+@@ -50,7 +50,9 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <stdlib.h>
++#ifndef __FreeBSD__
+ #include <malloc.h>
++#endif
+
+ static int setAudioOSS(int, duplexDev *, int, int, int);
+
diff --git a/audio/bristol/pkg-descr b/audio/bristol/pkg-descr
new file mode 100644
index 000000000000..314de9df03ef
--- /dev/null
+++ b/audio/bristol/pkg-descr
@@ -0,0 +1,7 @@
+Bristol is an emulation package for a number of different 'classic'
+synthesisers including additive, subtractive and a few organs.
+The application consists of the engine, which is called bristol,
+and its own GUI library called brighton that represents all the
+emulations.
+
+WWW: http://bristol.sourceforge.net/
diff --git a/audio/bristol/pkg-plist b/audio/bristol/pkg-plist
new file mode 100644
index 000000000000..e77dde614ef3
--- /dev/null
+++ b/audio/bristol/pkg-plist
@@ -0,0 +1,32 @@
+bin/startBristol
+bin/bristoljackstats
+bin/bristol
+bin/brighton
+lib/libbristolaudio.so.0
+lib/libbristolaudio.so
+lib/libbristolaudio.la
+lib/libbristolaudio.a
+lib/libbvg.so.0
+lib/libbvg.so
+lib/libbvg.la
+lib/libbvg.a
+lib/libbristolmidi.so.0
+lib/libbristolmidi.so
+lib/libbristolmidi.la
+lib/libbristolmidi.a
+lib/libbristolic.so.0
+lib/libbristolic.so
+lib/libbristolic.la
+lib/libbristolic.a
+lib/libbristol.so.0
+lib/libbristol.so
+lib/libbristol.la
+lib/libbristol.a
+lib/libbrighton.so.0
+lib/libbrighton.so
+lib/libbrighton.la
+lib/libbrighton.a
+lib/libC11.so.0
+lib/libC11.so
+lib/libC11.la
+lib/libC11.a