aboutsummaryrefslogtreecommitdiff
path: root/audio/bsequencer-lv2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-09-04 09:07:28 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-09-04 09:07:28 +0000
commit5c91460cb2673657fc6fac7d8571461a70fa6753 (patch)
treeaa039e66578380ed3a7c709f2533d1a09782d52c /audio/bsequencer-lv2
parent409b8a4ef53dd4db62453fefca434b8f751ae6d8 (diff)
downloadports-5c91460cb2673657fc6fac7d8571461a70fa6753.tar.gz
ports-5c91460cb2673657fc6fac7d8571461a70fa6753.zip
audio/bsequencer-lv2: Update 0.3-17 -> 0.4
Reported by: portscout
Notes
Notes: svn path=/head/; revision=511069
Diffstat (limited to 'audio/bsequencer-lv2')
-rw-r--r--audio/bsequencer-lv2/Makefile5
-rw-r--r--audio/bsequencer-lv2/distinfo6
-rw-r--r--audio/bsequencer-lv2/files/patch-src_BSEQuencer.cpp11
3 files changed, 16 insertions, 6 deletions
diff --git a/audio/bsequencer-lv2/Makefile b/audio/bsequencer-lv2/Makefile
index a794bb57e051..b7040c8a3ee4 100644
--- a/audio/bsequencer-lv2/Makefile
+++ b/audio/bsequencer-lv2/Makefile
@@ -2,8 +2,7 @@
PORTNAME= bsequencer
DISTVERSIONPREFIX= v
-DISTVERSION= 0.3-17
-DISTVERSIONSUFFIX= -g265b06c
+DISTVERSION= 0.4
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@@ -15,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= lv2>0:audio/lv2
-USES= compiler:c++11-lang gmake gnome pkgconfig
+USES= compiler:c++11-lang gmake gnome pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= sjaehn
GH_PROJECT= BSEQuencer
diff --git a/audio/bsequencer-lv2/distinfo b/audio/bsequencer-lv2/distinfo
index ec16aeef739b..00542ff11bfb 100644
--- a/audio/bsequencer-lv2/distinfo
+++ b/audio/bsequencer-lv2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1563133017
-SHA256 (sjaehn-BSEQuencer-v0.3-17-g265b06c_GH0.tar.gz) = 53a3882a2b7c0b28f2bbc24c662379121f764f598a2423bd731a87033581ac14
-SIZE (sjaehn-BSEQuencer-v0.3-17-g265b06c_GH0.tar.gz) = 1142523
+TIMESTAMP = 1567585780
+SHA256 (sjaehn-BSEQuencer-v0.4_GH0.tar.gz) = 43c77121d0460b98c38b07741b679440d947455f03a90b82a3e7f77940d0ae6d
+SIZE (sjaehn-BSEQuencer-v0.4_GH0.tar.gz) = 1144889
diff --git a/audio/bsequencer-lv2/files/patch-src_BSEQuencer.cpp b/audio/bsequencer-lv2/files/patch-src_BSEQuencer.cpp
new file mode 100644
index 000000000000..cac46c209464
--- /dev/null
+++ b/audio/bsequencer-lv2/files/patch-src_BSEQuencer.cpp
@@ -0,0 +1,11 @@
+--- src/BSEQuencer.cpp.orig 2019-09-04 08:30:06 UTC
++++ src/BSEQuencer.cpp
+@@ -626,7 +626,7 @@ void BSEQuencer::run (uint32_t n_samples)
+ PadMessage* pMes = (PadMessage*) (&vec->body + 1);
+
+ // Copy PadMessages to pads
+- for (uint i = 0; i < size; ++i)
++ for (unsigned i = 0; i < size; ++i)
+ {
+ int row = (int) pMes[i].row;
+ int step = (int) pMes[i].step;