aboutsummaryrefslogtreecommitdiff
path: root/audio/cantata
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-06-15 08:36:58 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-06-15 08:36:58 +0000
commit012f2d35060774a63d292e47ba3506ab62ecba19 (patch)
treee10c76021e55d0ac66164817f64918e85b83e4b0 /audio/cantata
parente5c8bd2806a4b94fcf07b33620f85b3deb4cac60 (diff)
downloadports-012f2d35060774a63d292e47ba3506ab62ecba19.tar.gz
ports-012f2d35060774a63d292e47ba3506ab62ecba19.zip
Notes
Notes: svn path=/head/; revision=416916
Diffstat (limited to 'audio/cantata')
-rw-r--r--audio/cantata/Makefile74
-rw-r--r--audio/cantata/distinfo5
-rw-r--r--audio/cantata/files/patch-git_c0a75da26
-rw-r--r--audio/cantata/files/patch-replaygain_ffmpeginput.cpp10
-rw-r--r--audio/cantata/files/patch-replaygain_mpg123input.cpp10
-rw-r--r--audio/cantata/files/patch-svn-5739-gui__application_qt.cpp39
-rw-r--r--audio/cantata/pkg-descr24
-rw-r--r--audio/cantata/pkg-plist88
8 files changed, 137 insertions, 139 deletions
diff --git a/audio/cantata/Makefile b/audio/cantata/Makefile
index dfb87ced5129..ed943e1d3f80 100644
--- a/audio/cantata/Makefile
+++ b/audio/cantata/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= cantata
-PORTVERSION= 1.5.1
-PORTREVISION= 3
+PORTVERSION= 2.0.1
+DISTVERSIONPREFIX= v
CATEGORIES= audio kde
-MASTER_SITES= https://drive.google.com/uc?export=download&id=0Bzghs6gQWi60UktwaTRMTjRIUW8&dummy=
MAINTAINER= kde@FreeBSD.org
COMMENT= Graphical client for MPD using Qt5
@@ -12,40 +11,57 @@ COMMENT= Graphical client for MPD using Qt5
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_KDE4= oxygen
-USE_QT5= buildtools_build concurrent core dbus gui \
- network qmake_build linguisttools svg widgets xml
+USE_GITHUB= yes
+GH_ACCOUNT= CDrummond
-FETCH_BEFORE_ARGS= -o ${DISTFILES}
+USE_QT5= buildtools_build concurrent core dbus gui network \
+ qmake_build sql sql-sqlite3_run svg widgets xml
CMAKE_ARGS= -DENABLE_QT5:BOOL=TRUE \
- -DENABLE_KDE:BOOL=FALSE \
- -DLCONVERT_EXECUTABLE:STRING=${QT_BINDIR}/lconvert \
- -DLRELEASE_EXECUTABLE:STRING=${QT_BINDIR}/lrelease
+ -DENABLE_KDE:BOOL=FALSE
USES= cmake:outsource cpe pkgconfig shebangfix tar:bzip2
SHEBANG_FILES= dynamic/cantata-dynamic cantata-remote.cmake
CPE_VENDOR= craig_drummond
USE_LDCONFIG= yes
-INSTALLS_ICONS= yes
-
-OPTIONS_DEFINE= CDDB CDPARANOIA FFMPEG MPG123 MTP MUSICBRAINZ TAGLIB
-OPTIONS_DEFAULT= TAGLIB
+OPTIONS_DEFINE= CDPARANOIA MTP NLS PROXY TAGLIB
+OPTIONS_GROUP= CDINFO REPLAYGAIN
+OPTIONS_GROUP_CDINFO= CDDB MUSICBRAINZ
+OPTIONS_GROUP_REPLAYGAIN= FFMPEG MPG123
+OPTIONS_RADIO= HSP
+OPTIONS_RADIO_HSP= QT5 VLC
+OPTIONS_DEFAULT= CDDB CDPARANOIA FFMPEG MPG123 MTP MUSICBRAINZ TAGLIB VLC
OPTIONS_SUB= yes
+CDDB_DESC= CD info retrieval via CDDB
+CDINFO_DESC= AudioCD support
+FFMPEG_DESC= ReplayGain calculation support via FFmpeg
+HSP_DESC= MPD HTTP stream playback
+MPG123_DESC= ReplayGain calculation support via mpg123
+MUSICBRAINZ_DESC= CD info retrieval via MusicBrainz
+PROXY_DESC= Proxy configuration in settings dialog
+QT5_DESC= HTTP streams support via QtMultimedia
+REPLAYGAIN_DESC= Replaygain calculation support
+TAGLIB_DESC= Reading and editing Meta-Data of audio files
+VLC_DESC= HTTP streams support via libVLC
+
+CDDB_IMPLIES= CDPARANOIA
CDDB_LIB_DEPENDS= libcddb.so:audio/libcddb
CDDB_CMAKE_ON= -DENABLE_CDDB:BOOL=TRUE
CDDB_CMAKE_OFF= -DENABLE_CDDB:BOOL=FALSE
+CDPARANOIA_IMPLIES= TAGLIB
CDPARANOIA_LIB_DEPENDS= libcdda_interface.so:audio/cdparanoia
CDPARANOIA_CMAKE_ON= -DENABLE_CDPARANOIA:BOOL=TRUE
CDPARANOIA_CMAKE_OFF= -DENABLE_CDPARANOIA:BOOL=FALSE
+FFMPEG_IMPLIES= TAGLIB
FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
FFMPEG_CMAKE_ON= -DENABLE_FFMPEG:BOOL=TRUE
FFMPEG_CMAKE_OFF= -DENABLE_FFMPEG:BOOL=FALSE
+MPG123_IMPLIES= TAGLIB
MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
MPG123_CMAKE_ON= -DENABLE_MPG123:BOOL=TRUE
MPG123_CMAKE_OFF= -DENABLE_MPG123:BOOL=FALSE
@@ -54,25 +70,47 @@ MTP_LIB_DEPENDS= libmtp.so:multimedia/libmtp
MTP_CMAKE_ON= -DENABLE_MTP:BOOL=TRUE
MTP_CMAKE_OFF= -DENABLE_MTP:BOOL=FALSE
+MUSICBRAINZ_IMPLIES= CDPARANOIA
MUSICBRAINZ_LIB_DEPENDS=libmusicbrainz5.so:audio/libmusicbrainz5
MUSICBRAINZ_CMAKE_ON= -DENABLE_MUSICBRAINZ:BOOL=TRUE
MUSICBRAINZ_CMAKE_OFF= -DENABLE_MUSICBRAINZ:BOOL=FALSE
-MUSICBRAINZ_DESC= Access MusicBrainz database for metadata lookup
-TAGLIB_LIB_DEPENDS= libtag.so:audio/taglib\
+NLS_USE= QT5=linguisttools_build
+NLS_CMAKE_ON= -DLCONVERT_EXECUTABLE:STRING=${QT_BINDIR}/lconvert \
+ -DLRELEASE_EXECUTABLE:STRING=${QT_BINDIR}/lrelease
+NLS_CMAKE_OFF= -DLCONVERT_EXECUTABLE:BOOL=FALSE \
+ -DLRELEASE_EXECUTABLE:BOOL=FALSE
+
+PROXY_CMAKE_ON= -DENABLE_PROXY_CONFIG:BOOL=TRUE
+PROXY_CMAKE_OFF= -DENABLE_PROXY_CONFIG:BOOL=FALSE
+
+QT5_USE= QT5=multimedia
+
+TAGLIB_LIB_DEPENDS= libtag.so:audio/taglib \
libtag-extras.so:audio/taglib-extras
+TAGLIB_USES= localbase
TAGLIB_CMAKE_ON= -DENABLE_TAGLIB_EXTRAS:BOOL=TRUE \
-DENABLE_TAGLIB:BOOL=TRUE
TAGLIB_CMAKE_OFF= -DENABLE_TAGLIB_EXTRAS:BOOL=FALSE \
-DENABLE_TAGLIB:BOOL=FALSE
-TAGLIB_DESC= Reading and editing Meta-Data of audio files
+
+VLC_LIB_DEPENDS= libvlc.so:multimedia/vlc
+VLC_CMAKE_ON= -DENABLE_LIBVLC:BOOL=TRUE
+VLC_CMAKE_OFF= -DENABLE_LIBVLC:BOOL=FALSE
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MTAGLIB} && ( ${PORT_OPTIONS:MFFMPEG} || ${PORT_OPTIONS:MMPG123} )
+.if ${PORT_OPTIONS:MFFMPEG} || ${PORT_OPTIONS:MMPG123}
+LIB_DEPENDS+= libebur128.so:audio/libebur128
PLIST_SUB+= REPLAYGAIN=""
.else
PLIST_SUB+= REPLAYGAIN="@comment "
.endif
+.if ${PORT_OPTIONS:MQT5} || ${PORT_OPTIONS:MVLC}
+CMAKE_ARGS+= -DENABLE_HTTP_STREAM_PLAYBACK:BOOL=TRUE
+.else
+CMAKE_ARGS+= -DENABLE_HTTP_STREAM_PLAYBACK:BOOL=FALSE
+.endif
+
.include <bsd.port.mk>
diff --git a/audio/cantata/distinfo b/audio/cantata/distinfo
index f77825476dda..4bcbbad9ebe5 100644
--- a/audio/cantata/distinfo
+++ b/audio/cantata/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cantata-1.5.1.tar.bz2) = 57173bdd0033a2c0c2829a6e05f7579b0f13ae7794d843167c013e1c971dfe78
-SIZE (cantata-1.5.1.tar.bz2) = 1986772
+TIMESTAMP = 1465799840
+SHA256 (CDrummond-cantata-v2.0.1_GH0.tar.gz) = 294fc96944dd2bb6056525a49ae9db1b1da1b7902ac63286ed6c01622b8e3b52
+SIZE (CDrummond-cantata-v2.0.1_GH0.tar.gz) = 2711833
diff --git a/audio/cantata/files/patch-git_c0a75da b/audio/cantata/files/patch-git_c0a75da
deleted file mode 100644
index e070fd66e456..000000000000
--- a/audio/cantata/files/patch-git_c0a75da
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/cmake/FindTaglib.cmake b/cmake/FindTaglib.cmake
-index 132b311..5d8c3db 100644
---- cmake/FindTaglib.cmake
-+++ cmake/FindTaglib.cmake
-@@ -31,10 +31,10 @@ if(TAGLIBCONFIG_EXECUTABLE)
-
- exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --version RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_VERSION)
-
-- if(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
-+ if(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
- message(STATUS "TagLib version too old: version searched :${TAGLIB_MIN_VERSION}, found ${TAGLIB_VERSION}")
- set(TAGLIB_FOUND FALSE)
-- else(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
-+ else(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
-
- exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --libs RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_LIBRARIES)
-
-@@ -44,7 +44,7 @@ if(TAGLIBCONFIG_EXECUTABLE)
- set(TAGLIB_FOUND TRUE)
- endif(TAGLIB_LIBRARIES AND TAGLIB_CFLAGS)
- string(REGEX REPLACE " *-I" ";" TAGLIB_INCLUDES "${TAGLIB_CFLAGS}")
-- endif(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
-+ endif(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
- mark_as_advanced(TAGLIB_CFLAGS TAGLIB_LIBRARIES TAGLIB_INCLUDES)
-
- else(TAGLIBCONFIG_EXECUTABLE)
diff --git a/audio/cantata/files/patch-replaygain_ffmpeginput.cpp b/audio/cantata/files/patch-replaygain_ffmpeginput.cpp
deleted file mode 100644
index 5648cc8472e3..000000000000
--- a/audio/cantata/files/patch-replaygain_ffmpeginput.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- replaygain/ffmpeginput.cpp.orig 2015-01-21 18:44:15 UTC
-+++ replaygain/ffmpeginput.cpp
-@@ -8,7 +8,6 @@
- */
-
- /* See LICENSE file for copyright and license details. */
--#define _POSIX_C_SOURCE 1
- #ifdef __cplusplus
- #define __STDC_CONSTANT_MACROS
- #ifdef _STDINT_H
diff --git a/audio/cantata/files/patch-replaygain_mpg123input.cpp b/audio/cantata/files/patch-replaygain_mpg123input.cpp
deleted file mode 100644
index b87532e6bd22..000000000000
--- a/audio/cantata/files/patch-replaygain_mpg123input.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- replaygain/mpg123input.cpp.orig 2015-01-21 18:46:32 UTC
-+++ replaygain/mpg123input.cpp
-@@ -8,7 +8,6 @@
- */
-
- /* See LICENSE file for copyright and license details. */
--#define _POSIX_C_SOURCE 1
- #ifdef __cplusplus
- extern "C" {
- #endif
diff --git a/audio/cantata/files/patch-svn-5739-gui__application_qt.cpp b/audio/cantata/files/patch-svn-5739-gui__application_qt.cpp
deleted file mode 100644
index e484d62f8146..000000000000
--- a/audio/cantata/files/patch-svn-5739-gui__application_qt.cpp
+++ /dev/null
@@ -1,39 +0,0 @@
-Look for icons in more than just /usr/share -- upstream svn patch:
-Log message
-
-- When checking for icon themes, also check in $PREFIX
-- Also ensure path is in QIcon's theme path
-
-https://code.google.com/p/cantata/source/detail?r=5740
-
-
-Index: gui/application_qt.cpp
-===================================================================
---- gui/application_qt.cpp (revision 5739)
-+++ gui/application_qt.cpp (working copy)
-@@ -45,11 +45,21 @@
- // or gnome icon themes are installed, and set theme to one of those.
- if (!QIcon::hasThemeIcon("document-save-as")) {
- QStringList themes=QStringList() << QLatin1String("oxygen") << QLatin1String("gnome");
-+ QStringList prefixes=QStringList() << QLatin1String("/usr") << QLatin1String("/usr/local");
-+ if (!prefixes.contains(QLatin1String(INSTALL_PREFIX))) {
-+ prefixes+=QLatin1String(INSTALL_PREFIX);
-+ }
- foreach (const QString &theme, themes) {
-- QString dir(QLatin1String("/usr/share/icons/")+theme);
-- if (QDir(dir).exists()) {
-- QIcon::setThemeName(theme);
-- return;
-+ foreach (const QString &prefix, prefixes) {
-+ QString dir(prefix+QLatin1String("/share/icons/")+theme);
-+ if (QDir(dir).exists()) {
-+ QIcon::setThemeName(theme);
-+ // Add to theme search paths, if it is not there already...
-+ if (!QIcon::themeSearchPaths().contains(prefix+QLatin1String("/share/icons"))) {
-+ QIcon::setThemeSearchPaths(QIcon::themeSearchPaths() << QString(prefix+QLatin1String("/share/icons")));
-+ }
-+ return;
-+ }
- }
- }
- }
diff --git a/audio/cantata/pkg-descr b/audio/cantata/pkg-descr
index 437bc0bef047..d24c2586cebc 100644
--- a/audio/cantata/pkg-descr
+++ b/audio/cantata/pkg-descr
@@ -1,3 +1,23 @@
-Cantata is a graphical client for MPD.
+Cantata is a QT graphical client for MPD with the following features:
+- Multiple MPD collections.
+- Highly customisable layout.
+- Songs grouped by album in play queue.
+- Context view to show artist, album, and song information of current track.
+- Simple tag editor.
+- File organizer - use tags to organize files and folders.
+- Ability to calculate ReplyGain tags.
+- Dynamic playlists.
+- Online services; Jamendo, Magnatune, SoundCloud, and Podcasts.
+- Radio stream support - search for streams via TuneIn, ShoutCast, or Dirble.
+- USB-Mass-Storage and MTP device support.
+- Audio CD ripping and playback.
+- Playback of non-MPD songs - via simple in-built HTTP server if connected
+ to MPD via a standard socket, otherwise filepath is sent to MPD.
+- MPRISv2 DBUS interface.
+- Supports KDE global shortcuts, GNOME media keys, standard media keys via Qxt.
+- Ubuntu/ambiance theme integration - including dragging of window via toolbar.
+- Basic support for touch-style interface (views are made 'flickable')
+- Scrobbling.
+- Ratings support.
-WWW: https://code.google.com/p/cantata/
+WWW: https://github.com/CDrummond/cantata
diff --git a/audio/cantata/pkg-plist b/audio/cantata/pkg-plist
index 765a05c48353..79f0a10182b2 100644
--- a/audio/cantata/pkg-plist
+++ b/audio/cantata/pkg-plist
@@ -2,38 +2,62 @@ bin/cantata
%%REPLAYGAIN%%lib/cantata/cantata-replaygain
%%TAGLIB%%lib/cantata/cantata-tags
share/applications/cantata.desktop
-share/cantata/config/lyrics_providers.xml
-share/cantata/config/podcast_directories.xml
-share/cantata/config/scrobblers.xml
-share/cantata/config/tag_fixes.xml
-share/cantata/config/weblinks.xml
-share/cantata/icons/bbc.svg
-share/cantata/icons/cbc.svg
-share/cantata/icons/npr.svg
-share/cantata/icons/podcasts.png
-share/cantata/icons/soundcloud.png
-share/cantata/icons/stream.png
-share/cantata/mpd/mpd.conf.template
-share/cantata/scripts/cantata-dynamic
-share/cantata/scripts/cantata-remote
-share/cantata/themes/adwaita.css
-share/cantata/themes/ambiance-dt.css
-share/cantata/themes/ambiance.css
-share/cantata/themes/elementary.css
-share/cantata/themes/faience.css
-share/cantata/themes/mint-x.css
-share/cantata/themes/radiance-dt.css
-share/cantata/themes/radiance.css
-share/cantata/translations/cantata_cs.qm
-share/cantata/translations/cantata_de.qm
-share/cantata/translations/cantata_en_GB.qm
-share/cantata/translations/cantata_es.qm
-share/cantata/translations/cantata_fr.qm
-share/cantata/translations/cantata_hu.qm
-share/cantata/translations/cantata_ko.qm
-share/cantata/translations/cantata_pl.qm
-share/cantata/translations/cantata_ru.qm
-share/cantata/translations/cantata_zh_CN.qm
+%%DATADIR%%/config/lyrics_providers.xml
+%%DATADIR%%/config/podcast_directories.xml
+%%DATADIR%%/config/scrobblers.xml
+%%DATADIR%%/config/tag_fixes.xml
+%%DATADIR%%/config/weblinks.xml
+%%DATADIR%%/fonts/fontawesome-4.3.0.ttf
+%%DATADIR%%/icons/bbc.svg
+%%DATADIR%%/icons/cbc.svg
+%%DATADIR%%/icons/npr.svg
+%%DATADIR%%/icons/podcasts.png
+%%DATADIR%%/icons/soundcloud.png
+%%DATADIR%%/icons/stream.png
+%%DATADIR%%/icons/cantata/AUTHORS
+%%DATADIR%%/icons/cantata/LICENSE
+%%DATADIR%%/icons/cantata/index.theme
+%%DATADIR%%/icons/cantata/svg/audio-x-generic.svg
+%%DATADIR%%/icons/cantata/svg/cantata.svg
+%%DATADIR%%/icons/cantata/svg/dynamic-playlist.svg
+%%TAGLIB%%%%DATADIR%%/icons/cantata/svg/drive-removable-media-usb-pendrive.svg
+%%DATADIR%%/icons/cantata/svg/folder-downloads.svg
+%%DATADIR%%/icons/cantata/svg/folder-temp.svg
+%%DATADIR%%/icons/cantata/svg/fork.svg
+%%DATADIR%%/icons/cantata/svg/information.svg
+%%DATADIR%%/icons/cantata/svg/inode-directory.svg
+%%TAGLIB%%%%DATADIR%%/icons/cantata/svg/multimedia-player.svg
+%%DATADIR%%/icons/cantata/svg/network-server-database.svg
+%%DATADIR%%/icons/cantata/svg/playlist.svg
+%%DATADIR%%/icons/cantata/svg/preferences-desktop-keyboard.svg
+%%DATADIR%%/icons/cantata/svg/preferences-other.svg
+%%PROXY%%%%DATADIR%%/icons/cantata/svg/preferences-system-network.svg
+%%DATADIR%%/icons/cantata/svg/speaker.svg
+%%DATADIR%%/icons/cantata/svg64/dialog-error.svg
+%%DATADIR%%/icons/cantata/svg64/dialog-information.svg
+%%DATADIR%%/icons/cantata/svg64/dialog-question.svg
+%%DATADIR%%/icons/cantata/svg64/dialog-warning.svg
+%%DATADIR%%/mpd/mpd.conf.template
+%%DATADIR%%/scripts/cantata-dynamic
+%%DATADIR%%/scripts/cantata-remote
+%%DATADIR%%/themes/adwaita.css
+%%DATADIR%%/themes/ambiance-dt.css
+%%DATADIR%%/themes/ambiance.css
+%%DATADIR%%/themes/elementary.css
+%%DATADIR%%/themes/faience.css
+%%DATADIR%%/themes/mint-x.css
+%%DATADIR%%/themes/radiance-dt.css
+%%DATADIR%%/themes/radiance.css
+%%NLS%%%%DATADIR%%/translations/cantata_cs.qm
+%%NLS%%%%DATADIR%%/translations/cantata_de.qm
+%%NLS%%%%DATADIR%%/translations/cantata_en_GB.qm
+%%NLS%%%%DATADIR%%/translations/cantata_es.qm
+%%NLS%%%%DATADIR%%/translations/cantata_fr.qm
+%%NLS%%%%DATADIR%%/translations/cantata_hu.qm
+%%NLS%%%%DATADIR%%/translations/cantata_ko.qm
+%%NLS%%%%DATADIR%%/translations/cantata_pl.qm
+%%NLS%%%%DATADIR%%/translations/cantata_ru.qm
+%%NLS%%%%DATADIR%%/translations/cantata_zh_CN.qm
share/icons/hicolor/16x16/apps/cantata.png
share/icons/hicolor/22x22/apps/cantata.png
share/icons/hicolor/24x24/apps/cantata.png