aboutsummaryrefslogtreecommitdiff
path: root/audio/cantata
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-29 15:08:14 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-29 15:08:14 +0000
commit7b8d0b35aaa0eb1f34532398fd4a0e041e30320d (patch)
tree109a520492532e2d17c66e15165c512c9fce5c06 /audio/cantata
parentab116c00b50842873b2b8c493e8bf311fca6dfe5 (diff)
downloadports-7b8d0b35aaa0eb1f34532398fd4a0e041e30320d.tar.gz
ports-7b8d0b35aaa0eb1f34532398fd4a0e041e30320d.zip
audio/cantanta update to 2.3.0
Notes
Notes: svn path=/head/; revision=468631
Diffstat (limited to 'audio/cantata')
-rw-r--r--audio/cantata/Makefile6
-rw-r--r--audio/cantata/distinfo6
-rw-r--r--audio/cantata/files/patch-CMakeLists.txt11
-rw-r--r--audio/cantata/files/patch-devices_mounter_CMakeLists.txt11
-rw-r--r--audio/cantata/pkg-plist22
5 files changed, 43 insertions, 13 deletions
diff --git a/audio/cantata/Makefile b/audio/cantata/Makefile
index 80f842463723..a5c61c8484b5 100644
--- a/audio/cantata/Makefile
+++ b/audio/cantata/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= cantata
-DISTVERSION= 2.2.0
+DISTVERSION= 2.3.0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= audio kde
MAINTAINER= kde@FreeBSD.org
@@ -23,7 +22,8 @@ CMAKE_ARGS= -DENABLE_QT5:BOOL=TRUE \
-DCMAKE_DISABLE_FIND_PACKAGE_UDev:BOOL=TRUE
USES= cmake:outsource cpe pkgconfig shebangfix
-SHEBANG_FILES= playlists/cantata-dynamic cantata-remote.cmake
+SHEBANG_FILES= playlists/cantata-dynamic cantata-remote.cmake \
+ devices/mounter/mount.cifs.wrapper
CPE_VENDOR= craig_drummond
USE_LDCONFIG= yes
diff --git a/audio/cantata/distinfo b/audio/cantata/distinfo
index 81e85da959c3..8d6503d6b004 100644
--- a/audio/cantata/distinfo
+++ b/audio/cantata/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1506781584
-SHA256 (CDrummond-cantata-v2.2.0_GH0.tar.gz) = 000f7a8561667fc8d15fad3b8bf0ada8f693a76fed0afafa166a0225cc93e9de
-SIZE (CDrummond-cantata-v2.2.0_GH0.tar.gz) = 2955660
+TIMESTAMP = 1524847557
+SHA256 (CDrummond-cantata-v2.3.0_GH0.tar.gz) = 99d232cb03e4e3ccdba0249c366237218d29fec00abfbbc0c83b4fdb8ceb4d90
+SIZE (CDrummond-cantata-v2.3.0_GH0.tar.gz) = 3998039
diff --git a/audio/cantata/files/patch-CMakeLists.txt b/audio/cantata/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a41231b4d0b1
--- /dev/null
+++ b/audio/cantata/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2018-04-27 18:02:32 UTC
++++ CMakeLists.txt
+@@ -100,7 +100,7 @@ elseif (NOT HAIKU)
+ set(CANTATA_ICON_INSTALL_PREFIX ${SHARE_INSTALL_PREFIX}/icons/hicolor)
+ endif ()
+
+-if (NOT WIN32 AND NOT APPLE AND ENABLE_DEVICES_SUPPORT AND ENABLE_UDISKS2)
++if (LINUX AND ENABLE_DEVICES_SUPPORT AND ENABLE_UDISKS2)
+ set(WITH_SOLID_UDISKS2 ON)
+ endif ()
+
diff --git a/audio/cantata/files/patch-devices_mounter_CMakeLists.txt b/audio/cantata/files/patch-devices_mounter_CMakeLists.txt
new file mode 100644
index 000000000000..61e9b6acdf9e
--- /dev/null
+++ b/audio/cantata/files/patch-devices_mounter_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- devices/mounter/CMakeLists.txt.orig 2018-04-29 14:02:49 UTC
++++ devices/mounter/CMakeLists.txt
+@@ -5,7 +5,7 @@ add_executable( cantata-mounter ${CANTATA_MOUNTER_SRCS
+ install(TARGETS cantata-mounter RUNTIME DESTINATION lib/cantata)
+ configure_file(mpd.cantata.mounter.service.cmake ${CMAKE_CURRENT_BINARY_DIR}/mpd.cantata.mounter.service)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/mpd.cantata.mounter.service DESTINATION ${SHARE_INSTALL_PREFIX}/dbus-1/system-services/ )
+-install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/mpd.cantata.mounter.conf DESTINATION /etc/dbus-1/system.d/ )
++install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/mpd.cantata.mounter.conf DESTINATION ${CMAKE_INSTALL_PREFIX}/etc/dbus-1/system.d/ )
+
+ target_link_libraries(cantata-mounter ${Qt5Core_LIBRARIES} ${Qt5DBus_LIBRARIES})
+ include_directories( ${QTINCLUDES} ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_BINARY_DIR})
diff --git a/audio/cantata/pkg-plist b/audio/cantata/pkg-plist
index 4d41ad0b620b..dc3ed4683755 100644
--- a/audio/cantata/pkg-plist
+++ b/audio/cantata/pkg-plist
@@ -1,4 +1,6 @@
bin/cantata
+%%TAGLIB%%etc/dbus-1/system.d/mpd.cantata.mounter.conf
+%%TAGLIB%%lib/cantata/cantata-mounter
%%REPLAYGAIN%%lib/cantata/cantata-replaygain
%%TAGLIB%%lib/cantata/cantata-tags
share/applications/cantata.desktop
@@ -9,22 +11,20 @@ share/applications/cantata.desktop
%%DATADIR%%/config/weblinks.xml
%%DATADIR%%/fonts/fontawesome-webfont.ttf
%%DATADIR%%/icons/bbc.svg
-%%DATADIR%%/icons/cbc.svg
-%%DATADIR%%/icons/npr.svg
-%%DATADIR%%/icons/podcasts.png
-%%DATADIR%%/icons/soundcloud.png
-%%DATADIR%%/icons/stream.png
+%%DATADIR%%/icons/cantata/128/cantata.png
%%DATADIR%%/icons/cantata/AUTHORS
%%DATADIR%%/icons/cantata/LICENSE
%%DATADIR%%/icons/cantata/index.theme
%%DATADIR%%/icons/cantata/svg/audio-x-generic.svg
%%DATADIR%%/icons/cantata/svg/cantata.svg
%%TAGLIB%%%%DATADIR%%/icons/cantata/svg/drive-removable-media-usb-pendrive.svg
-%%DATADIR%%/icons/cantata/svg/folder-downloads.svg
+%%TAGLIB%%%%DATADIR%%/icons/cantata/svg/folder-network.svg
+%%TAGLIB%%%%DATADIR%%/icons/cantata/svg/folder-samba.svg
%%DATADIR%%/icons/cantata/svg/folder-temp.svg
%%DATADIR%%/icons/cantata/svg/fork.svg
%%DATADIR%%/icons/cantata/svg/information.svg
%%DATADIR%%/icons/cantata/svg/inode-directory.svg
+%%DATADIR%%/icons/cantata/svg/key.svg
%%TAGLIB%%%%DATADIR%%/icons/cantata/svg/multimedia-player.svg
%%DATADIR%%/icons/cantata/svg/network-server-database.svg
%%DATADIR%%/icons/cantata/svg/preferences-desktop-keyboard.svg
@@ -35,11 +35,18 @@ share/applications/cantata.desktop
%%DATADIR%%/icons/cantata/svg64/dialog-information.svg
%%DATADIR%%/icons/cantata/svg64/dialog-question.svg
%%DATADIR%%/icons/cantata/svg64/dialog-warning.svg
+%%DATADIR%%/icons/cbc.svg
+%%DATADIR%%/icons/npr.svg
+%%DATADIR%%/icons/podcasts.png
+%%DATADIR%%/icons/soundcloud.png
+%%DATADIR%%/icons/stream.png
%%DATADIR%%/mpd/mpd.conf.template
%%DATADIR%%/scripts/cantata-dynamic
%%DATADIR%%/scripts/cantata-remote
+%%TAGLIB%%%%DATADIR%%/scripts/mount.cifs.wrapper
%%NLS%%%%DATADIR%%/translations/blank.qm
%%NLS%%%%DATADIR%%/translations/cantata_cs.qm
+%%NLS%%%%DATADIR%%/translations/cantata_da.qm
%%NLS%%%%DATADIR%%/translations/cantata_de.qm
%%NLS%%%%DATADIR%%/translations/cantata_en_GB.qm
%%NLS%%%%DATADIR%%/translations/cantata_es.qm
@@ -51,6 +58,7 @@ share/applications/cantata.desktop
%%NLS%%%%DATADIR%%/translations/cantata_pl.qm
%%NLS%%%%DATADIR%%/translations/cantata_ru.qm
%%NLS%%%%DATADIR%%/translations/cantata_zh_CN.qm
+%%TAGLIB%%share/dbus-1/system-services/mpd.cantata.mounter.service
share/icons/hicolor/128x128/apps/cantata.png
share/icons/hicolor/16x16/apps/cantata.png
share/icons/hicolor/22x22/apps/cantata.png
@@ -60,5 +68,5 @@ share/icons/hicolor/32x32/apps/cantata.png
share/icons/hicolor/48x48/apps/cantata.png
share/icons/hicolor/512x512/apps/cantata.png
share/icons/hicolor/64x64/apps/cantata.png
-share/icons/hicolor/scalable/apps/cantata.svg
share/icons/hicolor/scalable/apps/cantata-symbolic.svg
+share/icons/hicolor/scalable/apps/cantata.svg