aboutsummaryrefslogtreecommitdiff
path: root/audio/carla
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-11-22 20:18:37 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-11-22 20:18:37 +0000
commitcc8a667aa283dbd1c377aa55dd4b47568cebc6b9 (patch)
tree61cb3664013fb792e76869e17b47783aadc54052 /audio/carla
parent9ea8c5a60afa67ef2f40c0e73594522c3aec51a6 (diff)
downloadports-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.tar.gz
ports-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.zip
pyqt: Change install directories for Python flavor support
* PyQt could not be installed for multiple Python versions at the same time, as there were conflicting files. This patch creates Python-version versioned directories for all these, and further installs binaries with a version number. * Note, there might be some hickups for software that depends on on of the .so's provided by PyQt5, which might not be found anymore autmotically, and maybe need some LD-flaggery. * Update PyQt5 to 5.10.1 * Mark www/py-qt5-webengine broken. It is unforuntately no longer compatible with the old qt5-webengine-5.9.4 we ship. PR: 232745 Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D8714
Notes
Notes: svn path=/head/; revision=485614
Diffstat (limited to 'audio/carla')
-rw-r--r--audio/carla/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/carla/Makefile b/audio/carla/Makefile
index 2ba03e638ec8..592a7b4661d5 100644
--- a/audio/carla/Makefile
+++ b/audio/carla/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Carla
DISTVERSIONPREFIX= v
DISTVERSION= 1.9.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
@@ -30,7 +30,10 @@ USE_LDCONFIG= ${PREFIX}/lib/carla
SHEBANG_FILES= data/carla-single source/native-plugins/resources/*
MAKE_ARGS= HAVE_QT4=false \
- EXTERNAL_PLUGINS=false
+ EXTERNAL_PLUGINS=false \
+# Give the Makefile the proper versioned binaries of PyQt
+BINARY_ALIAS= pyuic5=${LOCALBASE}/bin/pyuic5-${PYTHON_VER} \
+ pyrcc5=${LOCALBASE}/bin/pyrcc5-${PYTHON_VER}
OPTIONS_DEFINE= FFMPEG FLUIDSYNTH LINUXSAMPLER
OPTIONS_DEFAULT= FFMPEG FLUIDSYNTH JACK LINUXSAMPLER