aboutsummaryrefslogtreecommitdiff
path: root/audio/ccaudio2
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2006-01-19 23:42:10 +0000
committerKris Kennaway <kris@FreeBSD.org>2006-01-19 23:42:10 +0000
commit48e1fdb6019556ec13589cd51919ac1a3a97c00d (patch)
tree53a7790b7656d026d5d5706241c2ee798f525ad7 /audio/ccaudio2
parente3df59997f7e2efcedc9ee963d12c05d0560ad52 (diff)
downloadports-48e1fdb6019556ec13589cd51919ac1a3a97c00d.tar.gz
ports-48e1fdb6019556ec13589cd51919ac1a3a97c00d.zip
BROKEN: Build fails on amd64 (missing -fPIC on shared libraries)
Notes
Notes: svn path=/head/; revision=153918
Diffstat (limited to 'audio/ccaudio2')
-rw-r--r--audio/ccaudio2/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/ccaudio2/Makefile b/audio/ccaudio2/Makefile
index cccbb55c8adf..e54d85bf5021 100644
--- a/audio/ccaudio2/Makefile
+++ b/audio/ccaudio2/Makefile
@@ -27,6 +27,12 @@ MAN3= Audio.3cc AudioCodec.3cc AudioCopy.3cc AudioFile.3cc \
AudioSample.3cc AudioTone.3cc CDAudio.3cc DTMFDetect.3cc \
LinearSample.3cc
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not build on amd64 (shared libraries must be compiled with -fPIC)"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|<stdint\.h>|<stdlib.h>|g' ${WRKSRC}/src/dtmf.cpp
@@ -34,4 +40,4 @@ post-patch:
pre-configure:
@${CP} ${LTMAIN} ${WRKSRC}/config
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>